
(i)

COMPUTER OPERATOR AND
PROGRAMMING ASSISTANT

NSQF LEVEL - 4

Volume II of II

TRADE PRACTICAL

SECTOR: IT & ITES

DIRECTORATE GENERAL OF TRAINING
MINISTRY OF SKILL DEVELOPMENT & ENTREPRENEURSHIP

GOVERNMENT OF INDIA

 NATIONAL INSTRUCTIONAL
MEDIA INSTITUTE, CHENNAI

Post Box No. 3142, CTI Campus, Guindy, Chennai - 600 032



(ii)

Sector : IT & ITES
Duration : 1 - Year
Trade : Computer Opeartor and Programming Assistant Vol II of II - Trade Practical -

NSQF (LEVEL - 4)

Developed & Published by

National Instructional Media Institute
Post Box No.3142
Guindy, Chennai - 600 032
INDIA
Email: chennai-nimi@nic.in
Website: www.nimi.gov.in

Copyright 2018 National Instructional Media Institute, Chennai

First Edition : August 2018  Copies : 1,000
First Reprint : September 2019  Copies :    500
Second Reprint : August 2021  Copies : 1,000

Rs.305/-



(iii)

FOREWORD

The Government of India has set an ambitious target of imparting skills to 30 crores people, one out of every
four Indians, by 2020 to help them secure jobs as part of the National Skills Development Policy. Industrial
Training Institutes (ITIs) play a vital role in this process especially in terms of providing skilled manpower.
Keeping this in mind, and for providing the current industry relevant skill training to Trainees, ITI syllabus
has been recently updated with the help of Mentor Councils comprising various stakeholder's viz. Industries,
Entrepreneurs, Academicians and representatives from ITIs.

The National Instructional Media Institute (NIMI), Chennai, an autonomous body under Ministry of Skill
Development & Entrepreneurship is entrusted with developing producing and disseminating Instructional
Media Packages (IMPs) required for ITIs and other related institutions.

The institute has now come up with instructional material to suit the revised curriculum for COPA -
Vol II of II Trade Practical NSQF (LEVEL - 4) in IT & ITES Sector under yearly Pattern. The NSQF
(LEVEL - 4) Trade Practical will help the trainees to get an international equivalency standard where their
skill proficiency and competency will be duly recognized across the globe and this will also increase the
scope of recognition of prior learning. NSQF (LEVEL - 4) trainees will also get the opportunities to promote
life long learning and skill development. I have no doubt that with NSQF (LEVEL - 4)  the trainers and
trainees of ITIs, and all stakeholders will derive maximum benefits from these IMPs and that NIMI's effort will
go a long way in improving the quality of Vocational training in the country.

The Executive Director & Staff of NIMI and members of Media Development Committee deserve appreciation
for their contribution in bringing out this publication.

Jai Hind

     RAJESH AGGARWAL
Director General/Addl. Secretary

Ministry of Skill Development & Entrepreneurship,
Government of India.

         New Delhi - 110 001
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PREFACE

The National Instructional Media Institute (NIMI) was established in 1986 at Chennai by then Directorate
General of Employment and Training (D.G.E & T), Ministry of Labour and Employment, (now under Ministry
of Skill Development and Entrepreneurship) Government of India, with technical assistance from the Govt.
of the Federal Republic of Germany. The prime objective of this institute is to develop and provide instructional
materials for various trades as per the prescribed syllabi (NSQF) under the Craftsman and Apprenticeship
Training Schemes.

The instructional materials are created keeping in mind, the main objective of Vocational Training under
NCVT/NAC in India, which is to help an individual to master skills to do a job. The instructional materials are
generated in the form of Instructional Media Packages (IMPs). An IMP consists of Theory book, Practical
book, Test and Assignment book, Instructor Guide, Audio Visual Aid (Wall charts and Transparencies) and
other support materials.

The trade practical book consists of series of exercises to be completed by the trainees in the workshop.
These exercises are designed to ensure that all the skills in the prescribed syllabus are covered. The trade
theory book provides related theoretical knowledge required to enable the trainee to do a job. The test and
assignments will enable the instructor to give assignments for the evaluation of the performance of a trainee.
The wall charts and transparencies are unique, as they not only help the instructor to effectively present a
topic but also help him to assess the trainee's understanding. The instructor guide enables the instructor to
plan his schedule of instruction, plan the raw material requirements, day to day lessons and demonstrations.

In order to perform the skills in a productive manner instructional videos are embedded in QR code of the
exercise in this instructional material so as to integrate the skill learning with the procedural practical steps
given in the exercise. The instructional videos will improve the quality of standard on practical training and
will motivate the trainees to focus and perform the skill seamlessly.

IMPs also deals with the complex skills required to be developed for effective team work. Necessary care
has also been taken to include important skill areas of allied trades as prescribed in the syllabus.

The availability of a complete Instructional Media Package in an institute helps both the trainer and
management to impart effective training.

The IMPs are the outcome of collective efforts of the staff members of NIMI and the members of the Media
Development Committees specially drawn from Public and Private sector industries, various training institutes
under the Directorate General of Training (DGT), Government and Private ITIs.

NIMI would like to take this opportunity to convey sincere thanks to the Directors of Employment & Training
of various State Governments, Training Departments of Industries both in the Public and Private sectors,
Officers of DGT and DGT field institutes, proof readers, individual media developers and coordinators, but for
whose active support NIMI would not have been able to bring out this materials.

R. P. DHINGRA
Chennai - 600 032      EXECUTIVE DIRECTOR
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INTRODUCTION

TRADE PRACTICAL

The trade practical manual is intented to be used in workshop . It consists of a series of practical exercises to be
completed by the trainees during the Volume II of II course of the COPA trade supplemented and supported by
instructions/ informations to assist in performing the exercises. These exercises are designed to ensure that all
the skills in the prescribed syllabus are covered.

The manual is divided into twelve modules to maintain completancy of leaning process in a stipulated time basis.

The skill training in the computer lab is planned through a series of practical exercises centred around some practical
project. However, there are few instance where the individual exercise does not form a part of project.

While developing the practical manual a sincere effort was made to prepare each exercise which will be easy to
understand and carry out even by below average traninee. However the development team accept that there if a scope
for further improvement. NIMI, looks forward to the suggestions from the experienced training faculty for improving
the manual.

TRADE THEORY

The manual of trade theory consists of theorectical information for the Volume II of II  course of the COPA Trade.
The contents are sequenced accoring to the practical exercise contained in the manual on Trade practical. Attempt
has been made to relate the theortical aspects with the skill covered in each exercise to the extent possible. This
co-relation is maintained to help the trainees to develop the perceptional capabilities for performing the skills.

The Trade Theory has to be taught and learnt along with the corresponding exercise contained in the manual on
trade practical. The indicating about the corresponding practical exercise are given in every sheet of this manual.

It will be preferable to teach/learn the trade theory connected to each exercise atleast one class before performing
the related skills in the system lab. The trade theory is to be treated as an integrated part of each exercise.

The material is not the purpose of self learning and should be considered as supplementary to class room
instruction.
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Outcome

Professional Skills
(Trade Practical)
With indicative hours

Professional Knowledge
(Trade Theory)
Introduction to JavaScript

Develop web
pages using
JavaScript.

JavaScript & creating Web page
94. Practice with basic elements of

JavaScript. (12 Hrs)
95. Embed JavaScript in HTML to

display information in web
pages, documentation and
formatting of HTML source
code. (18 Hrs)

96. Use JavaScript Variables, Data
types, Constants and
Operators. (18 Hrs)

97. Use Control statements and
Loops in JavaScript. (18 Hrs)

98. Practice with switch case, loop
controls and Errors in
JavaScript. (18 Hrs)

99. Practice with Arrays in
JavaScript page. (12 Hrs)

100.Practice with functions in
JavaScript web page. (18 Hrs)

101. Practice with String, Math and
Date functions in JavaScript.
(24 Hrs)

102. Use online tool or open
source software to develop and
edit web pages containing
Titles, different font sizes and
colours, frames, lists, tables,
images, image map, controls,
CSS, forms, hyperlinks etc., use
web template to create a
web page of various styles. (36
Hrs)

103. Develop a simple web project
using HTML, JavaScript and host
it in IIS and a registered domain.
(36 Hrs)

• Introduction to Programming
and Scripting Languages.

• Introduction to JavaScript
and its application for the web.

• Introduction to Web
Servers and their features.

• JavaScript Basics – Data
types, Variables, Constants
and Conversion between
data types.

• Arithmetic, Comparison,
Logical Operators in
JavaScript. Operator
precedence.

• Program Control
Statements and loops in
JavaScript.

• Arrays in JavaScript –
concepts, types and usage.

• The String data type in
JavaScript. Introduction to
String, Math and Date.

• Introduction to Functions
in JavaScript.

• Built in JavaScript functions
overview.

• Concepts of Pop Up boxes
in JavaScript.

• Introduction to the
Document Object Model.

• Concepts of using
Animation and multimedia
files in Java Script.

Develop
simple spread
sheets by
embedding
VBA.

Programming with VBA
104. Practice with basic functions of VBA

Editor. (3 Hrs)
105. Use form controls like buttons,

Check boxes, Labels, Combo Box,
Group Box, List Box, Option Button,
Scroll Bar and Spin button. (12 Hrs)

106.Modify object properties in V B A
program. (6 Hrs)

107. Write simple programs involving VBA
Data types, Variables, Operators and
Constants. (18 Hrs)

108.Create Message boxes and I n p u t

Introduction to VBA, Features
and Applications.
•  Introduction to VBA features and

applications.
•  Properties, events and methods

associated with the Button,
Check Box, Label, Combo Box,
Group Box, Option Button, List
Box, Scroll Bar and Spin button
controls.

• VBA Data types, Variables
and Constants.

27 - 33

34 - 41
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boxes in VBA. (6 Hrs)
109. Work with conditional

statements like if, Else-if, and
Select. (12 Hrs)

110. Practice with Loop, Loop Control
and Case statements in VBA. (15
Hrs)

111. Create and Manipulate Arrays in
VBA. (12 Hrs)

112. Practice with string variables in
VBA programming. (12 Hrs)

113. Write programs involving
Mathematical, Conversion, Date
and String Functions in VBA. (18
Hrs)

114. Create Functions, Procedures,
Passing Parameters and Using
Returned Data. (12 Hrs)

115. Practice with built in functions in
VBA programs. (12 Hrs)

116. Create and edit macros.
(12 Hrs)

117. Write code to work with Excel
in VBA forms. (12 Hrs)

118. Practice with methods and
events in VBA Programming.
(24 Hrs)

119. Debug, Step through code,
Breakpoints, find and fix errors
while debugging. (18 Hrs)

120. Develop a simple project
involving MS excel and VBA.
(36 Hrs)

• Operators in VBA and operator
precedence.

• Mathematical Expressions
in VBA.

• Introduction to Arrays in
VBA.

• Introduction to Strings in
VBA.

• Conditional processing in
VBA, using the IF, Else-if,
Select Case Statements.

• Introduction to Loops in
VBA.

• VBA message boxes and
input boxes.

• Introduction to Creating
functions and Procedures
in VBA.

• Using the built in
functions.

• Introduction to Object
Oriented Programming
Concepts. Concepts of
Classes, Objects,
Properties and Methods.

• The user forms and
control in Excel VBA.

• Introduction to Debugging
Techniques.

Maintain
accounts using
accounting
software.

42 - 45 Using Accounting Software
121. Practice Basic accounting with

 tally interface. (12 Hrs)
122. Create Company, Account and

 Voucher entry in Tally. (12 Hrs)
123. Generate reports for Invoice, Bill,

 Profit & Loss account etc. (10 Hrs)
124. Perform Cost Centre & Cost

 Category management. (12 Hrs)
125. Create and manage budgeting

 systems. (12 Hrs)
126. Create Scenario and Variance

  Analysis. (8 Hrs)
127. Use Tally for Costing, Ratio

 Analysis, Cash flow and Funds
 flow statements. (12 Hrs)

128. Analyze and Manage Inventory
 control. (10 Hrs)

129. Perform Point of Sales and
 Taxation (VAT, Excise, Service
 Tax). (8 Hrs)

130. Perform System Administration
 and use other Utilities. (8 Hrs)

131. Create users, take Backup &

Using Accounting Software
• Basics of Accounting,

Golden Rules of
Accounting, Voucher
Entry, Ledger Posting,
Final Accounts
Preparation.

• Cash Book. Ratio Analysis,
Depreciation, Stock
Management.

• Analysis of VAT, Cash
Flow, Fund Flow
Accounting.

• Introduction to Tally,
features and Advantages.

• Implementing accounts in
Tally.

• Double entry system of
book keeping.

• Budgeting Systems,
Scenario management
and Variance Analysis.

                   COPA 



Browse, select
and transact
using Ecommerce
websites
Secure
information
from Internet
by using cyber
security
concept.

E Commerce Concepts
• Introduction to ECommerce

advantages.
• Building business on

the net.
• Payment and Order

Processing,
Authorization,
Chargeback and other
payment methods.

• Security issues and
payment gateways. and

46

47

 Restore of Company. (8 Hrs)
132. Use Multilingual Functionality in

Tally. (8 Hrs)

E Commerce
133. Browse E-commerce websites viz.

ebay, Amazon, flipkart, OLX, quikr
etc. and prepare comparative
statement of the main features of
these sites. (8 Hrs)

134.Upload products for selling in
ECommerce Sites and make online
purchase from E Commerce
sites.(14 Hrs)

135. Manage security issues in
ECommerce and payment
operations. (8 Hrs)

Cyber Security:
• Overview of Information

Security, SSL, HTTPS,
Security threats,
information Security
vulnerability and Risk
management.

• Introduction to Directory
Services, Access Control,
Security, Privacy
protection, Audit and
Security.

• Introduction to IT Act and
penalties for cyber
crimes.

48 - 49

50-51

52

Cyber Security:
136. Protect information, computers

and networks from viruses,
spyware and other malicious
code. (3 Hrs)

137. Provide firewall security for
Internet connection and
Network System. (6 Hrs)

138. Protect the computer against
 various internet threats. (3 Hrs)

139.Make backup copies of
important  file, data and
information. (3 Hrs)

140. Secure your Wi-Fi networks
 using password, WEP, WPA-
PSK, WPA2-PSK, SSID, MAC
address filtering. Create
individual user accounts for
each member. (9 Hrs)

141. Limit member access to data
and information, and restrict
authority to install unnecessary
downloads. (6 Hrs)

Industrial Visit/Project work (1. Create and host a web site of atleast 6 web pages using
JavaScript containing interactive objects, functions etc. OR
2. Create a project with Excel & VBA on Payroll Systems. OR
3. Create a company in Tally and post vouchers in it for a financial period. Vouchers should
contain purchase, sales with VAT, contra, payment , receipts, cost centre cost category etc.)

Revision

Examination
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IT & ITES                                                                                          Exercise 2.1.94
COPA - JavaScript & Creating Web page

Practice with Basic Elements of JavaScript
Objectives: At the end of this exercise you shall be able to
• create javascript code in the <Head > section of HTML page
• create javascript code in the <Body > section of HTML page
• create javascript code in the <Head > and <Body> section of HTML page
• create and run sample JavaScript code.

PROCEDURE

TASK 1 : Create Javasscript code in the <Head > section of HTML page

Note to instructor : To run JavaScript, any modern browser should be installed as all modern browser
can run JavaScript by default.

1 Open Notepad.

2 Type the following code.

<html>

<head>

<script>

function myFunction() {

document.write("hello");

document.write(" world");

}

</script>

</head>

<body>

<h1>My Web Page</h1>

<button type="button" onclick="myFunction()">Try
it</button>

</body>

</html>

3  Click Save.

4  Type filename as page1.html.

5  Select file type as All Files.

6  Select destination in Desktop or any other location.
Click Save.

7   Close Notepad.

8   Now go to the file destination.

9   Double Click it to run.

10  Browser can show you a warning. (Fig 1)

11  If warning is shown, click yellow warning bar.

12  Select Allow Blocked Content.

13  A security warning can be shown (Fig 2).

14  Click yes.

15 Now click "Try it" to run the javascript code in the
page.

16 Hello World would be shown as output. (Fig 3).

Fig 1 

Fig 2

Fig 3
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TASK 2 : Create Javasscript code in the <Body > section of HTML page

1 Write and save following code and save with
access.html.

<html>

<body>

<p id="p1">Hello World!</p>

<script>

TASK 3: Create JavaScript code in the <Head>  and <Body> section of an HTML page.

IT & ITES : COPA - (NSQF- 4) Exercise 2.1.94

document.getElementById("p1").innerHTML = "New
text!";

</script>

</body>

</html>

2 Run it by double clicking this file name.

3 It will show the following output.

New text!

1 Create and run the following JavaScript code.

<!DOCTYPE html>

<head>

<title> Script in head and body section </title>

<script type = “text/javascript”>

document.writeln(“Good Morning”);

</script>

</head>

<body>

<script type = “text/javascript”>

alert(“Good Evening”);

</script>

</body>

</html>

2 Run the code and check the output.

TASK 4: Create and run sample JavaScript code.

1 Create and run the following JavaScript code.

<!DOCTYPE html>

<html>

<body>

<h1 id="header">Old Header</h1>

<script>

var element = document.getElementById("header");

element.innerHTML = "New Header";

</script>

</body>

</html>

2 Create and run the following JavaScript code.

<!DOCTYPE html>

<html>

<body>

<img id="myImage" src="smiley.gif">

<script>

document.getElementById("myImage").src=
"landscape.jpg";

</script>

</body>

</html>

3 Change the Value of an Attribute

To change the value of an HTML attribute, use this
syntax:

document.getElementById(id).attribute=new value
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IT & ITES                                                                                             Exercise 2.1.95A
COPA - JavaScript & Creating Web page

Embed JavaScript in HTML to Display Information in Web pages
Objectives: At the end of this exercise you shall be able to
• use external javascript files in HTML
• display information with javascript.

PROCEDURE

TASK 1 : Using external JavaScript files in HTML

1 Open Notepad.

2 Type the following code.

function myFunction() {

document.write("hello");

document.write(" world");

}

3 Click Save.

4 Type filename as myscript.js.

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Open Notepad again.

9 Type the following code. (Fig 2)

<html>

<head>

<script type="text/javascript" src=" myscript.js"> </
script>

</head>

<body>

<h1>My Web Page</h1>

<button type="button" onclick="myFunction()">Try
it</button>

</body>

</html>

10 Click Save.

11 Type filename as js2102.html

12 Select file type as All Files.

13 Select destination in Desktop or any other location.
Click Save.

14 Close Notepad.

15 Now go to the file destination.

16 Double Click it to run.

17 See the output as shown in Fig 1 & Fig 2.

Fig 1

Fig 2
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TASK 2 : Display information with JavaScript

1 Write the code and save it with jc21021.html.

<html>

<head>

<title>A Web page</title>

<script type="text/javascript">

function anotherAlert(textAlert) {

alert(textAlert);

}

anotherAlert("This is a alert");

</script>

<body>

<h1>Web Page with Alert</h1>

</body>

</html>

2 Run the code and see the output.(Fig 3)

Fig 3
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PROCEDURE

TASK 1: Document the source code

IT & ITES                                                                                         Exercise 2.1.95B
COPA - JavaScript & Creating Web page

Practice on Documentation and Formatting of HTML Source Code

Objectives: At the end of this exercise you shall be able to
• document the source code
• format the text in a web page

1 Open Notepad

2 Type the following code

<html>

<body>

<script type=”text/javascript”>

/**

* @ formatting source code the following
program is using

 * @author nimi chennai

 */

var str = “Learn JavaScript with easy examples!”;

//  Following displaying original text.

document.write (“Original text: “ + str);

// Following displaying bold text.

document.write (“<br>Changed to bold: “ + str.bold());

// Following displaying italics text.

document.write (“<br>Changed to italics: “ +
str.italics());

</script>

</body>

</html>

3 Click Save

4 Type filename as Documentsource.html

5 Select file type as All Files.

6 Select desktop or any other location. Click Save

7 Close Notepad

8 Now run the html file to see the result (Fig.1)

Fig 1
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IT & ITES                                                                                        Exercise 2.1.96A
COPA - JavaScript & Creating Web page

Work with JavaScript Variables and Data types
Objectives: At the end of this exercise you shall be able to
• create variables
• use objects
• use string data type
• use arrays.

PROCEDURE

TASK 1 : Create variables

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Addition of Hexadecimal Numbers</title>

<script>

var a=0xe;

var b=0x2;

var c=a+b;

alert(c);

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as var.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 1)

TASK 2 : Use Objects

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Objects</title>

<script>

var pi=Math.PI;

alert(pi);

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as ob1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 2)

Fig 1
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TASK 3: Use string data type

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Strings</title>

<script>

var st1="Hello\t\tWorld\n\tGood Bye";

alert(st1);

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as str.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 3)

TASK 4 : Use arrays

1 Open Notepad.

2 Type the following code.

<html>
<head>
<title>Arrays</title>
<script>
var stu=new Array("Lipika","Soma","kajal");
alert("Students are: "+stu[0]+", "+stu[1]+" and
"+stu[2]);
</script>
</head>
<body>
</body>
</html>

3 Click Save.

4 Type filename as arr1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 4)
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Fig 4
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IT & ITES                                                                                          Exercise 2.1.96B
COPA - JavaScript & Creating Web pages

Work with JavaScript Constants and Operators
Objectives: At the end of this exercise you shall be able to
• add two values using additive operator
• add one string and one number
• multiply using left shift operator
• use equality operator to check equality of two expressions.
• use const keyword
• check the behaviour of const keyword.

PROCEDURE

TASK 1 : Add two values using additive operator

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Additive Operator</title>

<script>

var no1=56;

var no2=28;

var res=no1+no2;

alert("Result="+res);

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as add1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (See Fig 1)

The same way as above subtraction(-),
Multiplication(*), Division(/) and Modulo(%) can
be used.

TASK 2: Add one string and one number
1 Open Notepad.

2 Type the following code. (See fig 3)

<html>

<head>

<title>String Add</title>

<script>

var a=847;

var b="567";

var r=a+b;

alert("Result is:"+r);

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as add2.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

Fig 1
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7 Close Notepad.

8 Now run the html file to see the result. (Fig 2)

TASK 3 : Multiply by 4 using left shift operator

3 Click Save.

4 Type filename as lftsft.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 3)

TASK 4: Use Equality Operator to check equality of two expressions

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Eqality</title>

<script>

var a=847;

var b="847";

if(a==b)

alert("Values are same");

else

alert("Values are not same");

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as equal1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 4)

IT & ITES : COPA - (NSQF- 4) Exercise 2.1.96B

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>String Length</title>

<script>

var a=847;

a=a<<2;

alert("Result is:"+a);

</script>

</head>

<body>

</body>

</html>

Fig 2

Fig 3
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Though the Datatype is not same, then also ==
operator just checks the value and returns true.
But if === operator is used in place of ==
operator, result would be not equal as it not
only checks for value but also checks for
equality of datatypes.

As the same as above, not equality operator
(!= and !==) also has same effect. First one do
not check for datatype and second one checks
it.
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TASK 5 :  Use const keyword

1 Open Notepad

2 Type the following code

<!DOCTYPE html>

<html>

<body>

<h2>JavaScript const Keyword</h2>

<script>

const  A=10;

document.write(A+100);

 </script>

</body>

</html>

3  Save the file

4 Type file name as constant1.html

5 Select file type as All files

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad

8 Now run the html file to see the result. (Fig.5)

TASK 6 :  Check the behaviour of const keyword.

1 Open Notepad

2 Type the following code

<!DOCTYPE html>

<html>

<body>

<h1>JavaScript const Keyword</h1>

<h3>You cannot change a primitive value.</h3>

<p id=”cons”></p>

<script>

try {

    const PI = 3.141592653589793;

    PI = 3.14;

}

catch (err) {

    document.getElementById(“cons”).innerHTML =
err;

}

</script>

</body>

</html>

3 Save the file

4 Type file name as constant2.html

5 Select file type as All files

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad

8 Now run the html file to see the result. (Fig.6)

Fig 5

Fig 4
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IT & ITES                                                                                         Exercise 2.1.97A
COPA - JavaScript & Creating Web pages

Work with Control statements in JavaScript
Objectives: At the end of this exercise you shall be able to
• display whether a number is even or odd
• display whether a year is leap year or not
• display the biggest number among three numbers
• calculate like a calculator.

PROCEDURE

TASK 1 : Program to display whether a number is even or odd

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Even Odd</title>

<script>

var a=84;

if(a%2==0)

alert("Even Number");

else

alert("Odd Number");

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as eo1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 1)

TASK 2: Program to display whether a year is leap year or not

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Leap Year</title>

<script>

var yr=1984;

if(yr%100==0)

if(yr%400==0)

alert("Leap Year");

else

alert("Not Leap Year");

else

if(yr%4==0)

alert("Leap Year");

else

alert("Not Leap Year");

</script>

</head>

<body>

</body>

</html>

Fig 1
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3 Click Save.

4 Type filename as ly1.html

5  Select file type as All Files.

6  Select destination in Desktop or any other location.
Click Save.

7  Close Notepad.

8  Now run the html file to see the result. (Fig 2)

TASK 3: Program to display the biggest number among three numbers

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Eqality</title>

<script>

var a=847;

var b=567;

var c=287;

if(a>b)

if(a>c)

alert(a);

else

alert(c);

else

if(b>c)

alert(b);

else

alert(c);

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as check1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 3)
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TASK 4: Program to calculate like a calculator

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>CALCULATOR</title>

<script>

var a=45;

var b=0;

var ch=4;

var r=0;

switch(ch)

{

case 1:

r=a+b;

break;

case 2:

r=a-b;

break;

case 3:

r=a*b;

break;

case 4:

r=a/b;

break;

default:

alert("Not correct option");

}

alert("The result is:"+r);

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as cal1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 4)
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IT & ITES                                                                                         Exercise 2.1.97B
COPA - JavaScript & Creating Web pages

Work with Looping statements  in JavaScript
Objectives: At the end of this exercise you shall be able to
• display loop counter value 4 times using while loop, for loop and do while loop
• display properties of an object by for in loop
• display a pattern using for loop
• display the summation of series of natural number s = 1+2+3+ .......upto Nth term
• display whether a number is palindrome or not
• display whether a number is prime or not.

PROCEDURE

TASK 1 : Display loop counter value 4 times using while loop, for loop and do while loop

1 Open Notepad.

2 Type the following code.

<html>
<head>
<title>Loop</title>
<script>
var i=0;
while (i<4) {
document.write("Counter Value in While Loop is
"+i+"<br>");
i++;
}
i=0;
do {
document.write("Counter Value in Do While Loop is
"+i+"<br>");
i++;
}while(i<4);
for(i=0;i<4;i++) {
document.write("Counter Value in For Loop is
"+i+"<br>");
}
</script>
</head>
<body>
</body>
</html>

3  Click Save.

4  Type filename as loop1.html

5  Select file type as All Files.

6  Select destination in Desktop or any other location.
Click Save.

7  Close Notepad.

8  Now run the html file to see the result. (Fig 1)

TASK 2: Display properties of an object by for in loop

1 Open Notepad. 2 Type the following code.

Fig 1
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<html>

<head>

<title>Loop for in</title>

<script>

var star=new Object;

star.name="Polaris";

star.type="Double/Cepheid";

star.constellation="Ursa Minor";

for(var starProp in star)

document.write(starProp+" = "+star[starProp]+"<br>");

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as lp2.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 2)

TASK 3: Display a pattern using for loop

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Pattern</title>

<script>

var l=4;

var i,j;

for(i=1;i<=l;i++) {

for(j=1;j<=i;j++)

document.write("*");

document.write("<br>");

}

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as patt1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 3)
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TASK 4  Display the summation of series of natural number s = 1+2+3+...... upto Nth term

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Series</title>

<script>

function series() {

var i=document.getElementById("val").value;

var s=0,j;

for(j=1;j<=i;j++)

s+=j;

document.write("Result of Sum of natural
numbers:"+s);

}

</script>

</head>

<body>

<form name="form1" id="form1" action="#">

Enter Value: <input id="val" name="val" type="text">

<input id="submit" type="submit" onclick="series()">

</form>

</body>

</html>

3 Click Save.

4 Type filename as loop4.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 4 &
Fig 5)

TASK 5 : Display whether a number is palindrome or not.

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Palindrome Number</title>

<script>

function series() {

var i=document.getElementById("val").value;

var s=0,j,t1,t2,t=i,k;

while(t!=0) {

k=t%10;

s=(s*10)+k;

t=Math.floor(t/10);

}

if(s==i)

document.write("Palindrome Number");

else

document.write("Not Palindrome Number");

}

</script>

</head>

<body>

<form name="form1" id="form1" action="#">

Enter Value: <input id="val" name="val" type="text">

<input id="submit" type="submit" onclick="series()">

</form>

</body>

</html>
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3 Click Save.

4 Type filename as palin1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 6 & Fig 7)

TASK 6  :  Display whether a number is prime or not

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Prime No</title>

<script>

function prime() {

var i=document.getElementById("val").value;

var f=0,j=1;

while(j<=i) {

if(i%j==0)

f++;

j++;

}

if(f==2)

document.write("Prime Number");

else

document.write("Not Prime Number");

}

</script>

</head>

<body>

<form name="form1" id="form1" action="#">

Enter Value: <input id="val" name="val" type="text">

<input id="submit" type="submit" onclick="prime()">

</form>

</body>

</html>

3 Click Save.

4 Type filename as prime4.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 8 &
Fig 9)

IT & ITES : COPA - (NSQF- 4) Exercise 2.1.97B

Fig 7
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IT & ITES                                                                                          Exercise 2.1.98A
COPA - JavaScript & Creating Web pages

Practice on Error Handling  in JavaScript
Objectives: At the end of this exercise you shall be able to
• use try-catch in JavaScript
• use finally in JavaScript
• use throw in JavaScript
• use onerror() method  in JavaScript.
PROCEDURE

TASK 1: Use try-catch in javascript

1 Open Notepad

2 Type the following code

<html>

<head>

<script type=”text/javascript”>

 function myFunc()

{

var a = 100;

try {

alert(“Value of variable a is : “ + a );

 }

catch ( e ) {

alert(“Error: “ + e.description );

}

}

</script>

</head>

<body>

<p>Click the following to see the result:</p>

<form>

<input type=”button” value=”Click Me”
onclick=”myFunc();” />

</form>

</body>

</html>

3 Click Save

4 Type filename as ErrorHandling1.html

5 Select file type as All Files.

6 Select desktop or any other location. Click Save

7 Close Notepad

8 Now run the html file to see the result(fig-1)

9 Click the Click Me button( fig-2)

 Fig 1
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TASK 2: Use finally in javascript

1 Open Notepad

2 Type the following code

<html>

<head>

<script type=”text/javascript”>

function myFunc()

{

var a = 100;

try {

alert(“Value of variable a is : “ + a );

}

 catch ( e ) {

alert(“Error: “ + e.description );

}

finally {

alert(“Finally block will always execute!” );

}

}

</script>

</head>

<body>

<p>Click the following to see the result:</p>

<form>

<input type=”button” value=”Click Me”
onclick=”myFunc();” />

</form>

</body>

 </html>

3 Click Save

4 Type filename as ErrorHandling2.html

5 Select file type as All Files.

6 Select desktop or any other location. Click Save

7 Close Notepad

8 Now run the html file to see the result (Fig-3)

9 Click on Click Me button (Fig-4)

TASK 3: Use throw in javascript

1 Open Notepad 2 Type the following code
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</script>

</head>

<body>

<p>Click the following to see the result:</p>

<form>

<input type=”button” value=”Click Me”
onclick=”myFunc();” />

</form>

</body>

</html>

3  Click Save

4 Type filename as ErrorHandling3.html

5 Select file type as All Files.

6 Select desktop or any other location. Click Save

7 Close Notepad

8 Now run the html file to see the result (Fig-5)

9 Click the Click Me button (Fig-6)

<html>

<head>

<script type=”text/javascript”>

  function myFunc()

{

var a = 100;

var b = 0;

try{

if ( b == 0 )

{

throw( “Divide by zero error.” );

}

else

{

 var c = a / b;

}

}

catch ( e ) {

alert(“Error: “ + e );

}

}
Fig 5
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TASK 4: Use onerror() Method  in javascript

1 Open Notepad

2 Type the following code

<html>

 <head>

 <script type=”text/javascript”>

  window.onerror = function () {

alert(“An error occurred.”);

}

</script>

</head>

 <body>

<p>Click the following to see the result:</p>

<form>

<input type=”button” value=”Click Me”
onclick=”myFunc();” />

</form>

</body>

</html>

3 Click Save

4 Type filename as ErrorHandling4.html

5 Select file type as All Files.

6 Select desktop or any other location. Click Save

7 Close Notepad

8 Now run the html file to see the result (Fig-7)

9 Click the Click Me button (Fig-8)
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PROCEDURE

TASK 1: Use switch case without break

1 Open Notepad

2 Type the following code

<html>

<body>

<script type=”text/javascript”>

var grade=’A’;

document.write(“Entering switch block<br />”);

switch (grade)

{

case ‘A’: document.write(“Good job<br />”);

case ‘B’: document.write(“Pretty good<br />”);

case ‘C’: document.write(“Passed<br />”);

case ‘D’: document.write(“Not so good<br />”);

case ‘F’: document.write(“Failed<br />”);

default: document.write(“Unknown grade<br />”)

}

document.write(“Exiting switch block”);

</script>

<p>Set the variable to different value and then try...</
p>

</body>

</html>

3 Click Save

4 Type filename as Switchcase1.html

5 Select file type as All Files.

6 Select desktop or any other location. Click Save

7 Close Notepad

8 Now run the html file to see the result (Fig.1)

IT & ITES                                                                                          Exercise 2.1.98B
COPA - JavaScript & Creating Web pages

Practice with Switch Case and Errors in JavaScript
Objectives: At the end of this exercise you shall be able to
• use switch case without break
• useswitch case with break and error handling.

Fig 1
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TASK 1: Use switch case with break and error handling

case ‘D’: document.write(“Not so good<br />”);
break;
case ‘F’: document.write(“Failed<br />”);
break;
default:  document.write(“Unknown grade<br />”)
}
document.write(“Exiting switch block”);
//—>
</script>
</body>
</html>

3 Click Save

4 Type filename as Switchcase2.html

5 Select file type as All Files.

6 Select desktop or any other location. Click Save

7 Close Notepad

8 Now run the html file to see the result (Fig.2)

9 Click the Click Me button (Fig.3)

1 Open Notepad

2 Type the following code

<html>
<body>
<script type=”text/javascript”>
<!—
var grade=’A’;
document.write(“Entering switch block<br />”);
switch (grade)
{
case ‘A’: document.write(“Good job<br />”);
break;
case ‘B’: try {
alert(“Value of variable a is : “ + a );
}
catch ( e ) {
alert(“Error: “ + e.description );
}
break;
case ‘C’: document.write(“Passed<br />”);
break;
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IT & ITES                                                                                          Exercise 2.1.99
COPA - JavaScript & Creating Web pages

Practice with Arrays  in JavaScript
Objectives: At the end of this exercise you shall be able to
• program to search an element in an array
• program to sort an array of numbers
• program to sort strings.

PROCEDURE

TASK 1 : Program to search an element in an array

1 Open Notepad.

2 Type the following code.

<html>
<head>
<title>Array</title>
<script>
var arr=new Array();
arr[0]=12;
arr[1]=9;
arr[2]=4;
arr[3]=30;
arr[4]=-5;
arr[5]=21;
arr[6]=9;
arr[7]=3;
arr[8]=14;
var f=prompt("Enter element to search:");
var i,fl=0;
for(i=0;i<arr.length;i++) {
if(f==arr[i]) {
fl=1;
break;
}
}
if(fl==1)
alert("found at location:"+i);
else
alert("Not found");
</script>
</head>
<body>
</body>
</html>

3 Click Save.

4 Type filename as serch11.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 1)

If entered 3 we get output like Fig 2.

And if 24 is entered , we get output like Fig 3.

 

 

Fig 1

Fig 2

Fig 3
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TASK 2: Program to sort an array.

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Array</title>

<script>

var arr=new Array();

arr[0]=10;

arr[1]=9;

arr[2]=40;

arr[3]=23;

arr[4]=1;

arr[5]=46;

arr[6]=2;

arr[7]=8;

arr[8]=14;

var i,j,l=arr.length,t;

for(i=0;i<l-1;i++) {

for(j=0;j<l-i-1;j++) {

if(arr[j]>arr[j+1]) {

t=arr[j];

arr[j]=arr[j+1];

arr[j+1]=t;

}

}

}

var r=arr.join();

alert(r);

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as sort1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 4)

TASK 3 : Program to sort strings.

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Array Sort</title>

<script>

var arr=new Array();

arr[0]="Kolkata";

arr[1]="New Delhi";

arr[2]="Mumbai";

arr[3]="Chennai";

arr[4]="Ahmedabad";

arr[5]="Bangalore";

arr[6]="Siliguri";

arr[7]="Barasat";

arr[8]="Amritsar";

arr.sort();

var r=arr.join();

alert(r);

</script>

</head>

<body>

</body>

</html>

Fig 4
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document.write("We will play a game now!");

else

document.write("May be next time");

</script>

</head>

<body>

</body>

</html>

3   Click Save.

4   Type filename as sort2.html

5   Select file type as All Files.

6   Select destination in Desktop or any other location
Click Save.

7   Close Notepad.

8   Now run the html file to see the result. (Fig 5)

Fig 5
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IT & ITES                                                                                          Exercise 2.1.100A
COPA - JavaScript & Creating Web pages

Practice with Functions  in JavaScript
Objectives: At the end of this exercise you shall be able to
• display add two numbers using function
• take input using prompt function
• take confirmation using confirm method
• using global variable.

PROCEDURE

TASK 1 : Display add two numbers using function

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Adder</title>

<script>

var a=4;

var b=6;

var c=add(a,b);

alert(c);

function add(a,b) {

return a+b;

}

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as add1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (See Fig 1)

TASK 2:  Take input using prompt function

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Prompt</title>

<script>

var a=prompt("Enter a Number:");

var b=prompt("Enter another Number:");

var ch=+prompt("1->Add  2->Sub  3->Mul  4->Div
Enter Choice:");

var r=0,fl=0;

switch(ch) {

case 1:

r=add(a,b);

break;

case 2:

Fig 1
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r=sub(a,b);

break;

case 3:

r=mul(a,b);

break;

case 4:

r=div(a,b);

break;

default:

fl=1;

}

if(fl)

document.write("Invalid choice");

else

document.write("Result is "+r);

function add(a,b) {

return a+b;

}

function sub(a,b) {

return a-b;

}

function mul(a,b) {

return a*b;

}

function div(a,b) {

return a/b;

}

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as calcul1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 2 to Fig 5)

TASK 3 :  Take confirmation using confirm method

1 Open Notepad.

2 Type the following code.
<html>

<head>

<title>Confirm</title>

<script>

var a=confirm("Want to play a game?");

if(a)
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document.write("We will play a game now!");

else

document.write("May be next time");

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as conf1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

TASK 4 : Using global variable

1 Open Notepad.

2 Type the following code.

<html>
<body>
<script>
function m()
{
window.value=100;//declaring global variable by
window object
}
function n(){
alert(value);//accessing global variable from other
function
}
m();
n();
</script>
</body>
</html>

8 Now run the html file to see the result. (Fig 6  to Fig 8)

If Ok is selected.
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If cancel is selected

3 Click Save.

4 Type filename as vari1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 9 )

Fig 6
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PROCEDURE

TASK 1 : Create object and adding properties to it using class

IT & ITES                                                                                          Exercise 2.1.100B
COPA - JavaScript & Creating Web pages

Practice with Objects  in JavaScript
Objectives: At the end of this exercise you shall be able to
• create object and adding properties to it using class

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Object Property</title>

<script>

var Employee={};

function Employee(eno,basic,gross) {

this.eno=eno;

this.basic=basic;

this.gross=gross;

}

Employee["Ram"]=new
Employee("2","12000","23000");

Employee["Jadu"]=new
Employee("21","9000","19000");

Employee["Karna"]=new
Employee("31","13000","28000");

Employee["Ratul"]=new
Employee("4","10000","24000");

Employee["Krishna"]=new
Employee("25","15000","31000");

</script>

</head>

<body>

<script>

for(var item in Employee) {

alert(item);

}

</script>

</body>

</html>

3 Click Save.

4 Type filename as obj1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result.
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IT & ITES                                                                                          Exercise 2.1.101A
COPA - JavaScript & Creating Web pages

Practice with Strings in JavaScript

Objectives: At the end of this exercise you shall be able to
•  display the length of a string
•  display substring of a string
•  return a particular character from a string
•  display whether a string is palindrome or not
•  count number of words in a string
•  find whether a word is present within a string.

PROCEDURE

TASK 1 : Display the length of a string

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>String length</title>

<script>

alert("dfgdf".length);

var st1='I am a resident of India';

var l=st1.length;

alert("Length of String:"+l);

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as len1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location. Click
Save.

7 Close Notepad.

8 Now run the html file to see the result. (See Fig 1
and Fig 2)

TASK 2: Display substring of a string

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Sub String</title>

<script>

var st1='I like Cricket';

var sub=st1.substring(7,14);

alert("name of the game:"+sub);

</script>

</head>

<body>

</body>

</html>

Fig 1

Fig 2
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3 Click Save.

4 Type filename as sub1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 3)

TASK 3 : Return character from a particular position

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>Char At function</title>

<script>

var st1='I like Cricket';

var ch=st1.charAt(7);

alert("character:"+ch);

</script>

</head>

<body>

</body>

</html>

3 Click Save.

4 Type filename as sub1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result.(Fig 4)

TASK 4 : Display whether a string is palindrome or not

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>String Problem</title>

<script>

function str() {

var st=document.getElementById("st1").value;

var i=0,st1="";

for(;i<st.length;i++) {

st1=st.charAt(i)+st1;

}

if(st==st1)

alert("palindrome");

else

alert("not palindrome");

}

</script>

</head>

<body>

<form id="f1" action="#">

String:<input id="st1" name="st1" type="text">

<input type="submit" value="submit" onclick="str()">

</form>

</body>

</html>
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3 Click Save.

4 Type filename as palinstr1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 5)

TASK 5:  Count number of words in a string

1 Open Notepad.

2 Type the following code.

<html>

<head>

<title>String Problem</title>

<script>

function str() {

var st=document.getElementById("st1").value;

var i=0,co=0,st1="";

for(;i<st.length;i++) {

if(st.charAt(i)==' ')

co++;

}

alert("Number of Words:"+(co+1));

}

</script>

</head>

<body>

<form id="f1" action="#">

String:<input id="st1" name="st1" type="text">

<input type="submit" value="submit" onclick="str()">

</form>

</body>

</html>

3 Click Save.

4 Type filename as strcont1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 6)
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TASK 6: Find whether a word is present within a string

3 Click Save.

4 Type filename as sub1.html

5 Select file type as All Files.

6 Select destination in Desktop or any other location.
Click Save.

7 Close Notepad.

8 Now run the html file to see the result. (Fig 7)

1 Open Notepad.

2 Type the following code. (Fig 5)

<html>

<head>

<title>String Problem</title>

<script>

function str() {

var st=document.getElementById("st1").value;

var st1=document.getElementById("wd").value;

var i=0,co=0,st2="";

while(i<st.length) {

st2="";

while(st.charAt(i)!=' '&&i<st.length) {

st2+=st.charAt(i);

i++;

}

if(st2==st1)

co++;

i++;

}

alert("Number of Words:"+co);

}

</script>

</head>

<body>

<form id="f1" action="#">

Sentence:<input id="st1" name="st1"
type="text"><br>

Enter Word:<input id="wd" name="wd"
type="text"><br>

<input type="submit" value="submit" onclick="str()">

</form>

</body>

</html>
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IT & ITES                                                                                          Exercise 2.1.101B
COPA - JavaScript & Creating Web pages

Practice with Math Function in JavaScript

Objectives: At the end of this exercise you shall be able to
•  round  a specified number to the nearest integer
•  print a random number from 0 to 10
•  find the highest of the  two numbers

PROCEDURE

TASK 1 : Round  a specified number to the nearest integer

1 Open Notepad

2 Type the following code

<html>

<body>

<html>

<body>

<script type=”text/javascript”>

document.write(Math.round(7.25))

</script>

</body>

</html>

3 Click Save

4 Type filename as MathObj1.html

5 Select file type as All Files.

6 Select desktop or any other location. Click Save

7 Close Notepad

8 Now run the html file to see the result. (Fig 1)

TASK 2: Print a random number from 0 to 10

1 Open Notepad

2 Type the following code

<html>

<body>

<script type=”text/javascript”>

no=Math.random()*10

document.write(Math.floor(no))

</script>

</body>

</html>

3 Click Save

4 Type filename as MathObj2.html

5 Select file type as All Files.

6 Select desktop or any other location. Click Save

7 Close Notepad

8 Now run the html file to see the result(Fig 2)

Fig 1
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TASK 3: Find the Highest of the  two numbers

1 Open Notepad

2 Type the following code

<html>

<body>

<script type=”text/javascript”>

document.write(Math.max(2,4))

</script>

</body>

</html>

3 Click Save

4 Type filename as MathObj3.html

5 Select file type as All Files.

6 Select desktop or any other location. Click Save

7 Close Notepad

8 Now run the html file to see the result (Fig3
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IT & ITES Exercise 2.1.101C
COPA - JavaScript &Creating Web pages

Practice with Date Functions in JavaScript
Objectives : At the end of this lesson you shall be able to
•  print date including date, month, and year
•  print current local time including hour, minutes, and seconds
•  display full date with the name of the day and the name of the month.

PROCEDURE

TASK 1 : Print date including date, month, and year

1 Open Notepad

2 Type the following code

<html>

<body>

<script type=”text/javascript”>

var d = new Date()

document.write(d.getDate())

document.write(“.”)

document.write(d.getMonth() + 1)

document.write(“.”)

document.write(d.getFullYear())

</script>

</body>

</html>

3 Click Save

4 Type filename as DateObj1.html

5 Select file type as All Files.

6 Select destination in desktop or any other location.
Click Save

7 Close Notepad

8 Now run the html file to see the result. (Fig 1)

TASK 2: Print current local time including hour, minutes, and seconds

1 Open Notepad

2 Type the following code

<html>

<body>

<script type=”text/javascript”>

var d = new Date()

document.write(d.getHours())

document.write(“.”)

document.write(d.getMinutes() + 1)

document.write(“.”)

document.write(d.getSeconds())

</script>

</body>

</html>

3 Click Save

4 Type filename as DateObj2.html

5 Select file type as All Files.

6 Select destination in desktop or any other location.
Click Save

7 Close Notepad

Fig 1
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Fig 2

Fig 3

8  Now run the html file to see the result (Fig 2)

TASK 3: Display full date with the name of the day and the name of the month

1 Open Notepad

2 Type the following code

<html>

<body>

<script type=”text/javascript”>

var d =  new Date()

var weekday= new Array (“Sunday”,”Monday”,

      ”Tuesday”,”Wednesday”,”Thursday”,”Friday”,”Saturday”)

var monthname=new Array (“Jan”,”Feb”,”Mar”, ”Apr”,
”May”,”Jun”,”Jul”,”Aug”,”Sep”,”Oct”,”Nov”,”Dec”)

document.write(weekday[d.getDay()] + “ “)

document.write(d.getDate() + “. “)

document.write(monthname[d.getMonth()] + “ “)

document.write(d.getFullYear())

</script>

</body>

</html>
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3 Click Save

4 Type file name as DateObj3.html

5 Select file type as All Files.

6 Select destination in desktop or any other location.
     Click Save

7 Close Notepad

8 Now run the html file to see the result. (Fig 3)



39

IT & ITES                                                                                          Exercise 2.1.102A
COPA - JavaScript & Creating Web pages

Working with Titles, Font sizes and Colours, lists, and Images in Kompozer
Objectives: At the end of this exercise you shall be able to
• work with Tiles, font sizes and colours, lists and images in Kompozer.

PROCEDURE

TASK 1: Develop the given Web page(Fig 1) with Titles, font sizes and colours, lists and images in Kompozer
using    the following steps.

1 Start typing text HIBISCUS into the authoring pane
(the large pane).

2 Select the text and apply the following settings to the
text HIBISCUS.

a Click on Format -> Font -> Comic Sans MS

b  Click on Format -> Font -> Text Style ->  Bold

c Click on Format -> Text Color -> Predefined colours
-> Red and then click OK.

d Click on Larger Font Size button          to enlarge the
text.

e Click on Center button       to center the text.

Note: You can download Kompozer (free) from www.kompozer.net. Install it in your system and load it
    by clicking the file kompozer.exe

Fig 1
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3 Inset the Image by applying the following steps.

a Click on Insert -> Image .  Image Properties window is
displayed. (Fig.2)

b Click on  Location  ->  Choose File button

c Choose the image file. And then click Open (Fig.3)

d Opened Image location is displayed . Type the Alter
nate text as 'Image of a Flower' and then click  OK.
(Fig.4)

e Now the image is inserted.

f Press the Enter key.

Fig 2
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4  Insert table and add bulleted list.

a Click on Insert -> Table to insert the table. (Fig.5)

b  In the Insert Table window select single cell and
press OK. (Fig.5)

d Click on Insert -> Horizontal line to insert a line. (Fig.5)

e Click on Format -> list -> bulleted to list out the uses
of Hibiscus. (Text colour : Red)    (Fig.5)

c Expand the cell and type the heading 'Medicinal
uses and Home remedies with Hibiscus'.  (Text
colour : Green) (Fig.5)
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5  Save the file with Title.

a Click on File -> Save. It displays the Page title window.
(Fig.6)

b Give the title as 'Hibiscus - The medicinal flower' and
click OK (Fig.6)

c It asks file name to save. Give the file name as
MPLANT.HTML

6 View the file MPLANT.HTML as a web page in Browser
by double clicking the file name.(Fig 7)
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IT & ITES                                                                                          Exercise 2.1.102B
COPA - JavaScript &creating Web pages

Work with tables and links in kompozer
Objectives: At the end of this exercise you shall be able to
• create a HTML file with an Image in Kompozer
• create a HTML file with table in Kompozer
• create the HTML file with links in Kompozer
• open the HTML file in Browser and view the linked pages.

PROCEDURE:

Design the webpages with tables and links in kompozer ( Fig 1).

TASK 1 : Create a HTML file with an Image in Kompozer.

1 Open Kompozer and Click on Insert -> Image. It
displays Image Properties window.

2 Click on  Location  ->  Choose File button

3 Choose the image file. And then click Open. Opened
Image location is displayed.

4 Type the Alternate text as ‘Home Page Picture’.
(Fig.2)

Fig 2

  Fig 1
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5 Click on Dimensions -> Custom Size and type width
as 100 % of cell and click OK to make fit the image
in the window. (Fig.3)

6 Save it as ‘Home Page Link.HTML’ and close the
file.

TASK 2 : Create a HTML file with table in Kompozer.

1 Open Kompozer and Click on Insert -> Table with 2
rows and 4 columns and click OK to insert a
table.(Fig.4)
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2 Right click on the cell. It displays Table Properties
window.

3. Click on Cells -> Width -> 25 % of table. (Fig.5)

4. Click on Apply and then OK.

5. Click on Insert -> Image. It displays Image
Properties window.

6. Click on  Location  ->  Choose File button

7. Choose the image file. And then click Open. Opened
Image location is displayed.

8. Type the Alternate text as ‘b1’. (Fig.6)
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6 Click on Dimensions -> Custom Size and type width
as 100 % of cell and click OK to make fit the image
in the cell. (Fig.7)

7 Repeat the steps 2 to 6  of Task 2 of this exercise
and insert the images in the remaining cells of a
table. The table looks as Fig.8.

8 Save the file as ‘Bouquet.HTML’ and close the file. Note : Create a HTML file Flower pot.HTML (Fig.9)
 using steps given in Task2
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Task 3 : Create the HTML file with links in Kompozer.

1 Open Kompozer.

2 Click on Insert -> Table to insert a single cell. (Fig.10)

3 Right click on the cell. It displays Table Properties
window.

4 Click on Cells -> Width -> 100 % of table. (Fig.11)

5 Click on Apply

6 Click OK.

7 Click on Insert -> Image. It displays Image Properties
window.

8 Click on  Location  ->  Choose File button

9 Choose the image file. And then click Open. Opened
Image location is displayed.

10 Type the Alternate text as ‘Nursery’. (Fig.12)
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11  Click on Dimensions -> Custom Size and type width
as 100 % of cell and click OK to make fit the image in
the cell. (Fig.13)

12 Now the screen is displayed with an image inside a
table. (Fig.14)
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13 Click at the end of the image and press Enter key to
go to the new line of the table cell.

14 Right click on the table and select ‘Table or Cell
Background colour’. Select the colour and click OK to
fill the table cell.

15 Type the text ‘Greenways Nursery Garden’ and
increase its size as you need.

16 Click at the next line of the table and type ‘Home’.

17 Select the text ‘Home’ and click on Link button. It
displays Link Properties Window. (Fig.15)

18 Click on File button in the Link location to insert the
file Home Page Link.html (Fig.16)

Click on ‘Link is to be opened’  and choose ‘in a new
window’ and press ‘OK’ to open the linked file in new
window. (Fig.16)
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19 Using Steps 16 to 18, link the file Bouquets.HTML to
the text Bouquet and the Flower pot.HTML to the
text Flowerpot.

20 Save the file as ‘Nursery.HTML’. Now it looks as Fig.1

TASK 4 : Open the HTML file in Browser and view the linked pages.

1 Open Chrome

2 Open the file ‘Nursery.Html’. It shows the web page.
(Fig.1)

4 Click on back button  at the top left side of the chrome
window to go to the Home page.

3 Click on Home. It Opens ‘Home Page Link.Html’.
(Fig.16)

Note : Check the links on the text Bouquet and
Flowerpot.
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IT & ITES Exercise 2.1.102C
COPA - JavaScript & Creating Web pages

Work with Web Template and CSS in Kompozer
Objectives : At the end of this lesson you shall be able to
•  create templates from Format menu of Kompozer
•  create CSS in Kompozer.

PROCEDURE:

TASK 1 : Create templates from Format menu of Kompozer

Note : A template is like a frame structure. For example you have five copies of the same template each
saved as with an extension .html. In each copy you add whatever content you want. When you view the
website it will have web pages linked to each other. The frame structure will be identical in each webpage however
each webpage will have different content. Usually all webpages have the same Left Side Bar, Header, Right Side
Bar and Footer.

1  Click on Format -> Page Title and Properties. This will
display the following image Page Properties.
Select This page is a template. Click on OK button
when you are ready.(Fig.1)

There are other options you might want to fill out.

Page Properties Fields:

- Title

- Author

- Description

- This page is a template -> Selected for this
Exercise

- Language

- Writing direction

- Character set
       Fig 1
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2  Once you have selected ”This page is a template” in
the previous step, click on File -> Save As. Select
from Save as type: HTML templates as in Fig.2. The
file will be saved as a template with the following
extension .mzt.

3  The following image displays when you click on File ->
New. You can select from the following options. (Fig.3)

Create a new document or template

- A blank document

- A new document based on a template   -> This
is the option selected for this tutorial

- A blank template

- Choose New Tab or New Window in Create in.

- Click on Create button when you are ready
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Task 2 : Create CSS in Kompozer.

 Apply the following style for Headings 1 (h1).

Font :  Times New Roman

Case : Uppercase

Alignment : Centre

Background color : Light Blue

Border : Dotted Border

1 Open a new file in Kompozer.

2 Give the title name and save the file.

3 In Composition toolbar, select the Cascade button
(Fig.4).

 

4 It opens CSS Stylesheets Window (Fig.5).

5 Click on first radio button (Fig.5).

6 Select h1 from the drop down menu(Fig.5).

7 Click the Create Style rule button. (Fig.5).

Note: Now CSS Stylesheet window remains open
but the options will change. It shows the h1 element
just below the heading internal stylesheet on the
left pane of the window.(Fig.6).
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8 Click on Text tab in the CSS stylesheet
window.(Fig.7)

9   In the Font family section, select the Predefined
radio button and choose Times New Roman from
drop down menu. (Fig.7)

10 Choose Upper case  from Case menu. (Fig.7)

11 Choose Center from the Alignment menu. (Fig.7)

12 To set the background select the Background tab.
(Fig.8)
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13 In the Colour option click the colour palette button
(Fig.8). This opens the Block Background Colour
dialog box. (Fig.9).

14 Choose the predefined colour  and click OK. 15 If you want to keep an image in the background then
in the Image option click on Choose file and select
the file. (Fig.10)

IT & ITES : COPA - (NSQF- 4) Exercise 2.1.102C

Fig 9

Fig 10
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16 Click on Border tab to set the border. To apply same
border on all sides, tick the check box All four sides
use same border style. (Fig.11)

Note : When you apply same border on all sides, only
top will be enabled. (Fig.11)

17  Select dotted in Top. This is shown in Preview Box.
(Fig.11)

18  Click on General tab. The CSS code is displayed for
the settings you have been set so far.(Fig.12)
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19 To add other CSS click on Style Rule Button.
Otherwise click on OK button to save the CSS
Stylesheet settings.

20  In Format Tool bar click on Heading 1 option to insert
a heading in the page. Now the cursor is automatically
placed in the center with green background dotted
border. (Fig.13)

21 Type the text. It will appear in Uppercase and black
colour. (Fig.13).
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IT & ITES Exercise 2.1.103A
COPA - JavaScript & Creating Web pages

Internet Information Services or IIS Server
Objectives : At the end of this lesson you shall be able to
•  configure IIS in Windows 10 Operating System
•  publish website on IIS locally
•  publish Web site in IIS.

PROCEDURE

TASK 1 : Configure IIS in Windows 10 Operating System

 Fig 1
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2 Click Programs (Fig 2)

4 Check the Internet Information Services and its
related features in the New popup window( Fig 4)
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Fig 2

3 Click Turn Window features on or off (Fig 3)

 Fig 3
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Under Internet Information Services check the following
folders:(Fig 5)

- FTP Server

- Web Management Tools

- World wide web services

- Application development features

- Common HTTP Feature

- Health and Diagnostics

- Perfomance Feature

- Security
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5 Then click OK to complete the installation of new
    features.

6 Click Close to complete the IIS feature installation.
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Fig 6
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7 Open the browser, type url http://localhost 8  Internet Information Services (IIS) successfully
   configured (Fig 8)

TASK 2 :  Publish website on IIS web server locally
1 Create a home page for the website using any web
    page design tool

2 Copy the home page in to inetpub/wwwroot the Web
publishing directory of IIS

3 Type the user’s computer name or the computer’s
    numerical IP address followed by the home page
    name in the browser’s address bar to reach user’s
    site.
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TASK 3 : Publish a new Web site in IIS

1 Type IIS Manger in Cortana search 2 Open IIS Manager by clicking on Internet Information
     Services(IIS) Manager. (Fig,10)

3 Right click on Sites and click on Add Website.
(Fig11)

4 Opens Add website dialog. (Fig 12)
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5 Fill in required details and select folder where
     compiled code is located. (Fig 13)

              Eg: C:\Nigel\Publish

6 Select required port .(Fig 13)

7 Enter host name details

(Do not enter host name details if you are testing or
     using on LAN).

IT & ITES : COPA - (NSQF- 4) Exercise 2.1.103A

Fig 12

Fig 13



65

7 Click ok, website gets created and it will show under
    Sites(Fig 14)

8 Right click on website name then Manage website
    and then click browse.

9 Type firewall In Cortana search for change in Firewall
     Rules.(Fig16)
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10 Click on Windows firewall (Fig 17)
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11 Click advanced settings.(Fig 18)

12 Click on Inbound rules on the left. (Fig 19)
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Fig 18

 Fig 19
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13 Click new Rule in the right side menu.(Fig 20)

14 Select Port in the New inbound rule wizard and click
Next .(Fig 21)
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15 Enter port number in specific local ports textbox,
Then click Next (Fig 22)

16 Select Allow the connection in the opened Action
form and click Next .(Fig 23)
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Fig 22

    Fig 23
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17 Select required ones in the profile form and Click
Next. (Fig 24)

18 Give firewall rule Name and Description, Then click
finish. (Fig 25)
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Fig 25
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TASK 3:  Publish Content on IIS web server locally

1 Create a home page for the website using any web
page design tool

2 Copy the home page in to inetpub/wwwroot the Web
publishing directory of IIS

IT & ITES : COPA - (NSQF- 4) Exercise 2.1.103A

3 Type the user’s computer name or the computer’s
numerical IP address followed by the home page
name in the browser’s address bar to reach user’s
site.
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IT & ITES Exercise 2.1.103B
COPA - JavaScript & Creating Web pages

JavaScript Project
Objectives : At the end of this lesson you shall be able to
•  create html file for entering a Resume of Candidate
•  create java validation for the numeric inputs
•  create java validation for the alphabet inputs
• create email validation java script
• close the HTML file to complete the validated file

PROCEDURE

TASK 1 : Create html file for entering a Resume of Candidate

<td><div align=”right”>Gender </div></td>

<td>

< input required name=”gender” type=”radio”
value=”Male”>

          Male

<input name=”gender” type=”radio” value=”Female”>

Female

<input name=”gender” type=”radio” value=”TG”>

TransGender

</td>

</tr>

<tr>

<td><div align=”right”>Person With Disability </div></
td>

<td><input required name=”phstatus” type=”radio”
value=”Yes”>

          Yes

<input name=”phstatus” type=”radio” value=”No”>

        No</td>

</tr>

<tr>

<td><div align=”right”>Category of Candidate</div></
td>

<td>

<input name=”category” type=”radio” value=”General”
required>

      General

<input name=”category” type=”radio” value=”OBC”>

       OBC

1 Open notepad.exe from the all programs

2 Type the following html code into the file

<html>

<head>

<title>Resume update Web Page</title>

</head>

<body ‘>

<div align=”center”>

<form method=”post” action=”#” >

<table width=”90%” border=1  cellpadding=”10px” >

<tr>

<td width=”40%”><div align=”right”>Name of the
Candidate </div></td>

<td width=’33%’><input name=”cname” type=”text “
onkeypress=”return onlyAlphabets(event,this);”
required></td>

</tr>

<tr>

<td><div align=”right”>Date of Birth </div></td>

<td><input type=date name=’dob’>

</td></tr>

<tr>

<td><div align=”right”>Father / Husband’s Name </
div></td>

<td>

<input name=”gname” type=”text”onkeypress=”return
onlyAlphabets(event,this); required></td>

</tr>

<tr>
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<input name=”category” type=”radio” value=”SC”>

       SC

<input name=”category” type=”radio” value=”ST”>

      ST

</td>

</tr>

</table>

<p class=”style2">Contact Details of Candidate <p>

<table width=”90%”  border=”1" cellpadding=”10px”>

<tr>

<td width=”41%”><div align=”right”>Address Line
1</div></td>

<td width=”59%” ><input name=”ad1" type=”text”
id=”ad1" size=”60" required></td>

</tr>

<tr>

<td><div align=”right”>Address Line 2 </div></td>

<td><input name=”ad2" type=”text” id=”ad2"
size=”60"></td>

</tr>

<tr>

<td><div align=”right”>City / Town </div></td>

<td><input name=”city” type=”text” id=”city”
size=”40" onkeypress=”return
onlyAlphabets(event,this);” required></td>

</tr>

<tr>

<td><div align=”right”>PIN Code</div></td>

<td ><input name=”pin” type=”text id=”pincode”
size=”10" maxlength=”6" onkeypress=”return
isNumber(event)” required></td>

</tr>

<tr>

<td><div align=”right”>State </div></td>

<td>< input type = ‘text’ name=’state’ required>

</td>

</tr>

<tr>

<td><div align=”right”>District </div></td>

<td>

<input type=’text’ name=’district’
onkeypress=”return onlyAlphabets(event,this);”
required>

</td></tr>

<tr>

<td><div align=”right”>Email Address </div></td>

<td><input name=”email” type=”email”
onblur=”validateEmail(this);” required></td>

</tr>

<tr>

<td><div align=”right”>Phone </div></td>

<td>STD

<input name=”std” type=”text” onkeypress=”return
isNumber(event)” size=”6">

     No.

<input name=”phone” type=”text”onkeypress=”return
isNumber(event)” maxlength=”12"></td>

</tr>

<tr>

<td><div align=”right”>Mobile No. </div></td>

<td class=”inputtext”><input name=”mobile”
type=”text” onkeypress=”return isNumber(event)”
required></td>

</tr>

<tr>

<td width=”41%” class=”style1"><div
align=”right”>Aadhar Number </div></td>

<td width=”59%”><input name=”aadhar” type=”text”
maxlength=”12" onkeypress=”return
isNumber(event)”>

     (if Available)</td>

</tr>

<tr>

<td class=”style1"><div align=”right”>Qualification
</div></td>

<td>

<input name=”qualifi” type=”radio” value=”Degree”
required>

     Degree

<input name=”qualifi” type=”radio” value=”Diploma”
required>
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    Diploma

<input name=”qualifi” type=”radio” value=”NCVT”
required>

 NCVT

</td>

</tr>

</table>

<p>

<input name=”Submit” type=”submit”
class=”inputtext” value=”Submit”>

<input name=”Submit2" type=”reset”
class=”inputtext” value=”Reset”>

</p>

</form>

Note : The above HTML CODE creates an input page
for getting the resume data.

TASK 2 : Create java validation for the numeric inputs
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<script type=’text/javascript’>

functionisNumber(evt) {

evt = (evt) ? evt :window.event;

varcharCode = (evt.which) ? evt.which :evt.keyCode;

if (charCode> 31 && (charCode< 48 || charCode>
57)) {

return false;

    }

return true;

}

</script>

TASK 3 : Create java validation for the alphabet inputs

Note :This function checks the input is only number not
other character or special character.1 Insert the following lines at the end of the file, after

the </FORM > tab.

<script type=’text/javascript’>

functiononlyAlphabets(e, t) {

try {

if (window.event) {

varcharCode = window.event.keyCode;

      }

else if (e) {

varcharCode = e.which;

      }

else { return true; }

if ((charCode> 64 &&charCode< 91) || (charCode>
96 &&charCode< 123))

return true;

else

return false;

      }

catch (err) {

alert(err.Description);

      }

  }

</script>
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TASK 4 : Create email validation java script

<script type=’text/javascript’>

functionvalidateEmail(emailField){

var reg = /^([A-Za-z0-9_\-\.])+\@([A-Za-z0-9_\-
\.])+\.([A-Za-z]{2,4})$/;

if (reg.test(emailField.value) == false)

     {

alert(‘Invalid Email Address’);

return false;

     }

return true;

}

</script>

TASK 5 : Close the HTML file to complete the validated file

1 Insert the following codes to complete the file

</body>

</html>

2 Save the file as the “javascripttest.html”

TASK 5 : Test run the saved file

1 Open the file using right click on the file and “open
with” with a web browser as in Fig.1
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The html file will be displayed as in Fig.2
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Fig 2

Test the inputs of the fields and check the following are
now validated by the javascript functions added in the
html file.

a) If the form is submitted as it is (blank), there will be a
warning, ‘Field is required’ where there is a blank field
left in the form.

- This is because of the condition put as ‘REQUIRED’
in the input tags.

b) Name, Father Name, etc. fields wont accept numbers
in the fields.

- This is the reason since the script checks for only
alphabets input.

c) PIN code wont accept alphabets and only 6
numbers.

-  As the script checks only numbers and the size
attributed to maximum of 6.

d) While the email is not proper, it will display a
message box as invalid email.

- Email should be in proper form as xxxx@xxx.xxx
and is checked by the javascript inserted.

Like the above, it can be added with numeric
value functions to calculate age with the input
date, qualify with the age limit, etc.

Points to add :

- The dynamic web page is to be hosted into a server to
perform as sending inputs to a database. It requires a
web server hosting, which is available in internet in
various costs.

- Javascript is a common platform for both Windows
and Linux based servers. So, it will work on any platform
for dynamic publication.

- To try with local installation in a PC / Laptop, import
XAMPP / WAMP / LAMP tool to run serverside within
the system using mySql as database source.



77

IT & ITES                                                                                          Exercise 2.2.104
COPA - Programming with VBA

Practice Basic Function of VBA Editor
Objectives: At the end of this exercise you shall be able to
• display the developer tab
• enable the macros
• open the VBA Editor and Identify the VBA editor elements
• write code to display "Hello COPA"
• use Debug.print method to display the output in the immediate window
• save the file as macro enabled work book.

PROCEDURE

TASK 1 : Display the developer tab

1 Click the File menu then select Options.

2 From the dialogue box, click on Customize Ribbon on
the left side.

3 From the right hand side you'll then see an area called
"Customize the Ribbon". Under "Main Tabs" click  the
Developer  check box and click OK .(Refer Fig 1)

4 Click on the developer tab, the buttons for VBA
development like Visual Basic, Macros etc. are
visible.(Refer Fig 2 )

Fig 1

Fig 2
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TASK 2 : Enable the Macros

1 Click on Macro Security, on the Developer Ribbon.

2 Select the option to Enable all macros.

3 Check  "Trust access to the VBA object model"
checkbox. This will let you run macros without any
annoying security warnings.

TASK 3 : Open the VBA Editor and Identify the VBA editor elements.

1 Open the VBA Editor

a Method I:   Click on the Visual Basic button on the
Developer tab.

b Method II:  Click on the View code button on the
Developer tab.

c Method III:  Use the shortcut keys combination of
Alt + F11.

d Method IV : Right click on sheet name and select
“View code”

a The left side area in the VBA window is
called as VBA Project window. This shows
a list of all the objects in the current project.

b One Excel workbook is displayed by default
and this workbook contains all the macros.

c This window also displays one or more
Excel sheets depending on the version of
Excel being used.

2 Double click on the Sheet1 object in the project window.

This opens the Code Window on the right side
with the default name Book 1. (Refer Fig 3)  This
is where the VBA code is written.

TASK 4: Write code to display "Hello COPA"

1 Open the VBA editor (Press Alt F11).

2 Click on the Insert menu item.

3 Select module.

A new module is inserted in the VBA Project
(Book1) with default name Module 1 (Refer Fig
4)

Fig 3
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TASK 5: Use Debug.print method to display the output in the immediate window.

Fig 4

4 Type the following code in the Module1 code window.

Sub HelloWord()

MsgBox "Hello VBA World!"

End Sub

5 To run the program click on the green triangle in the
standard tool bar / click the Run button on the Run
Menu / press F5  on the keyboard.

6 The result will be as in Fig 5.

a. The Immediate window can be used for
executing VBA statements directly, displays
the intermediate and final results, testing
statements and helping to debug your code

b. The Immediate window can also be opened
by using the Shortcut key Ctrl +G.

1 Type the following code in the Module1 code window.

Sub result()

Debug.Print "Hello"

End Sub

2 Click on View > Immediate Window or Press "Ctrl +
G".

This opens the immediate Window from where
the code can be executed.

3 Type the name of the macro ie. "result" (without the
double quotes)  in the immediate window and press
"Enter".

This causes the program to be executed in the
immediate window and display the result

4 Verify the results.

The message "Hello" is displayed in the
immediate window.

5 Type the following code in the Module1 code window.

Sub display()

Dim s As String

s = "Welcome"

Debug.Print "Hello"

'Prints 5 spaces between the two strings

Debug.Print "Hello"; Spc(5); "Good Morning"

'Tab(7) starts to print after 7 spaces from the end of
“Hello”

Debug.Print "Hello"; Tab(7); "Good Morning"

'Uses the len() function to give a space equal to the
first string and 6 spaces together

Debug.Print s; Tab(Len(s) + 6); “Good morning”

'Uses the vbCr, Carriage return to print the ensuing
message in the next line

Debug.Print s; Tab(Len(s) + 6); Good; morning; vbCr;
"Bye"

Debug.Print "The End!"

End Sub

6 Type the name of the macro ie. "display" (without the
double quotes)  in the immediate window and press
"Enter".

7 Verify the results.(Refer Fig 5)

This causes the program to be executed in the
immediate window and display the result
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Fig 6

TASK 6: Save the File as a Macro Enabled WorkBook.

1 Click on the File menu item.

2  Click on "Save As" option.

3 Select the location for the file.

4  Type in a proper name for the file.

5 From the "Save as type" dropdown list box, select
"Excel Macro - Enabled WorkBook (*.xlsm) ".

6 Click OK.

The file is now saved as a Macro Enabled
WorkBook with the extension *.xlsm
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IT & ITES                                                                                          Exercise 2.2.105A
COPA - Programming with VBA

Work with form controls like Button, Scroll bar, Spin Button,Text box and
Label controls
Objectives: At the end of this exercise you shall be able to
• place a command button control on the user form and modify its properties at design time
• place command buttons on a user form and write code in the Click() event of the buttons
• modify the command button properties at run time
• create and use a Scroll Bar control
• use a Spin Button control
• to insert and use Text Box and Labels on a User Form.

PROCEDURE

TASK 1:  Place a Command button control on the user form and modify its properties at design time

1 Click on the Developer menu item.

2 Click on the Visual Basic of the developer ribbon.
(Refer Fig. 1)

3 Click on the Insert menu and select User Form
(Refer Fig. 2)

An User form is displayed as shown in Fig. 3

Fig 1

Fig 2
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4 Select Button from the tool box and place it in the
User form (click and drag in the User form) Refer
Fig. 4.
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5 Select CommandButton1 from the UserForm1 and
then press F4 Key to see its properties in properties
window as shown in Fig. 5.

6 Change the Backcolor, Caption, Font, ForeColor,
Picture etc. properties of the Command Button1 and
test the effect on the CommandButton1 for each
change.
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TASK 2 :  Place Command buttons on a User form and write code in the Click() event of the command
   buttons.

1  Add three command buttons in the
 UserForm1 as shown in Fig. 6.

Control          Name Caption

CommandButton1 cmd_red RED

CommandButton2 cmd_green GREEN

CommandButton3 cmd_blue BLUE

3 Double Click on the cmd_red Command Button
event.

4 Type the following line in the cmd_red_Click()
procedure.

Range(“A1:G10”).Interior.Color = vbRed

 Table 1
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2 Set the properties of the controls as shown in Table
1 below

Fig 6
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5 Double Click on the cmd_blue Command Button
envent.

6 Type the following line in the cmd_blue_Click()
procedure.

Range(“A1:G10”).Interior.Color = vbBlue

7 Double Click on the cmd_green Command Button
event.

8 Type the following line in the cmd_green_Click()
procedure.

Range(“A1:G10”).Interior.Color = vbGreen

9 Run the code.

10 Check the results by clicking on the buttons in the
form.
In the Sheet, the BackColor of the  Range (“A1 :
G10”) changes depending on which button is
clicked.

TASK 3:  Modify the Command button properties at run time.

CommandButton1.Caption = “Welcome to NIMI”

CommandButton1.BackColor = vbRed

CommandButton1.ForeColor = vbGreen

TASK 4:  Create and use a Scroll Bar control.
1 Click on the Developer menu item.

2 Click on the Visual Basic of the developer ribbon.
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1 Click on the Developer menu item.

2 Click on the Visual Basic of the developer ribbon.

3 Click on the Insert menu and select User Form.

4 Select Button from the tool box and add one
command button in the User form.

5 Double click on CommandButton1 and write the
following code in the CommandButton1_Click()
event.

6 Run the Module by Pressing F5 key.

7 Click on the CommandButton1 and verify the results.

3 Click on the Insert menu and select User Form.

4 Place controls in the User Form from the tool box
and add controls as shown in Fig.  7.

Fig 7
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5 Set the properties of the controls as in Table 2.

6 Type the following code in ScrollBar1_Scroll event.

Private Sub ScrollBar1_Scroll()

Dim n As Integer

n = ScrollBar1.Value

TextBox1.Text = n & “Degree Celsius”

End Sub

7 Scroll the ScrollBar1 control and verify the results.

TextBox1 displays the value of the Scroll Bar in
the Celsius scale.

8 Add the following line to the ScrollBar1_Scroll event.

TextBox2.Text = ((9/5) *n + 32) & “Degrees of
Fahrenheit”

The complete code should be a follows:

Private Sub ScrollBar1_Scroll()

Dim n As Integer

n = ScrollBar1.Value

TextBox1.Text = n & “Degree Celsius”

TextBox2.Text = ((9/5) *n + 32) & “Degrees of
Fahrenheit”

End Sub

     Table 2

User Form control Name Caption Min. Max

Scroll Bar ScrollBar1     - -50 100

TextBox1 TextBox1     -   -   -

TextBox2 TextBox2     -   -   -

Lable3 lblScale Celsius Scale   -   -

Lable1 lblCelsius Celsius   -   -

Lable2 lblFhn Fahrenheit   -   -

9 Scroll the ScrollBar1 again and verify the results.

The TextBox1 displays the value of the Scroll
Bar in the Celsius Scale.
The TextBox2 display the value of the Scroll
Bar in the Fahrenheit scale.
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TASK 5: Use a Spin button control.

1 Click on the Developer menu item.

2 Click on the Developer menu item.

3 Click on the Visual Basic of the developer ribbon.

6 Set the properties of the controls as in Table 3.

4 Click on the Insert menu and select User Form.

5 Add the controls in the UserForm1 as shown Fig. 8

7. Type the following code in SpinButton1_Change
event.

Private Sub SpinButton1_Change()

TextBox1.Value = SpinButton1.Value

End Sub

8. Type the following code in TextBox1_AfterUpdate
event.

Private Sub TextBox1_AfterUpdate()

SpinButton1.Value = TextBox1.Value

End Sub

9 Run UserForm1 by Pressing F5 key.

10 Enter a Number in the TextBox1, for ex. 35.

11 Click on Upward/downward triangle in the Spin
Button.

The TextBox1 value is incremented by 1 each
time the upward triangle on the spin button is
clicked.
The TextBox1 value is decremented by 1 each
time the downward triangle on the spin button
is clicked.
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Fig 8

   Table 3
User Form control Name Caption Min. Max             Value

SpinButton1 SpinButton1 - 1 100                  -

TextBox1 TextBox1 - - -                    1

Lable1 lblAge Age - -                    -
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5 Set the properties of the controls as in Table 4.

User Form Controls Name          Caption

CommandButton1 CommandButton1            -

CommandButton2 CommandButton2            -

Lable1 lblColorValue            Enter a value between from 0 to 65535

TextBox1 TextBox1

       Table 4
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TASK 6: To insert and use Text Box and Labels in a User Form.

1 Click on the Developer menu item.

2 Click on the Visual Basic of the developer ribbon.

3 Click on the Insert menu and select User Form.

4 Add the controls in the UserForm1 as shown Fig. 9

Fig 9
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7 Type the following code in the code window.

Private Sub CommandButton1_Click()

Me.BackColor = TextBox1.Value

End Sub

Private Sub CommandButton2_Click()

Me.BackColor = -2147483633 ‘Default color of User
form

     TextBox1.Value = “”

End Sub

8 Run the User form.

9 Enter color value of User form in the Textbox1

10 Click the Command button1, See the result.

11 Click Command button2 to set default color for User
form and TextBox1 value is cleared.

IT & ITES : COPA - (NSQF- 4) Exercise 2.2.105A
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IT & ITES                                                                                          Exercise 2.2.105B
COPA - Programming with VBA

Work with Form controls like List Box and Combo Box controls
Objectives: At the end of this exercise you shall be able to
• create a list box and add items to it.
• to Add Items, Delete Items and Clear List Box.
• to Create combo box, Add items, Delete items, Clear all the items.

PROCEDURE

TASK 1:  Create a list box and add items to it.

1 Click on the Developer menu item.

2 Click on the Visual Basic of the developer ribbon.

3 Click on the Insert menu and select User Form.

4 Add the controls in the UserForm1 as shown Fig. 10

Fig 10
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5 Set the controls properties as shown in table 5.

      Table 5

User form control Name property  Other properties Caption

ListBox1 ListBox1          -

Label1 Label1 Sector Names

Label2 Label2 No. of Items

CommandButton1 CommandButton1 Display Sector Names

CommandButton2 CommandButton2 Display List Count

TextBox1 TextBox1        MultiLine= True

6 Double click the CommandButton1 and add the
following code in code window.

Me.ListBox1.AddItem “AUTOMOBILE”

Me.ListBox1.AddItem “BEAUTY & WELLNESS”

Me.ListBox1.AddItem “ELECTRONICS”

Me.ListBox1.AddItem “PRODUCTION”

Me.ListBox1.AddItem “IT & ITESM”

7 Double click the CommandButton2 and add the
following code in code window.

Me.TextBox1.Value = “Total Number of Items in
the List Box : “ & ListBox1.ListCount

8 Run the user form.

9 Click CommandButton1 and verify the result.

10 Click CommandButton2 and verify the result (Refer
Fig. 11)
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TASK 2:  To Add items, Delete items and Clear List Box items.
1 Click on the Developer menu item.

2 Click on the Visual Basic of the developer ribbon.
3 Click on the Insert menu and select User Form.

4 Add the controls in the UserForm1 as shown Fig. 12

5 Set their properties as shown in Table 6.
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       Table 6

User form control Name property Other Property Caption

ListBox1 lstSectorNames

TextBox1 txtNoOfItems

TextBox2 txtItemToBeAdded

CommandButton1 cmdDisplaySectorNames DisplaySectorNames

CommandButton2 cmdDisplayListCount DisplayListCount

CommandButton3 cmdAddItem Add Item

CommandButton4 cmdDeleteItem Delete Item

CommandButton5 cmdClearList Clear List

Label1 lblSectorNames SectorNames

Label2 lblNoOfItems No. of Items

Label3 lblItemsToBeAdded Type the item to

be added

Fig 12
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11   Click Display Sector Names and see the Sectors in the ListBox1 as shown in Fig. 13.
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12 Click Display List Count Button and Number of Items in ListBox1 will be displayed  in the txtNoOfItems text box
as shown in Fig 14.

Fig 13

Fig 14
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13 Type the following Sector Name “Fittings” in TextBox2 and click AddIteamButton (The item will be added to
the lstSectionNames List Box as Show in Fig. 15.
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14 Select “Electronics” item in the lstSectorNames  List Box and Click  Delete Item Command Button. (The Item will
be deleted as shown in Fig. 16.)

Fig 16

Fig 15
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15 Click cmdClearList Button to clear all the items as shown in Fig. 17.

All the lstSectorNames List Box Items are cleared.

TASK 3:  To Create combo box, Add items, Delete items, Clear all the items.
1 Click on the Developer menu item.

2 Click on the Visual Basic of the developer ribbon.

3 Click on the Insert menu and select User Form.

4 Add the controls in the User Form as shown in
Fig18

Fig 17

Fig 18
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5 Set their properties as shown in Table 7

Table 6

User form control Name property Caption

Label1 lblTrades Trades

Label2 lblItemToBeAdded Type item to be add and click the Add Item Button

ComboBox1 cboTradeNames

TextBox1 txtItemToBeAdded

CommandButton1 cmdAddItem Add Item

CommandButton2 cmdDeleteItem Delete Item

CommandButton3 cmdClearList Clear List

6 Double click cmdAddItem button and add following code
in the cmdAddItem's  Click event procedure

Private Sub cmdAddItem_Click()

cboTradeNames.AddItemtxtItemToBeAdded.Text

End Sub

7  Double click cmdClearList button and add following
code in the cmdClearList's  Click event procedure

Private Sub cmdClearList_Click()

cboTradeNames.Clear

End Sub

8 Double click cmdDeleteItem button and add
following code in the cmdDeleteItem's  Click event
procedure

Private Sub cmdDeleteItem_Click()

               cboTradeNames.RemoveItemcboTradeNames.ListIndex

cboTradeNames.Text = ""

End Sub

9 Type the following code in UserForm_Activate()
 event.

Private Sub UserForm_Activate()

ComboBox1.AddItem “COPA”

ComboBox1.AddItem “FITTER”

ComboBox1.AddItem “WELDER”

ComboBox1.AddItem “TURNER”

End Sub

10 Run the UserForm.

11 Click ComboBox1’s Triangle button. (This will
display all the items in the drop down list box) as
shown in Fig. 19

12 Click cmdClearList  to clear list in the Combo
Box, verify the result.

13 Select any one item from the Combo box.

14 Click on the Delete Item button and verify the result.

15 Type a new trade in txtIteamToBeAdded text box
and click cmdAddIteam commad Button and verify
the result.

Fig 19
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IT & ITES                                                                                          Exercise 2.2.105C
COPA - Programming with VBA

Work with Form controls like Check Box and Option Button
Objectives: At the end of this exercise you shall be able to
• create and use check box and option button controls.

PROCEDURE

TASK 1 :  Create and use checkbox and option
button controls.

1 Click on the Developer menu item.

2 Click on the Visual Basic of the developer ribbon.

3 Click on the Insert menu and select User Form.

4 Add the controls in the UserForm1 as shown Fig. 1.

5 Set the properties of the controls in the User form as
shown in Table 1.

Form control Caption

Frame1

OptionButton1 Vegeterian

OptionButton2 Non-Vegetarian

CheckBox1 Tamil

CheckBox2 English

CheckBox3 Hindi

CommandButton1 Ok

  Label1 Getting User Information

        Table 1

Fig 1
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6 Double click OK Button and entre the following
code.

Dim strUserInfoAs String

strUserInfo = “You are a “

    If OptionButton1.Value = True Then

strUserInfo = strUserInfo& OptionButton1.Caption

    End If

    If OptionButton2.Value = True Then

strUserInfo = strUserInfo& OptionButton2.Caption

    End If

strUserInfo = strUserInfo& “ and You Know “

    If CheckBox1.Value = True Then

strUserInfo = strUserInfo& CheckBox1.Caption

    End If

    If CheckBox2.Value = True Then

strUserInfo = strUserInfo& “,” & CheckBox2.Caption

    End If

    If CheckBox3.Value = True Then

strUserInfo = strUserInfo& “,” & CheckBox3.Caption

    End If

MsgBox “User Information” & strUserInfo & “Language
(s)” , vbOKonly

7 Select any one option button and select any two
check boxes as shown in Fig. 2.

8 Click Ok button.

9 The output is as shown in the Fig. 3.
10 Verify the result.
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Fig 2

Fig 3
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IT & ITES                                                                                           Exercise 2.2.106A
COPA - Programming with VBA

Work with Form Properties
Objectives: At the end of this exercise you shall be able to
• create user forms
• modify user form properties at design time
• to place controls on a sheet and write code to perform calculations.

PROCEDURE

TASK 1 : Create a user form

1 Click on the Developer tab in the Excel Window.

2 Click on the Visual Basic Button.

This opens the Visual Basic for Applications
(VBA) Window.

3 In the VBA Window, Click on the Insert button.

4 Select the UserForm option from the choices.

This displays a User Form, ToolBox and also
the properties window of the UserForm (Refer
Fig 1)

Fig 1

TASK 2 : Modify the User form properties at design time.

Before starting the exercise, save a picture of
your choice in an allowed location for use in
the form, ex. a photograph of the institute or a
logo etc.

1 Click on the "Name" property of the UserForm, and
change its value to "Frm1".

There should be no spaces in the Form Name
property value, underscores are allowed.

2 Click on the "Caption"  property and change its value
to "COPA Form"
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3 Click on the “Back Color” property of the from and
change  its value to a new color of your choice, for ex.
yellow by choosing it from the Palette.

4 Change the “Height” and “Width” property values by
dragging the sizing handles of the form.

5  Check the effect of changing the from size on the
values of “ Height” and  “Width” property values in the
from properties window.

6 Run the form by clicking on the Run button,or using
the function key F5,or clicking on the green triangle
icon for “Run” (Refer Fig 2)

7 Change the values of the “Left” and “Top” Property
values in the properties window of the form to 200 and
400 respectively in desing mode.

8 Run the form again and check the difference in the
location of the  form compared to the earlier one.

9 Click on the three dots in the “Picture” property value
text box.

The load picture Window appears.

10 Select the required picture from the location known to
you and open it by double clicking/ clicking on the
“open” button.

The picture appears on the Form (Refer Fig 3)

11 Change the “Picture Alignment” property value to
different values from the options offered and check the
effect.

12 Change the “PictureSizeMode” property value to 1,ie.
Stretch mode and check the effect.

13 Change the “PictureSizeMode” property value to 3,ie.
Zoom mode and check the effect.

14 Change the “PictureTiling” property value to “True”
and check the effect.

15 Change the “ScrollBars” property value to 2,3 and 4
one by one and check the effect in each case.

Fig 3

Fig 2
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PROCEDURE

TASK 1 : Access worksheet properties

IT & ITES                                                                                           Exercise 2.2.106B
COPA - Programming with VBA

View and Modify Worksheet Properties
Objectives: At the end of this exercise you shall be able to
• access worksheet properties
• change the sheet properties
• hide and unhide sheets
• set Cell values through code.

1 Create a new Worksheet.

2 Click on the View menu item.

3 Click on the Macros button from the View ribbon.

4 Select the record macro option.

5 Give the name of the macro as "Sheet_name" and
press OK.

6 Click the Macros button on the view ribbon and select
"Stop recording".

7 Open the VBA code window.

8 Expand the "Modules" object in the VBA project
window.

9 Double Click Module 1.

An empty procedure for the macro
"Sheet_name" appears in the code window.

10 Type the following code in the procedure for the macro
"Sheet_name".

Msgbox ("The name of this sheet is  "&
Worksheets(1).name)

11 Open the Excel Worksheet.

12 Insert a command button on the worksheet.

The Assign Macro window pops up when a new
control is placed on the worksheet.

13 Select the macro "Sheet_name" and click OK.

14 Change the text on the Command button to "Sheet
name".

15 Click on the "Sheet name " button and check the result.
Refer Fig 1.

Method 2. Creating a Button control first and writing code
for the Button _Click() event to view the sheet properties.

1 Type the following code in the code window for Module1.

Sub Button2_Click()

MsgBox (Worksheets.Count)

End Sub

2 Open the Worksheet.

3 Insert a command button on the worksheet.

The Assign Macro window pops up showing
the name of the new macro as "Button1_Click".

4 Click OK.

5 Click the text on the Button1 as "Sheet Count"

6 Click on the button "Sheet Count" and check the result.
(Refer Fig 2)

Fig 1

Fig 2

7 Insert a new worksheet.

8 Click on the button Sheet count again and verify the
result.

The message box shows the sheet count as 2
now since a new sheet has been added.
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9 Close the worksheet2.

10 Add the following code in the VBA module 1.

Sub Button2_Click()

MsgBox ("The number of columns in this sheet is
"& Worksheets(1).Columns.Count)

End Sub

11 Open the Worksheet.

12 Add another button to the worksheet1.

13In the Assign Macro window select the name
Button2_Click and press OK.

14 Change the button2 text to " Columns count"

15 Exit design mode and click on the button "Columns
count" and verify the result.(Refer Fig 3)

16  Add the following code in the VBA module 1

 Sub Button3_Click()

Sheets("Sheet1").Name = "Mark Sheet"

 End Sub

17 Insert a command button (Button3) on the worksheet

18  In the assign macro window select the name
 Button3_Click and click OK.

19  Change the text of Button3 button to "Rename Sheet".

20  Exit design mode and click on the "Rename Sheet"
 Button and verify the result.

 The sheet is renamed to "Mark List"

The sheet is renamed to "Marks Sheet"

Fig 3

TASK 2 : Change the sheet properties

1 Write the following code in the module1 code window.

Sub format_sheet()

Range("A1").Interior.ColorIndex = 8

Range("C1: C10").Cells.Font.Color = vbRed

Range("C1: C10").HorizontalAlignment = xlCenter

Worksheets("Sheet1").Columns(3).Font.Bold = True

Worksheets("Sheet1").Rows(3).Font.Italic = True

Worksheets("Sheet1").Rows(4).Interior.ColorIndex = 4

Worksheets("Sheet1").Columns(2).Interior.ColorIndex
= 7

Worksheets("Sheet1").Columns(4).Interior.Color =
vbYellow

Worksheets("Sheet1").Columns(6).Interior.Color =
RGB(200, 100, 100)

End Sub

2 Insert a command button on the worksheet.

3 Assign the macro format_sheet() to this button.

4 Change the text of the button to "Format".

5 Exit the design mode and click on the Format Button.

6 Verify the results.

The worksheet cells, columns and rows
colours, font will change as written in the
program.

7 Add the following code in the VBA module 1.

Sub orientation()

Dim n As Integer

n = InputBox("Enter the page orientation: 1 for Portrait,
2 forlandscape")

If n = 2 Then

ActiveSheet.PageSetup.orientation = xlLandscape

Else

ActiveSheet.PageSetup.orientation = xlPortrait

End If

End Sub

10 Add a Button to the form.

11 Assign the macro "orientation" to this button.

12 Change the button text to "Orientation"

13 Click on the "Orientation  Button" and verify the result.
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An input box prompts you to enter the
orientation in the form of 1 or 2

Based on the option entered, the page
orientation is changed.

TASK 3 : Hide and unhide sheets

1 Add three more worksheets (for ex. sheet2, sheet3
and sheet4) to the workbook.

2 Write the following codein the module1 code window.

Sub show_form()

Dim s As String

s = InputBox("enter sheet number to be shown,
except 1")

If Worksheets("Sheet" & s).Visible = False Then

Worksheets("Sheet" & s).Visible = True

End If

End Sub

Sub hide_form()

Dim s As String

s = InputBox("enter sheet number to be shown,
except 1")

If Worksheets("Sheet" & s).Visible = True Then

Worksheets("Sheet" & s).Visible = False

End If

End Sub

3 Add a Button control to the sheet.

4 Assign the show_form() macro to it.

5 Change the Button text to Show Form.

6 Click on the button and verify the result.

7 Add a Button control to the sheet.

8 Assign the hide_form() macro to it.

9 Change the Button text to Hide Form.

10 Click on the button and verify the result.

Based on the sheet number option provided
in the input box, the sheet will be closed or
opened if not done so already.

TASK 4 : Set Cell values through code.

1 Write the following code in the module1 code window.

Sub set_values()

'Set value of cell A1

Dim n As Integer

n = InputBox("Enter a value for cell A1")

Range("A1").Value = n

'Set value of Cell

n = InputBox("Enter a value for cell B1")

Cells(1, 2).Value = n

'Set value of a range

n = InputBox("Enter a value for cells C1 to C10")

Range("C1: C10").Value = n

'Set value of a range

n = InputBox("Enter a value for Row 11, column 1 to
4")

Range(Cells(11, 1), Cells(11, 4)).Value = n

End Sub

2 Add a Button control to the sheet.

3 Assign the set_values() macro to it.

4 Change the Button text to Set values.

5 Click on the button and verify the result.

The values of cells will be set as per the
program and values provided at run time by
you.

The layout of all the buttons in the sheet for
Ex.No 2.2.106 B should be similar to that in
Fig 4.
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Fig 4
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IT & ITES                                                                                           Exercise 2.2.107A
COPA - Programming with VBA

Practice with Data types, Variables, and Constants in VBA - I
Objectives: At the end of this exercise you shall be able to
• create integer variables and performs Addition, Subaction, Multiplication and Division on variables
   in VBA
• use and compare nature of single and double data type variables
• use the Byte data type variables
• use Boolean type variables
• use the Option Explicit Statement
• write and test VBA programs to solve problems.

1 Type the following code in module1  code window.

Sub test1()

    Dim x, y As Integer

    x = 22

    y = 5

Debug.Print "Value of x is:" & x

Debug.Print "Value of y is:" & y

Debug.Print "Sum of x and y is:" & x + y

Debug.Print "Difference of x and y is:" & x - y

Debug.Print "Product of x & y is:" & x * y

Debug.Print "Division of x & y:" & x / y

Debug.Print "Negation of x is:" & -x

End Sub

TASK 2 : Use and Compare the nature of Single and Double Data type Variables

PROCEDURE

TASK 1 : Create integer variables and performs Addition, Subaction, Multiplication,Negation and Division on
  variables in VBA

1 Type the following code in the code window.

Sub test2()

Dim a As Single

Dim b As Single

Dim c As Double

a = 3.143

b = 22 / 7

Debug.Print "value of single type variable a is :" & a

Debug.Print "value of single type variable b is :" & b

c = 22 / 7

Debug.Print "value of double type variable c is :" & c

End Sub

2 Run the code from the immediate window by entering
the name of the Sub, ie. test2

3 Check the result in the Immediate Window. (Refer Fig.
2)

Fig 2

2 Run the code from the immediate window by typing
the name of the procedure, ie. test1.

3 Check the results in the Immediate Window.(Refer Fig
1)

   To comment a line of text in VBA prefix it with a
single quote or apostrophe. The commented line
appears in green colour font.

Fig 1



106

4 Type the following module 1 code in the code window.

Sub test3()

Dim radius As Double

Dim circum1 As Single

Dim circum2 As Double

Dim area As Double

radius = 4

circum1 = 2 * 22 / 7 * radius

area = 3.14 * radius ̂  2

'Here the ̂  symbol is used to raise radius to the power
2

'The same value is now stored as a double precision
number

circum2 = circum1

Debug.Print "value of radius is :" & radius

Debug.Print "value of circumference as a single
precision number is :" & circum1

Debug.Print "value of circumference as a double
precision number is :" & circum2

Debug.Print "value of area is :" & area

End Sub

5 Run the code from the immediate window by tying the
name of the subroutine in the immediate window.

6 Check the result in the Immediate Window. (Refer Fig.
3)

TASK 3 : Use the Byte data type variables

Fig 4

Fig 5

Fig 3

1 Type the following code in the code window.

Sub testbyte()

Dim x As Byte

x = 145

Debug.Print "value of x is :" & x

End Sub

2 Run the code using from the immediate window..

3 Check the result in the Immediate Window. (Refer Fig.
4)

4 Assign an out of range value to x by changing the
value of x to 256

5 Run the code using from the immediate window.

6 Check the result in the Immediate Window. (Refer Fig.
5)

An error message appears indicating that an
out of range value has been assigned to a
variable.(Refer Fig 5)
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Fig 6

Fig 7
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TASK 4 : Use Boolean type variables

1 Type the following code in the code window.

Sub testbool()

Dim x As Boolean

Debug.Print "The default value of Boolean x is : " & x

'Assign a value of 0 to x

x = 0

Debug.Print "Now the value of Boolean x is : " & x

'Assign a value of "False" to x

x = False

Debug.Print "Once again the value of Boolean x is :
" & x

'Assign a value of 1 to x

x = 1

Debug.Print "Now again the value of Boolean x is : "
& x

'Assign a value of "True to x

x = True

Debug.Print "Once again the value of Boolean x is :
" & x

End Sub

2 Run the code from the immediate window

3 Check the result in the Immediate Window. (Refer Fig.
6)

TASK 5 : Use the Option Explicit Statement

1 Type the following code in the code window.

Option Explicit

Sub test1()

Dim x As Byte

x = 1

y = 2

Debug.Print "The value of x is : " & x

Debug.Print "The value of y is : " & y

End Sub

This program will result in an error as the
variable y has not been declared and the use
of the statement "Option Explicit" will force
variables to be declared.

2 Run the code from the immediate window.

3 Check the error statement. (Refer Fig 7)
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TASK  6  : Write and test VBA programs to solve problems

1 Write the code, execute and verify the results for the
following situations:

a Ask the user for a temperature value in Celsius (C
)and convert it to Fahrenheit(F) value.

Hint :Formula is F =C × 9/5 + 32

b Ask the user to input a value in inches and convert it
to cms.

Hint : Formula is 1 inch = 2.54 cms

c Ask the user to input a value in miles and convert it to
kilometers.

Hint : Formula is 1 Mile = 1.609344
KilometersHint :

d Ask the user to input the value of the side of a cuboid
and display the total surface area and volume of the
cuboid.

Formula for total surface area of cuboid = 6*
l2

Formula and formula forVolume of cube = l ×
l × l



109

Fig 3

IT & ITES                                                                                           Exercise 2.2.107B
COPA - Programming with VBA

Practice with Data types, Variable, Constants and Operators in VBA - II
Objectives: At the end of this exercise you shall be able to
• concatenate strings
• use the currency and data type in VBA
• use the Date data type in VBA
• use the Variant data type in VBA
• use the Variables without data type in VBA
• create and use enumerated data type variables.

PROCEDURE
TASK 1:  Concatenate Strings
1 Type the following code in the module1 code window.

Sub teststring()

Dim fname As String

Dim lname As String

fname = "Vidya"

lname = "Nidhi"

Debug.Print "First name is :" &fname

Debug.Print "Last name is :" &lname

Debug.Print "LFull name is :" &fname& " " &lname

End Sub

2 Run the code from the immediate window..

3 Check the result in the Immediate Window. (Refer Fig
2)

Fig 2

TASK 2 : Use  the Currency data type in VBA

1 Type the following code in the code window.

Sub test_cur()

Dim Months As Integer

Dim profit, total_profit As Currency

Months = 12

profit = 5000000

Debug.Print "Profit per month is :" & profit

Debug.Print "Annual profit is :" & profit * Months

End Sub

2 Run the code from the immediate window.

3 Check the result in the Immediate Window.
(Refer Fig 3)



110

TASK 4 : Use the Date data type in VBA

1 Type the following code in the code window.

Sub test_date()

Dim birthday As Date

birthday = #1/1/1990#

Debug.Print "My birthday is :" & birthday

End Sub

2 Run the code from the immediate window.

TASK 5 : Use the Variant data type in VBA

Fig 4

Fig 5

1 Type the following code in the code window.

Sub test_variant()

Dim name As Variant

Dim age As Variant

Dim joiningday As Variant

Dim salary As Variant

name = "Vijay"

age = 18

joiningdate = #1/1/2014#

salary = 100000

Debug.Print "Name is :" & name

Debug.Print "Age is :" & age

Debug.Print "Salary is :" & salary

Debug.Print "Joining Date is :" &joiningdate

End Sub

2 Run the code from the immediate window.

3 Check the result in the Immediate Window. (Refer Fig
5)

TASK 6 : Use the Variables without data type in VBA

1 Type the following code in the code window.

Sub notype()

Dim name

Dim age

Dim joiningday

Dim salary

name = "Kiran"

age = 18

joiningdate = #1/1/2014#

salary = 100000

Debug.Print "Name is :" & name

Debug.Print "Age is :" & age

Debug.Print "Salary is :" & salary

Debug.Print "Joining Date is :" &joiningdate

End Sub

2 Run the code from the immediate window.

3 Check the result in the Immediate Window. (Refer Fig
6)

Fig 6
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3 Check the result in the immediate window. (Refer Fig
4)
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TASK 7 : Create and Use Enumerated Data type variables

1 Type the following code in the code window.

EnumFruitType

        [_First] = 1

        Apple = 1

        Orange = 2

        Plum = 3

        [_Last] = 3

End Enum

Sub test()

    Dim N As Long

    Dim IsValidAs Boolean

    Dim Fruit AsFruitType

    Fruit = InputBox("Enter Fruit Value", "Fruit value input")

    For N = FruitType.[_First] To FruitType.[_Last]

        If Fruit = N Then

IsValid = True

            Exit For

        End If

    Next N

    If IsValid = True Then

Debug.Print Fruit &" is a valid value for a Fruit."

    Else

Debug.Print Fruit &" is not a valid value for a Fruit."

    End If

End Sub
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2 Run the code from the immediate window.

3  Enter value1 in the inout box, the output will be as
follows.

1 is a valid value  for a fruit.

4 Run code again from immediate window.

5   Enter value 6 in the inout box, the output will be as
follows.

6 is a valid value for a fruit.
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IT & ITES                                                                                           Exercise 2.2.108
COPA - Programming with VBA

Create Message Boxes and Input Boxes in VBA
Objectives: At the end of this exercise you shall be able to
• display string data through MsgBox
•  use Input box to get numeric data
• use  Input box to get string  data

PROCEDURE

Fig 3

TASK 1: Display string data through MsgBox

1 Open the Visual Basic Window in Excel.

2 Insert a module.

3 Type the following code in module1 code window.

Sub test_messagebox()

Dim strNameAs String

strName = “Kumaravel K”

MsgBox “Your Name is : “ &strName, vbOKOnly, “Your
Name”

End Sub

4 Run the code from the immediate window.

TASK 2 : Use Input box to get numeric data

1 Open the Visual Basic Window in Excel.

2 Insert a module.

3 Write the following code in the code window.

Sub test_inputbox()

Dim age As Integer

age = Application.InputBox(Prompt:="Please enter
yourage.", Title:="AGE DETAILS", Type:=1)

'Type:=1 is for collecting a Numeric data type.

Debug.Print "Your age is :" & age

End Sub

4 Run the code from the immediate window.

An Input Box is displayed as shown in Fig 2.

5 Enter the age and click "OK"

6 Check the result in the immediate window. (Refer Fig
3)

Fig 1

Fig 2
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Fig 4

Fig 5

TASK 3 : Use  Input box to get string  data

1 Write the following code in the module1 code window.

Sub test2()

Dim name As String

name = InputBox(Prompt:="Your name please.",
Title:="NAME DETAILS", Type:= 2 )

‘Type := 2 for text output

Debug.Print "Your name is :" & name

End Sub

2 Run the code from the immediate window.

An Input Box is displayed as shown in Fig 4.

3 Enter your name in the Text Box of the Input Box and
Click the OK button.

4 Check the result in the Immediate Window. (Refer Fig
5)

IT & ITES : COPA -  (NSQF- 4)  Exercise 2.2.108
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IT & ITES                                                                                           Exercise 2.2.109A
COPA - Programming with VBA

Practice with Conditional Statements simple if and IF.....Then......Else
Objectives: At the end of this exercise you shall be able to
• use the IF statement for decision making in VBA programs
• use the IF .....Then....Else statement for decision making in VBA programs
• use the multiple IF....Then.....Else statements for decision making in VBA programs.

PROCEDURE

TASK 1 : Use the IF statement for decision making in VBA programs

1 Open the Visual Basic Window in Excel.

2 Insert a new module.

3 Type the following code in the Module1 code window.

Sub test_if()

 Dim mark As Integer

mark = Application.InputBox(Prompt:="Enter Your
Mark:", Title:="Entry of Mark", Type:=1)

    'Check if mark is below 45

    If (mark < 45) Then

Debug.Print "Sorry, You have failed to clear test! (Your
mark is less than 45)"

    End If

End Sub

4 Run the code from the immediate window.

An Input Box is displayed prompting the user
to enter the mark as shown in Fig 1.

5 Enter the marks in the text box and Click "OK".

6 Check the result in the immediate window.
(Refer Fig 2)

Fig 1

TASK 2 : Use the IF … Then… Else statement for decision making in VBA programs.
1 Type the following code in the Module1code window.

Sub ifelse()

Dim marks As Integer

'Accept marks from the user through InputBox

marks = Application.InputBox(Prompt:="Enter your
marks", Title:="MARKS DETAILS", Type:=2)

Debug.Print "Your marks are :" & marks

'Check if marks are below 45 to declare the result

If (marks < 45) Then

Debug.Print "Sorry, Try Again !"

Fig 2

Else

Debug.Print "Congratulations, You have passed the
test"

End If

End Sub

2 Run the code from the immediate window.

An Input Box is displayed prompting the user
to enter the marks
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3 Enter a value for marks in the TextBox for ex. 78 and
click the OK Button.

4 Check the result in the immediate window.
(Refer Fig 3)

TASK 3 : Use the " MultipleIf ..then..Elseif" statements for Decision making in VBA

1 Type the following code in the Module1code window.

Sub testif2()

Dim marks As Integer

marks = Application.InputBox(Prompt:="Enter your
marks", Title:="MARKS DETAILS", Type:=1)

Debug.Print "Your marks are :" & marks

'Check if marks are greater than or equal to 80 for
distinction

If (marks >= 80) Then

Debug.Print "You have passed with Distinction !"

'Check if mark  is between 60 and 79 for A grade

ElseIf (marks >= 60) Then

Debug.Print "You have passed with A grade"

'Check if mark  is between 40 and 59 for B grade

ElseIf (marks >= 40) Then

Debug.Print "You have passed with B grade"

Else

'Check if mark is lesser than 40 and declare result
as failed

Debug.Print" Sorry, You have failed "

End If

End Sub

2 Run the code from the immediate window.

An Input Box is displayed prompting the user
to enter the marks.

3 Enter a value for marks in the TextBox and click the
OK Button.

4 Check the result in the immediate window.
(Refer Fig 4)

5 Similarly test the program by entering different values
for marks and checking the result for each input.

Fig 4

Fig3
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IT & ITES                                                                                           Exercise 2.2.109B
COPA - Programming with VBA

Practice with Conditional Statements,Nested if, Select, Case, and IIF
Objectives: At the end of this exercise you shall be able to
• write and test a program using “Nested if” statements
• write and test programs for decision making with "If" along with "AND" operator
• write and test programs using the Select Case Statement in VBA
• write and test programs using the IIF Statement in VBA.

PROCEDURE

TASK 1 : Write and test a program using “Nested if” statements

1 Write the following code in the Module1 code window.

Sub nestedif(x, y, z As Integer)

Dim largest As Integer

Debug.Print "Value of x is :" & x

Debug.Print "Value of y is :" & y

Debug.Print "Value of z is :" & z

'Check for the largest value among x, y and z

 If (x > y) Then

If (x > z) Then

largest = x

Else: largest = z

End If

ElseIf (y > z) Then

largest = y

Else: largest = z

End If

Debug.Print "largest is :" & largest

End Sub

2 Enter the subroutine name followed by three
integers(separated by commas) in the immediate
window.

3 Press the enter key.

4 Check the result in the Immediate Window. (Refer Fig
1)

Fig 1

TASK 2 : Write and test programs for decision making with "If" along with "AND" operator

1 Type the following code in the Module1 code window.

Sub if_and(x, y, z As Integer)

Dim largest As Integer

Debug.Print "Value of x is :" & x

Debug.Print "Value of y is :" & y

Debug.Print "Value of z is :" & z

'Check for the largest value among x,y and z

 If (x > y) And (x > z) Then

largest = x

ElseIf (x > y) And (x < z) Then

largest = z

Else

largest = y

End If

Debug.Print "largest is :" & largest

End Sub
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2 Enter the subroutine name followed by three
integers(separated by commas) in the immediate
window.

3 Press the enter key.

4 Check the result in the Immediate Window. (Refer Fig
2)

Fig 2

TASK 3 : Write and test programs using the Select Case Statement in VBA

1 Write the following code in the Module1 code window.

Sub test_select(percentage As Integer)

Select Case percentage

Case 0 To 39

MsgBox ("Failed")

Case 40 To 49

MsgBox ("C Grade")

Case 50 To 59

MsgBox ("B Grade")

Case 60 To 79

MsgBox ("A Grade")

Case 80 To 100

MsgBox ("Distinction")

Case Else

MsgBox ("Invalid Marks Entry")

End Select

End Sub

2 Enter the subroutine name followed by the percentage
value) in the immediate window.

3 Press the enter key.

4 Check the result.(Refer Fig 3)

5 Test the program for different input values.

Fig 3

TASK 4 : Write and test programs using the IIF Statement in VBA

1 Write the following code in Module1 code window.

Sub test_iif(weight As Integer)

Dim result As String

result = IIf(weight > 25, "Heavy", "Light")

Debug.Print "The entered weight "& weight &" is very
" & result

End Sub

2 Enter the subroutine name followed by the percentage
value) in the immediate window.

3 Press the enter key.

4 Check the result.(Refer Fig.4)

5 Test the program for different input values.

Fig 4

IT & ITES : COPA -  (NSQF- 4)  Exercise 2.2.109B
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IT & ITES                                                                                           Exercise 2.2.109C
COPA - Programming with VBA

Practice with Application of Decision Making Statements
Objectives: At the end of this exercise you shall be able to
• write and test VBA program to find if the given number is even or odd
• write and test VBA program to calculate the wages
•  write and test VBA program to calculate the Income Tax of an individual.

PROCEDURE

TASK 1 : Write and test VBA program to find if the given number is even or odd

1 Write the program using the IF statement.

2 Accept the number from the immediate window or an
input box.

3 Execute the program and verify the results.

4 Write and test the same program using the IIF
statement.

TASK 2 : Write and test VBA program to calculate the wages

Problem Assessment:

a. The normal rate of payment of wages in a
workshop is Rs. X per hour.

b. The normal rate of wages are applicable only
upto a maximum of 40 working hours per
week.

c. For any extra hours of work, overtime
payment is at the rate of 1.5 times the normal
rate of payment.

1 Write a VBA program using IF statement for the
situation mentioned.

2 Accept the normal rate of payment from the user.

3 Accept the normal rate of wages from the user.

4 Execute the program and verify the results.

TASK 3 : Write and test VBA program to calculate the Income Tax of an individual.

Problem Assessment:

a The Income Tax is to be calculated for the
Taxable income for a financial year.

d The Income Tax slabs and rates of income
Tax for a particular Financial year are as
follows:

Taxable Income Rate of income tax

1. Upto 2.5 lakhs NIL

2. Above 2.5 Lakhs & 10 % of the taxable
upto 5 Lakhs income

3. Above  5 lakhs & 20 % of the Taxable
upto 10 Lakhs income

4. Above 10 Lakhs 30% of the Taxable
income

1 Write a VBA program using IF … Then…Else
statements for the situation mentioned.

2 Accept the taxable income from the user.

3 Execute the program and verify the results.

4 Rewrite the program using the Select … Case
Statement.

5 Execute the program and verify the results.
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IT & ITES                                                                                           Exercise 2.2.110A
COPA - Programming with VBA

 Looping Controls in VBA

Objectives: At the end of this exercise you shall be able to
• use the Do....Loop to perform repetitive tasks
• use the Do....Loop While statement for iterations
• use  the "Do … Until" statements to perform iterations
• perform Iterations using the "For" loop
• exit a loop using the  "Exit For" statement

PROCEDURE

TASK 1 : Use the “Do.....While” loop to perform repetitive tasks

1 Type the following code in the Module1code window.

'enter the number whose table is to be printed

Sub test_dowhile(n As Integer)

Dim i, j As Integer

i = 1

'keep going round the loop until the condition is true

Do While i<= 10

Debug.Print n; " X " &i& " = " &i * n

i = i + 1

Loop

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window. (Refer Fig
1)

Fig 1

TASK 2 : Use the Do …Loop While statement for iterations.

1 Type the following code in the Module1code window.

Sub test_do2()

Dim n As Integer

n = 10

Do

Debug.Print" You have only "& n & " attempts left !"

    n = n - 1

Loop While n > 0

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window. (Refer Fig
2)

Fig 2
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TASK 3 : Use  the "Do … Until" statements to perform iterations

1 Type the following code in the Module 1 code window.

Sub test_dountil()

Dim n As Integer

'The Do... Until tests a condition for "False" state

'The loop is repeated as long as the condition is
"False"

Do Until n >= 10

'by default n=0

n = n + 1

Debug.Print" This is your attempt No. " & n

Loop

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window. (Refer Fig
3)

Fig 3

TASK 4 : Perform Iterations using the "For" loop

1 Insert a new module in the Excel VBA window.

2 Type the following code in the Module1code window.

Sub test_for()

Dim n As Integer

For n = 0 To 10

Debug.Print " n is : " & n

Next n

End Sub

3 Run the code from the immediate window.

4 Check the result in the immediate window. (Refer Fig
4)

Fig 4

TASK 5 : Exit a loop using the  "Exit For" statement
1 Type the following code in the Module1code window.

Sub exit_for()
Dim n, sum As Integer
sum = 0
For n = 1 To 10
sum = sum + n
Debug.Print " sum is : " & sum
    If sum = 15 Then
Debug.Print "i should stop at 15"
        Exit For
     End If
Next n
End Sub

Fig 5

2 Run the code from the immediate window.

3 Check the result in the immediate window. (Refer Fig
5)

IT & ITES : COPA -   (NSQF- 4)  Exercise 2.2.110A
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IT & ITES                                                                                           Exercise 2.2.110B
COPA - Programming with VBA

Apply Loops in Providing Solutions
Objectives: At the end of this exercise you shall be able to
• use the loop control statements to print customized patterns
• perform calculation using the loop control statements
• generate tables of calculated values using loop statements.

PROCEDURE

TASK 1 : Use the loop control statements to print customized patterns

1 Write code using multiple For statements to generate
the following patterns:

a) b) c)

* * * * * * * * * *

* * * * * * * * * *

* * * * * * * * * *

* * * * * * * * * *

* * * * *

d) e) f)

1 1 1 1 1 1 1 0 1 0 1

2 2 2 2 2 2 2 0 1 0 1 0

3 3 3 3 3 3 3 3 1 0 1 0 1

4 4 4 4 4 4 4 4 4 0 1 0 1 0

g)

1

2 3

4 5 6

7 8 9 10

2 Execute the programs and verify the results.

TASK 2 : Perform calculations using the Loop statements.

1 Write code find the factorial of a supplied number.

2 Supply the input to the program.

3 Execute the program and verify the results.

4 Write code find if the supplied number is prime or not.

5 Supply the input to the program.

6 Execute the program and verify the results.

TASK 3 : Generate tables of calculated values using Loop statements.

1 Write programs using loops to generate a table as
shown. Refer Table 1.

2 Execute the program and verify the result.

3 Write a program to print area and circumference of a
circle for the radius from 1 to 8 as shown in table 2

4. Use Pi() value from excel worksheet function also use
round() function

5. Execute the program and verify the result.
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Number Square Cube

1 1 1

2 4 8

3 9 27

4 16 64

5 25 125

6 36 216

7 49 343

8 64 512

9 81 729

10 100 1000

Table 1

IT & ITES : COPA  - (NSQF- 4)  Exercise 2.2.110B

Table 2

 Radius Area Circumference

  1 3.14       6.28

  2 12.57      12.57

  3 28.27      18.85

  4 50.27      25.13

  5 78.54      31.42

  6 113.1      37.7

  7 153.94      43.98

  8 201.06      50.27
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IT & ITES                                                                                           Exercise 2.2.111A
COPA -  Programming with VBA

Create and Use One Dimensional Arrays
Objectives: At the end of this exercise you shall be able to
• create and use a one dimensional array by specifying the size
• create a one dimensional array by specifying lower and upper limits
• create an array with integers
• accept Array elements through a loop
• create an Array using the Array() function

PROCEDURE

TASK 1 : Create and use a one dimensional array by specifying the size

1 Insert a new module in Excel VBA window.

2 Type the following code in the Module1code window.

Sub test_array()

Dim classmate(5) As String

classmate(1) = "Uma"

classmate(2) = "Rama"

classmate(3) = "Reema"

classmate(4) = "Suma"

classmate(5) = "Garima"

For n = 1 To 5

Debug.Printclassmate(n)

Next n

End Sub

3 Run the code from the immediate window.

4 Check the result in the immediate window. (Refer Fig
1)

Fig 1

TASK  2 : Create a one dimensional array by specifying lower and upper limits

1 Type the following code in the Module1 code window.

Sub test_array2()

Dim subject(0 To 5) As String

subject(0) = "Hindi"

subject(1) = "Sanskrit"

subject(2) = "English"

subject(3) = "Science"

subject(4) = "Social Studies"

subject(5) = "Maths"

For n = 0 To 5

Debug.Printsubject(n)

Next n

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window. (Refer Fig
2)

Fig 2
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TASK 3 : Create an array with integers

1 Type the following code in the Module1 code window.

Sub num_array()
Dim n(5), i, sum As Integer
n(1) = 10
n(2) = 4
n(3) = 6
n(4) = 11
n(5) = 3
For i = 1 To 5
Debug.Print " Element no. " &i& " is "; n(i)
sum = sum + n(i)
Next i
Debug.Print "the sum of the array elements is : " &
sum
End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window. (Refer Fig
3 )

Fig 3

TASK 4 : Accept Array elements through a loop

1 Type the following code in the Module1 code window.

Sub array1_test()
Dim n(5), i, sum As Integer
For i = 1 To 5
n(i) = InputBox("enter the array element number "
&i)
Next i
For i = 1 To 5
Debug.Print " Element no. " &i& " is "; n(i)
sum = sum + n(i)
Next i
Debug.Print "the sum of the array elements is : " &
sum
End Sub

2 Run the code from the immediate window.

3 Enter the array elements in the Input boxes.

4 Check the result in the immediate window. (Refer Fig
4 )

Fig 4

TASK 5 : Create an Array using the Array() function

1 Type the following code in the Module1 code window.

Sub Test_Array3()
Dim A As Variant
A = Array("11", "25", "83", "60")
For i = LBound(A) To UBound(A)
Debug.Print A(i)
Next
End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window. (Refer Fig
5)

Fig 5
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IT & ITES                                                                                           Exercise 2.2.111B
COPA - Programming with VBA

Create and Use Dynamic Arrays
Objectives: At the end of this exercise you shall be able to
• create and use dynamic array
• change the array dimensions dynamically.

PROCEDURE

TASK 1 : Create and use dynamic array

1 Type the following code in the Module1 code window.

Sub dyna_array()

Dim names() As String

'Array without size specification

Dim i As Integer

'Change the array dimensions using ReDim to 4
elements

ReDim names(4)

names(0) = "Ganga"

names(1) = "Yamuna"

names(2) = "Narmada"

names(3) = "Sindhu"

names(4) = "Kaveri"

For i = 0 To 4

Debug.Print names(i); vbCrLf;

Next i

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window. (Refer Fig
1)

4 Add the following line of code to the program shown
above.

names(5) = "Godavari".

Fig 1

This tries to add a 6th element to an array
defined for five elements.

5 Check the result. (Refer Fig 2)

Fig 2

An array subscript out of range error message
is generated. To avoid this redefine the array
size and preserve data using ReDim and
preserve statement.

TASK 2 : Change the array dimensions dynamically

1 Add the Redim and Preserve statements to the
program as shown below.



126

Sub dyna_array()

Dim names() As String

Dim iAs Integer

ReDim names(4)

names(0) = "Ganga"

names(1) = "Yamuna"

names(2) = "Narmada"

names(3) = "Sindhu"

names(4) = "Kaveri"

For i = 0 To 4

Debug.Print names(i); vbCrLf;

Next i

ReDim Preserve names(5)

names(5) = "Godavari"

Debug.Print names(5)

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window. (Refer Fig
3)

Fig 3

IT & ITES : COPA - (NSQF- 4)  Exercise 2.2.111B
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IT & ITES                                                                                           Exercise 2.2.111C
COPA -  Programming with VBA

Create and Use Two Dimensional Arrays
Objectives: At the end of this exercise you shall be able to
• create and use a two dimensional array
• create a two Dimensional Array and Display its elements in the Excel sheet.
• create a Multi dimensional array and read its "LBound" and "UBound" values

PROCEDURE

TASK 1 : Create and use a two dimensional array

1 Insert a new module in the Excel VBA window.

2 Type the code in the Module1 code window as shown
if Table 1.

3 Run the code from the immediate window.

4 Check the result in the immediate window. (Refer Fig
1 )

Sub twod_array()
Dim row, col, myarray(3, 4) As Integer
'values for row  no. 1
myarray(0, 0) = 12
myarray(0, 1) = 14
myarray(0, 2) = 40
myarray(0, 3) = 24
'values for row  no. 2
myarray(1, 0) = 34
myarray(1, 1) = 62
myarray(1, 2) = 32
myarray(1, 3) = 80
'values for row  no. 3
myarray(2, 0) = 90
myarray(2, 1) = 60
myarray(2, 2) = 10
myarray(2, 3) = 11
For row = 0 To 2
For col = 0 To 3
'print the row data in the same row using the
semicolon
Debug.Print myarray(row, col); Spc(5);
Next col
'go to the next line before starting the next row data
printing
Debug.Print
Next row
End Sub

5 Change the code line

"Debug.Print myarray(row, col); "    to

" Debug.Print  myarray(row, col); Spc(5);"

Adding the function "Spc(5)" with semicolon
will allow printing of the next dta to be done
after 5 spaces.

6 Run the code from the immediate window.

7 Check the result in the immediate window.
(Refer Fig 2)

Fig 1

Fig 2
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1 Type the following code in the Module1 code window.

Sub marks_array()

Dim fname(3) As String, Admn_No(3) As String,
Marks(3) As Single

For i = 1 To 3

'Accept input values through Input Boxes for each
row

fname(i) = InputBox("Enter  Name")

Admn_No(i) = InputBox("Enter Admn. No.")

Marks(i) = InputBox("Enter Marks")

'Display the marks in the Excel sheet in the cells
mentioned here

Cells(i, 1) = fname(i)

Cells(i, 2) = Admn_No(i)

Cells(i, 3) = Marks(i)

Next

End Sub

TASK 2 : Create a two Dimensional Array and Display its elements in the Excel sheet.

2 Run the code from the immediate window.

3 Enter values for first name, Admn. No. and marks for
each row in the Input Boxes.

4 Check the result in the Excel Worksheet. (Refer Fig
3)

Fig 3

TASK 3 : Create a Multi dimensional array and read its "LBound" and "UBound" values

1 Type the following code in the Module1 code window.

Sub array_bounds()

Dim A(1 To 5)

Dim B(1 To 3, 0 To 4)

Dim C(0 To 2, 1 To 3, -1 To 6)

Debug.Print "Array A starts at "&LBound(A) & " and
ends at " &UBound(A)

Debug.Print "Array B starts at "&LBound(B, 2) & "
and ends at " &UBound(B, 2)

Debug.Print "Array C starts at "&LBound(C, 3) &"
and ends at " &UBound(C, 3)

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window. (Refer Fig
4)

Fig 4
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IT & ITES                                                                                           Exercise 2.2.112
COPA - Programming with VBA

Practice with String Variables
Objectives: At the end of this exercise you shall be able to
• use the string functions concatenation, chr(), len()
• perform case conversion of strings using Ucase() and Lcase() functions
• extract part of string using Left(), Mid() and Right() functions
• find the position of a substring in s string, use instr()
• perform string replacement using Replace()
• reverse the given string
• return a string with the leading and trailing spaces removed.

PROCEDURE

TASK 1 : Use the string functions concatenation, Chr(), Len()

1 Type the following code in the Excel Module1code
window.

' Concatenation of Strings using "+" and "&" operators

Sub concate_string()

    'Concatenation strings using "+" and "&" operators

    Dim fname, lname, fullname As String

fname = "Pon"

lname = "Nila"

    'concatenation using "+" operator

fullname = fname + lname

Debug.Print "First name is:" &fname

Debug.Print "Last name is:" &lname

Debug.Print "Full name is:" &fullname

    'concatenation using "&" operator

fname = "Pon"

lname = "Suriyan"

fullname = fname&lname

Debug.Print "First name is:" &fname

Debug.Print "Last name is:" &lname

Debug.Print "Full name is:" &fullname

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 1)

4 Type the following code in the Module1code window.

'Getting the Character for a given ASCII Code

Sub test_ascii()

Dim ascii_code As Integer

Dim c As String

ascii_code = 65

c = Chr(ascii_code)

Debug.Print "The ASCII character for the asciicode
"&ascii_code&" is " & c

End Sub

5 Run the code from the immediate window.

6 Check the result in the immediate window.
(Refer Fig 2)

Fig 2

7 Type the following code in the Module 1code window.

'Getting the length of a given string

Sub test_len()

Dim length As Integer

Dim str As String

str = "Time is Money"

length = Len(str)

Debug.Print "The length of the stringis  "& length

End Sub

8 Run the code from the immediate window.

9 Check the result in the immediate window.
(Refer Fig 3 )

Fig 1
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Fig 3

10 Type the following code in the Module 1 code window.

'This program returns the size of the data types used.

This program returns the size of the data types used.

Sub test_size()

    Dim s As String, a As Byte, b As Integer, c As
Double

    s = "Govt. ITI, CPT"

    a = 123

    b = 9999

    c = 10

Debug.Print "Size of s is "& Len(s)

Debug.Print "Size of a is " &Len(a)

Debug.Print "Size of b is "& Len(b)

Debug.Print "Size of c is "& Len(c)

End Sub

11 Run the code from the immediate window.

12 Check the result in the immediate window.
(Refer Fig 4 )

Fig 5
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Fig 4

TASK 2 : Perform case conversion of strings using Ucase() and Lcase() functions
1 Type the following code in the Module1code window.

'Changing the case of a given string

Sub change_case()

Dim A, B As String

A = " upper case letters"

B = " LOWER CASE LETTERS"

Debug.Print A &" is now converted to "&UCase(A)

Debug.Print B &" is now converted to "&LCase(B)

End Sub

TASK 3 : Extract part of strings using Left(), Mid() and Right() functions

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 5)

1 Type the following code in the Module1code window.

'Extracting part of a given string

Sub extract_string()

    Dim A, B As String

    A = "Government"

    B = "Delhi-City"

Debug.Print "The Left six characters of the string "&
A & " are " & Left(A, 6)

Debug.Print "The Right four characters of the string
"& A & " are " & Right(A, 4)

Debug.Print "The string "& B & " starting from position
2 is " & Mid(B, 2)

Debug.Print "The string "& B & " starting from position
2 and 4 characters long is " & Mid(B, 2, 4)

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 6)
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TASK 4 : Find the position of a substring in s string, use instr()

1 Type the following code in the Excel VBA Module 1 code window.

'Finding the position of a substring in a string, use
Instr.

Sub find_string_pos()

Dim strString As String, strStringToBeFind As String,
intPos As Integer

strString = "Computer Operator"

'Search from the begining

intPos = InStr(1, strString, "Opera")

Debug.Print "The string 'Opera' appears at position
"&intPos& " in the main string " & "'" &strString& "'"

intPos = InStr(strString, "ter")

'here starting position is not mentioned, hence default
search from 1st character

Debug.Print "The string 'ter' appears at position
"&intPos& " in the main string " & "'" &strString& "'"

intPos = InStr(2, strString, "put")

    'here starting position 2 is mentioned

Debug.Print "The string 'put' appears at position
"&intPos& " in the main string " & "'" &strString& "'"

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 7)

TASK 5 :  Perform string replacement using Replace()

1 Type the following code in the Excel VBA Module1code
window.

'Replacement of a string

Sub string_replace()

Dim A, result As String

A = "Computer Operator"

res = Replace(A, "Operator", "Programmer")

Debug.Print "The string " & A & " has been changed
to " & res

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 8)

4 Type the following code in the Module1code window.

'Replacement of a single character

Sub string_replace()

Dim A, result As String

A = "Calendar"

res = Replace(A, "a", "e")

Debug.Print "The string " & A & " has been changed
to " & res

End Sub

5 Run the code from the immediate window.

6 Check the result in the immediate window.
(Refer Fig 9)
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Fig 7

Fig 6
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7 Type the following code in the Module1code window.

'Srting replacement of one character from beginning

Sub string_replace()

Dim result As String

res = Replace("institute", "i", "a", 1, 1)

Debug.Print res

End Sub

8 Run the code from the immediate window.

9 Check the result in the immediate window. (Refer Fig
10 )

10 Type the following code in the Module1code window.

'String replacement of two characters from beginning

Sub string_replace()

Dim result As String

res = Replace("institute", "i", "a", 1, 2)

Debug.Print res

End Sub

11 Run the code from the immediate window.

12 Check the result in the immediate window. (Refer Fig
11)

TASK 6 : Reverse the given string

1 Type the following code in the VBA Module 1 code
window.

'Reversing a String

Sub string_reverse()

Dim A, result As String

A = "spool"

res = StrReverse(A)

Debug.Print "The string " & A & " when reversed
becomes " & res

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 12)

TASK 7 :Return the numeric part of a string

1 Type the following code in the VBA Module1code
window.
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'Returning the numbers found in a string.

Sub test_val()

Dim s As String

s = "50000 per month is his salary"

Debug.Print Val(s)

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 13 )

TASK 8 : Return a string with the leading and trailing spaces removed.

1 Type the following code in the VBA Module1code
window.

Sub trim_spaces()

Dim A As String

'this is a a string with leading and trailing spaces

A = "       A Very Happy       "

'This removes the leading spaces in the string

Debug.Print "I Wish You" & LTrim(A) & "Journey"

'This removes the trailing spaces in the string

Debug.Print "I Wish You" & RTrim(A) & "Journey"

'This removes both leading and trailing spaces in the
string

Debug.Print "I Wish You" & Trim(A) & "Journey"

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 14 )

4 Run the code from the immediate window.

5 Check the result in the immediate window.
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PROCEDURE

TASK 1 : Use the date and time built in function to extract part of a date

1 Type the following code in the Excel VBAModule1 code window.

Sub test_dates()

'Displaying the current Date and Time values

Debug.Print "Today's date is : " & Date

Debug.Print "Today's date using the now() function
is : " & Now()

Debug.Print "The present time is : " & Time()

Debug.Print

'Extracting the year, month and Date parts of a date

Debug.Print "The year part of the given date is : " &
Year("May 12, 2018")

Debug.Print "The month part of today's date is : " &
Month("May 12, 2018")

Debug.Print "The day part of today's date is : " &
Day("May 12, 2018")

Debug.Print

'Extracting the hour, minute and second parts of a
time

Debug.Print "The hour part of the present time is : "
& Hour("09:30:28 PM")

Debug.Print "The minute part of the present time is
: "&Minute("09:30:28 PM")

Debug.Print "The second part of the present time is
: "&Second("09:30:28 PM")

Debug.Print

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig  1 below )

Fig 1

IT & ITES                                                                                           Exercise 2.2.113
COPA - Visual Basic for Application

Date and Time, Conversion Functions
Objectives: At the end of this exercise you shall be able to
• use the date and time built in function to extract part of a date
• format the Date and Time using the Format() function
• use  the DateAdd () function
• use the DateDiff() function
• use the VBA conversion functions
•  use the conversion functions.
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TASK 2 : Format the Date and Time using the Format() function

1 Type the following code in the Excel VBA Module1code
window.

Sub format_Date()

d1 = Now()

Debug.Print "The date is displayed in the short date
format:" &Format(d1, "Short Date")

Debug.Print "The date is displayed in the Long date
format:" &Format(d1, "Long Date")

Debug.Print "The is displaed in format as follows
'yyyy, month, day':"; Format(d1, "yyyy,MMM, dd")

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 2)

TASK 3 : Use  the DateAdd () function

1 Type the following code in the Excel VBA code window.

Sub add_dates()

    Dim d1, d2, d3, d4, d5, d6 As Date

    d1 = Now()

    d1 = Format(d1, "dd/MMM/yyyy")

    'add 10 days to the date

    d2 = DateAdd("d", 10, d1)

    d2 = Format(d2, "dd/MMM/yyyy")

Debug.Print "After adding 10 days with "& d1 & " is
now " & d2

    'add 5 months to the date

    d3 = DateAdd("m", 5, d2)

Debug.Print "After adding 5 months with "& d2 & " is
now " & d3

    'add 5 years to the date

    d4 = DateAdd("yyyy", 5, d3)

Debug.Print "After adding 5 years with "& d3 & " is
now " & d4

    'add a quarter to the date

    d5 = DateAdd("q", 1, d4)

Debug.Print "After adding 1 quarter with "& d4 & " is
now " & d5

    'add a negative number to the date

    d6 = DateAdd("yyyy", -1, d5)

Debug.Print "After adding -1 year "& d5 & " is now "
& d6

  End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 3 )
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TASK 4 : Use the DateDiff() function

1 Type the following code in the Excel VBA code window.

Sub date_diff()

Dim n As Integer

Dim d1, d2 As Date

d1 = #1/1/2000#

d2 = #1/2/2004#

'Find difference in years

n = DateDiff("yyyy", d1, d2)

Debug.Print "The difference between dates  "& d1 &
" and  " & d2; " is " & n & " years"

'Find difference in quarters

n = DateDiff("q", d1, d2)

Debug.Print "The difference between dates  "& d1 &
" and  " & d2; " is " & n & " quarters"

'Find difference in months

n = DateDiff("m", d1, d2)

Debug.Print "The difference between dates  "& d1 &
" and  " & d2; " is " & n & " months"

'Find difference in days

d1 = #1/1/2000#

d2 = #1/2/2001#

n = DateDiff("d", d1, d2)

Debug.Print "The difference between dates  "& d1 &
" and  " & d2; " is " & n & " days"

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 4)

Fig 4
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TASK 5 : Use the VBA information functions

1 Type the following code in the Excel VBA Module1code
window.

Sub test_info(x)

Dim ans As Boolean

ans = IsNumeric(x)

'test if the function returns true or false

If x Then

Debug.Print "You supplied a number as argument"

Else

Debug.Print "The supplied argument is not a number"

End If

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig. 5)

4 Type the following code in the Excel VBA Module1code
window.

Sub test_date(x)

Dim ans As Boolean

ans = IsDate(x)

If x Then

Debug.Print "The supplied argument is a date"

Else

Debug.Print "The supplied argument is not a date"

End If

End Sub

Fig 5
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5 Run the code from the immediate window.

6 Check the result in the immediate window.
(Refer Fig 6 )

7 Type the following code in the Excel VBA Module1code
window.

'Supply either Null or any data as argument to this
Subroutine while executing it

Sub test_null(x)

Dim ans As Boolean

ans = IsNull(x)

If ans Then

Debug.Print "NULL Argument supplied"

Else

Debug.Print "The supplied argument is not NULL"

End If

End Sub

TASK 6 :  Use the conversion functions

8 Run the code from the immediate window.

9 Check the result in the immediate window.
(Refer Fig. 7 and 8 )

1 Type the following code in the Excel VBA Module1code
window.

Sub conv_fns()

Dim x As Integer

Dim y As Single

'Use the Cint() conversion function

x = CInt(3.36)

Debug.Print "CInt(3.36) is : " & x

x = CInt(3.89)

Debug.Print "CInt(3.89) is : " & x

'Use the Fix() function for truncating decimal part

x = Fix(3.99)

Debug.Print "FIx(3.99)results in : " & x

'Use the CSng() function

y = CSng(8.123456325678)

Debug.Print "CSng(8.123456325678)results in : " & y

End Sub

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 9)

Fig 6
Fig 7

Fig 8

Fig 9
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IT & ITES                                                                                           Exercise 2.2.114
COPA - Programming with VBA

Work with User Defined Function and Procedures in VBA
Objectives: At the end of this exercise you shall be able to
• create and call a function with no arguments and no return type
• create and call functions with arguments but no return type
• create and use a Function that returns a value
•  pass parameters by value and by reference to a function
•  call  a User defined function from the Excel sheet
create functions,procedures returning value of a function.
PROCEDURE
TASK 1 : Create and call a function with arguments and no return type
1 Type the following code in the Excel VBA Module1

code window.

'This function draws a line whenever called

Function prnt_line()

Debug.Print "______________________________"

End Function

'This function prints a table of squares and cubes for
numbers 1 to 10

Function user()

Dim n As Integer

'This function is called to draw a line

Call prnt_line

Debug.Print" Number    Square       Cube"

Call prnt_line

For n = 1 To 10

Debug.Print n; Tab(12); n * n; Tab(25); n * n * n

Next

Call prnt_line

End Function

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 1)

Fig 1

TASK 2 : Create and call a function with arguments but no return type

1 Type the following code in the Excel VBA Module1
code window.

Function even_odd(a As Integer)

If (a Mod 2) = 0 Then

Debug.Print a &" is an even number "

Else

Debug.Print a &" is an odd number "

End If

End Function

Function user()

Fig 2

even_odd (23)

even_odd (56)

End Function

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 2)
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5 Run the code from the immediate window.

6 Check the result in the immediate window.
(Refer Fig  3)

Function print_stars(n As Integer, c As String)

Dim x As Integer

For x = 0 To n

Debug.Print c;

Next

Debug.Print

End Sub

'This function calculates the area and circumference
for circles with radius 1 to 10 units

Sub user()

Dim rad As Integer

Call print_stars(30, "*")

Debug.Print "Radius     Area     Circumference"

Call print_stars(33, "^")

For rad = 1 To 10

Debug.Print rad; Tab(10); (3.14 * rad * rad); Tab(25);
6.28 * rad

Next

Call print_stars(40, "&")

End Sub

Fig 3

TASK 3 : Create and use a Function that returns a value

1 Type the following code in the Excel VBA Module1
code window.

'create a function that takes two sides of a triangle a
and b

'of double type and calculate the hypotenuse

Function hypot(a As Double, b As Double) As Double

hypot = Sqr((a * a) + (b * b))

End Function

Function f1()

'call the function hypot from here with arguments

Debug.Print "hypotenuse is : "; hypot(3, 4)

End Function

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 4)

Fig 4
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TASK 4 : Pass parameters by value and by reference to a function

1 Type the following code in the Excel VBA Module1
code window.

'Passing parameters by Value

Sub test_byval(n As Integer)

Debug.Print "Inside the calling function n is "& n

multiply_by5 (n)

'The original value of n is not changed by the function

Debug.Print "After returning from the multiply function,
n is "& n

End Sub

Function multiply_by5(ByVal n As Integer) As Integer

n = n * 5

multiply_by5 = n

Debug.Print "Inside the multiply  function n is " & n

End Function

2 Run the code from the immediate window.

3 Check the result in the immediate window.
(Refer Fig 5)

Fig 5

4 Type the following code in the Excel VBA code window.

'Passing parameters by Reference

Option Explicit

'Passing parameters by reference

Sub test_byref(n As Integer)

Debug.Print "Inside the calling function n is:" & n

    'The original value of n is changed by the function

Debug.Print "After returning from the multiply function
the value of n is:" &Square(n)

End Sub

Function Square(ByRef n As Integer) As Integer

    n = n * n

    Square = n

Debug.Print "Inside the multiply function n is " & n

End Function

5 Run the code from the immediate window.

6 Check the result in the immediate window.
(Refer Fig 6)

7 Write and test functions using a type character for
return types using the syntax shown in below instead
of the conventional syntax.

a. Function Square&()  instead of

Function Square() as integer

b. Function Join_String$ (s1 as String , s2 as
String) instead of

Function Join_String$ (s1 as String , s2 as
String) as String

TASK 5 : Call a User defined function from the Excel sheet.

1 Type the following code in the Module1 Code window.

Function CircArea(ByRef rad As Integer)

CircArea = 3.14 * rad * rad

End Function

2 Open the excel sheet.

3 Type any number for ex. 10 in a cell for ex. B10

4 In the adjacent cell type = CircArea(B10)

5 Press enter and verify the results.

The User defined function can now be used in
the Excel sheet like any Excel built in function.

IT & ITES : COPA -  (NSQF- 4) Exercise 2.2.114

Fig 6



141

TASK 6  :  Creating functions, procedures passing and returning value to a function.

1 Type the following code with Excel VBA module1

Option Explicit

‘Finding Area and Circumference of a Rectangle

Public Sub main()

Dim intLen, intBre As Integer, intArea As Integer,
intCircum As Integer

    ‘Reading Length of Rectangle

intLen = funReadLen     ‘Calling function funReadLen

    ‘Reading Breadth of Rectangle

intBre = funReadBre     ‘Calling function funReadBre

    ‘Finding Area of Rectangle

proCalcAreaintLen, intBre, intArea     ‘Calling
Procedure proCalcArea by passing intLen, intBre by
value and intArea by reference to fetch the Area

    ‘Finding Circumference of Rectangle

proCalcCircumintLen, intBre, intCircum     ‘Calling
Procedure proCalcCircum by passing intLen, intBre
by value and intCircum by reference to fetch the
Circumference

    ‘Displaying Area of given Rectangle

funDispArea (intArea)

    ‘Displaying Circumference of given Rectangle

funDispCircum (intCircum)

End Sub

Function funReadLen()

    Dim intVarLen As Integer

intVarLen = InputBox(“Enter Length of Rectangle”,
“Input Length”, 0)

funReadLen = intVarLen

End Function

Function funReadBre()

    Dim intVarBre As Integer

intVarBre = InputBox(“Enter Breadth of Rectangle”,
“Input Breadth”, 0)

funReadBre = intVarBre

End Function

Sub proCalcArea(ByValintXlen As Integer,
ByValintXbre As Integer, ByRefintXArea As
Integer)

intXArea = intXlen * intXbre

End Sub

Sub proCalcCircum(ByValintXlen As Integer,
ByValintXbre As Integer, ByRefintXCircum As
Integer)

intXCircum = 2 * (intXlen + intXbre)

End Sub

Function funDispArea(ByValintXArea)

MsgBox “The Area of Rectangle is : “ &intXArea

End Function

Function funDispCircum(ByValintXCircum)

MsgBox “The Circumference of Rectangle is : “
&intXCircum

End Function
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Fig 6

2 Run the code from immediate window.

3 Enter a valure in the input box and click Ok as
shown in Fig 6.
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Fig 7

Fig 8

4 Enter a value in the input box and and click OK as shown in Fig 7.

5 The results are as shown in the Fig 8 & Fig 9

Fig 9
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IT & ITES                                                                                           Exercise 2.2.115
COPA - Programming with VBA

Built in Function in VBA
Objectives: At the end of this exercise you shall be able to
• practice on executing various Mathematical Functions.

TASK 1: Practice on executing various Mathematical
Functions

1 Type the following code in module code window.

Sub mathfunc()

Debug.Print “The Absolute Value of X is =” &Abs(5)

Debug.Print “The Absolute Value of X is =” &Abs(-5)

Debug.Print “The Absolute Value of X is =” &Abs(-
5.04)

Debug.Print “The Cosine Value of Given number is
=” &Cos(0)

Debug.Print “The Cosine Value of Given number is
=” &Cos(-3.14159265358979)

Debug.Print “The sine Value of Given number is =”
&Sin(0)

Debug.Print “The sine Value of Given number is =”
&Sin(1.5707963267949)

Debug.Print “The Tangent Value of Given number is
=” &Tan(0)

Debug.Print “The Tangent Value of Given number is
=” &Tan(-1.0471975511966)

Debug.Print “The SqureRoot Value of Given number
is=” &Sqr(9)

Debug.Print “The SqureRoot Value of Given number
is =” &Sqr(10)

Debug.Print “The Arithmetic sign of Given number is
=” &Sgn(3)

Debug.Print “The Arithmetic sign of Given number is
=” &Sgn(0)

Debug.Print “The Arithmetic Sign of Given number is
=” &Sgn(-9)

Debug.Print “The integer portion of Given number is
=”&Fix(35.09)

Debug.Print “The integer portion of Given number is
=” &Fix(-67.1)

‘The Fix function has rounded the number 77.7 to
the integer 77;

‘The Fix function has rounded the number -77.7 to
the integer -77.

Debug.Print “The integer portion of Given number is
=” &Int(35.9)

Debug.Print “The integer portion of Given
number is =” &Int(-35.1)

‘The Int function has rounded the positive number
77.7 to the integer 77   (i.e. towards zero);

‘The Int function has rounded the negative number -
77.7 to the integer -78   (i.e. away from zero).

Debug.Print “The Natural Logarithm of Given number
is =” &Log(0.1)

Debug.Print “The Natural Logarithm of Given number
is =” &Log(1)

Debug.Print “The Natural Logarithm of Given number
is =” &Log(500)

Debug.Print “The Random number is =” &Rnd()

Debug.Print “The Rounded portion of given number
is =” &Round(77.777, 2)

Debug.Print “The Rounded portion of given number
is =” &Round(77.377)

‘The VBA Round function rounds a numbers to a
specified number of decimal places.

End Sub

2 Run the code from immediate window (Fig 1) and verif
result the instructor.
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Fig 1
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IT & ITES                                                                                           Exercise 2.2.116
COPA -  Programming with VBA

Create and Edit Macros
Objectives: At the end of this exercise you shall be able to
• create macro in excel
• view and edit the macro Subroutine.
• assign the macro subroutine to a Command Button Control.

PROCEDURE

TASK 1 : Create macro in excel

The following are the requirements from the
macro to be created

1 The macro should create a table as shown
in Fig 1.

2 The background should be in "yellow" colour.

3 The formula for the cell value under "area"
should be =3.14*rad*rad

4 The formula for the cell value under "circum"
should be =6.14*rad

1 Click on the View menu item.

2 Click on Macros and select "Record Macro".

The macro window opens and displays the
macro name as Macro1. Click OK.

This starts the Macro Recorder.

3 Type the headings as in the Fig 1

Fig 1

4 Type the data for radius ie. 10 in this example.

5 Type the following formula below the heading cell area
=3.14*rad*rad

6 Type the following formula below the heading cell
circum  =6.28*rad

7 Select the cells containing the headings and the data.

8 Click on the Home menu item.

9 Fill the cells with yellow colour.

10 Select Stop recording.

The macro is now ready for use.

11 Open the worksheet 2.

12 Press Alt + F8

13 Click on Macro1 and click "Run".

14 Verify the result.

A table similar to the one in Fig. 1 with all
formatting and formulae will appearin Sheet
2 now.

TASK 2 : View and edit the macro Subroutine.

1 Click on the macros button.

2 Select view macros.

3 Select macro1 created in task 1 above.

4  Click on the edit button.

The Subroutine for Macro1 is displayed in the
VBA code window. Refer to the Code given
below.

Sub Macro1()

'

' Macro1 Macro

'

Range("G5").Select

ActiveCell.FormulaR1C1 = "radius"

Range("H5").Select

ActiveCell.FormulaR1C1 = "area"

Range("I5").Select

ActiveCell.FormulaR1C1 = "circum"
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Range("G6").Select

ActiveCell.FormulaR1C1 = "10"

Range("H6").Select

ActiveCell.FormulaR1C1 = "=3.14*RC[-1]"

Range("I6").Select

ActiveCell.FormulaR1C1 = "=6.28*RC[-2]"

Range("G5:I6").Select

With Selection.Interior

.Pattern = xlSolid

.PatternColorIndex = xlAutomatic

.Color = 65535

.TintAndShade = 0

.PatternTintAndShade = 0

End With

End Sub

TASK 3 : Assign the macro subroutine to a Command Button Control.

5 Select the line  ActiveCell.FormulaR1C1 = "circum"in
the code.

6 Change the text "circum" to "Perimeter".

7 Select the line .Color = 65535in the code.

8 Type any other number for the colour code for ex.
Colour =88888.

9 Open the worksheet.

10 Press Alt  +  F8.

The View macros window is opened.

11 Select the Macro1 and click on "Run".

The changes done in the macro window are
reflected in the Excel sheet now.

1 Click on the Developer Menu item.

2 Go to the "Controls" section of the Developer Ribbon.

3 Click on the "Design" icon.

Form Controls and ActiveX controls are
displayed when the insert button is
clicked.(Refer Fig 2)

4 Click on the "Insert" button.

Fig 2

5 Click on the Button control from the Form Controls
section.

A cross hair pattern appears.

6 Place the cross hair pattern anywhere on the Excel
sheet and drag it to draw a rectangle.

A button is placed on the Worksheet and
immediately the "Assign Macro" window
appears. (Refer Fig 3)

7 Click on the macro with name "Macro1" from the
macros available.

8 Click "OK"
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"Macro1" is assigned to the Button.

9 Disable the Design Mode by clicking on it.

10  Click on the button to test its working.

11 Verify the result for various input values.

The code written in the subroutine named
"Macro1" is executed here.
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IT & ITES                                                                                           Exercise 2.2.117
COPA - Visual Basic for Application

Working with Forms
Objectives: At the end of this exercise you shall be able to
• use the events of the form to perform an action
• modify the form properties at run time.

PROCEDURE

TASK 1 : Working with form events

1 Create a new Excel sheet.

2 Open the Visual Basic window in the  Excel sheet.

3 Insert a new Userform from the "Insert" menu of the
VBA window.

4 Locate the properties window.

5 Press F7.

6 Type the following code in the UserForm_Click() event.

Private Sub UserForm_Click()

UserForm1.BackColor = vbRed

End Sub

7 Run the code.

The UserForm opens in the worksheet.

8 Click on the Form.

9 Check the result.

The Form BackColor changes to Red.

10 Close the Form and return to the Code Window.

11 Click on the "Reset Button" of the Standard toolbar.

12 Open the Code window again.

13 Click on the DblClick event procedure from the
procedures drop down box.

14 Type the following code in the UserForm_DblClick()
event.

Private Sub UserForm_DblClick(ByVal Cancel As
MSForms.ReturnBoolean)

UserForm1.BackColor = vbGreen

End Sub

15 Run the code.

16 Double Click on the Form.

The Form BackColor changes to Green.

17 Type the following code in the VBA code window.

Private Sub UserForm_MouseMove(ByVal Button As
Integer, ByVal Shift As Integer, ByVal X As Single,
ByVal Y As Single)

Static bc

If bc>= 5555555 Then

bc = 0

Else

    UserForm1.BackColor = bc

bc = bc + 500

End If

End Sub

18 Run the code.

19 Check the result.

The Form Backcolour changes each time the
mouse is moved

20 Write code to change the properties like Form.Left,
Form.Width, Form.Left on different event procedures.

21 Check the result.

Fig 3

Fig 1
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IT & ITES                                                                                           Exercise 2.2.118
COPA -  Programming with VBA

Practice with Methods and Event VBA

Objectives: At the end of this exercise you shall be able to
• practice on how to run the code in work book open Event
• practice on how to run the code in work sheet change Event.

Task 1 : Workbook Open Event

Code added to the Workbook Open Event will be executed by Excel VBA when open the workbook.

1 Open the Visual Basic Editor.

2 Double click on This Workbook in the Project Explorer.

3  Choose Workbook from the left drop-down list. Choose

Open from the right drop-down list.

4  Add the following code line to the Workbook Open

Event:

MsgBox “Good Morning”

5 Save, close and reopen the Excel file

Result:

Fig 1

Fig 2
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Task-2 Worksheet Change Event

4 Add the following code lines to the Worksheet Change

Event:

The Worksheet Change Event listens to all changes

on Sheet1. We only want Excel VBA to do

something if something changes in cell B2. To

achieve this, add the following code lines:

Code added to the Worksheet Change Event will be

executed by Excel VBA when you change a cell on a

worksheet.

1 Open the Visual Basic Editor.

2 Double click on a sheet (for example Sheet1) in the

Project Explorer.

3 Choose Worksheet from the left drop-down list. Choose

Change from the right drop-down list.

If Target.Address = “$B$2” Then
End If

5 We only want Excel VBA to show aMsgBox if the user

enters a value greater than 80. To achieve this, add the

following code line between If and End If.

If Target.Value> 80 Then MsgBox “Goal Completed”

6 On Sheet1, enter a number greater than 80 into cell B2.

Result:
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IT & ITES                                                                                           Exercise 2.2.119
COPA -  Programming with VBA

Debugg and Set Break Point in VBA

Objectives: At the end of this exercise you shall be able to
• practice on how to debug and step through the code
• practice on set a break point to halt execution at a specific code line
• practice with watch window.

TASK 1 : Debug and step through the code

1 Place a command button on the worksheet and add

the following code lines in the button click event:

Dim i As Integer, j As Integer

For i = 1 To 2

For j = 1 To 5

Cells(i,j).Value=

WorksheetFunction.RandBetween(20, 100)

    Next j

Next i

2 click the command button on the sheet:

3 Empty the range A1:E2.

4 Open the Visual Basic Editor and reduce the size of
the screen so that can see the Visual Basic Editor and
worksheet at the same time.

5 In the Visual Basic Editor, place the cursor

before”Private” and press F8.

The first line turns yellow.

Fig 1

Fig 2
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6 Press F8 four times. For i = 1 and j = 1, Excel VBA

enters a random number between 20 and 100 into the

cell at the intersection of row 1 and column 1. By

7  Press F8 two more times. For i = 1 and j = 2, Excel

VBA enters a random number between 20 and 100

into the cell at the intersection of row 1 and column 2.
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8 Single step through the rest of the code to see how

Excel VBA enters the other numbers. This is an

excellent way to learn how a loop works. If you wish

to stop the program,click the Reset (Stop) button.

holding the cursor steady on a variable, and see the

value of the variable.

Fig 3

Fig 4
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TASK 2 : Set a breakpoint to halt execution at a specific code line.
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1 Empty the range A1:E2. 2 To set a breakpoint, click on the left margin (in grey)

where you want to place the breakpoint. A red dot

appears.

3 Click on the green arrow to execute the macro until

the breakpoint.
Result:

Fig 5

Fig 6
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Only part of the macro (for i = 1) has been executed.

4. To remove the breakpoint, click on the red dot. Next,

click on the green arrow to continue execution.

3 Go to Debug menu and select Add Watch (Fig.8)

If you receive a macro from someone else, remember,

debugging is great way to understand the code. You

can easily see the effect of each code line on your

worksheet.

TASK 3 :  Debugging using Watch Window

1 Inert a module and enter the following code

Sub vars()

    Dim iAs Integer

    For i = 1 To 5

Debug.Printi

    Next i

End Sub

2 To View watch window go to View and select Watch
Window (Watch Window appears (Fig. 7)

4 Enter variable i in the Expression Then click OK. 5 Put the cursor where you want to break then press
F9 key. The breakpoint is added at that line (Fig.9).

Fig 7

Fig 8
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6 Press F5 to run the module. The value of variable i will
be displayed when VBA crosses the break point
(Fig.10)

Fig 9

Fig 10
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IT & ITES                                                                                           Exercise 2.2.120
COPA -  Programming with VBA

Simple project involving MS excel and VBA

Objectives: At the end of this lesson you shall be able to
• read the instructions and write the code of EMI calculator in VBA with the help you instructor
• read the instructions and write the code of Simple calculator in VBA with the help you instructor.

Project 1

create a simple EMI calculator in Excel with VBA in
your Practical Session

EMI is the acronym for Equated Monthly Installment. It’s
the monthly amount that repay when you get a loan. The
following image shows the formula for calculating EMI.
(Fig 1)

The above formula is complex and can be written in excel.
You can use the PMT function to compute the above.

The PMT function works as follows

=PMT(rate,nper,pv)

HERE,

• “rate” this is the monthly rate. It’s the interest rate
divided by the number of payments per year

• “nper” it is the total number of payments. It’s the loan
term multiplied by number of payments per year

• “pv” present value. It’s the actual loan amount

Create the GUI using excel cells as shown below. (Fig 2)

Add a command button between rows 7 and 8

Give the button macro name btnCalculateEMI_Click

Click on edit button

Enter the following code

Dim monthly_rate As Single, loan_amount As Double,
number_of_periods As Single, emi As Double

Monthly_rate = Range(“B6”).Value / Range(“B5”).Value

Loan_amount = Range(“B3”).Value

Number_of_periods = Range(“B4”).Value *
Range(“B5”).Value

Emi = WorksheetFunction.Pmt(monthly_rate,
number_of_periods, -loan_amount)

Range(“B9”).Value = emi

HERE,

• “Dim monthly_rate As Single,…” Dim is the key-
word that is used to define variables in VBA,
monthly_rate is the variable name, Single is the data
type that means the variable will accept number.

• “monthly_rate = Range(“B6”).Value /
Range(“B5”).Value” Range is the function used to
access excel cells from VBA, Range(“B6”).Value makes
reference to the value in B6

• “WorksheetFunction.Pmt(…)” WorksheetFunction is the
function used to access all the functions in excel.

The following image shows the complete source code.
(Fig 3)

Fig 3

Fig 1

Fig 2
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Click on save and close the code window

• Test your program as shown in the image below.
(Fig 4)

Fig 4

Project-2

Calculator using Excel VBA UserForm

The KEY steps:-

Step 1: Create User Form: we have to first create the
userform from the Insert menu in VBA Editor as
shown in Fig 5.

Step 2: Place toolbox controls on the created
userform: Place required controls on the
userform. You can drag the controls from the
toolbox and drop controls on the user form.

Step 3: Set properties and alignment of all controls:
Properties of each control has set. It is shown
in the design section.

Step 4: Clear Button: It is used to clear the display
area.

Step 5: Back Button : It is used to go back one digit.

Step 6: Divide (/) Button: It is used for division.

Step 7: Multiplcation (*) Button: It is used for multipli-
cation.

Step 8: Minus (-) Button: It is used for subtraction.

Step 9: Add (+) Button: It is used for addition.

Step 10: Dot (.) Button : It is used to add dot to the num-
ber.

Step 11: One (1) Button: It is used to display number 1.

Step 12: Two (2) Button: It is used to display number 2.

Step 13: Three (3) Button: It is used to display
number 3.

Step 14: Four (4) Button: It is used to display number 4.

Step 15: Five (5) Button: It is used to display number 5.

Step 16: Six (6) Button: It is used to display number 6.

Step 17: Seven (7) Button: It is used to display
  number 7.

Step 18: Eight (8) Button: It is used to display
number 8.

Step 19: Nine (9) Button: It is used to display number 9.

Step 20: Zero (0) Button: It is used to display number  0.

Step 21: EqualTo (=) Button: It is used to perform all
calculations like addition, substraction,
multiplcation, etc .

Step 22: Textbox: It is used to display result.

Design of the Calculator :

Fig 5

Control Property Value

User Form Name frm Calculator

Frame Name display Frame

TextBox Name txt Display

Enabled False

Special Effect 0-frm Special EffectFlat

Text Align 3-frm Text Align Right
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Control Property Value

Text Box Name txtRes

Value 0

Enabled False

SpecialEffect 0-frm Special Effect Flat

TextAlign 3-frm Text Align Right

Enter Key Behavior True

Command Button Name cmd Btn clr

Caption Clear

Command Button Name cmd Btn Bak

Caption Back

Command Button Name cmd Btn Dvd

Caption /

Command Button Name cmd Btn Mult

Caption *

Command Button Name cmd Btn Mns

Caption –

Command Button Name cmd Btn Add

Caption +

Command Button Name cmd Btn Dot

Caption .

Command Button Name cmd Btn Eql

Caption =

CommandButton Name cmdBtn1

Caption 1

CommandButton Name cmdBtn2

Caption 2
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         Control Property Value

CommandButton Name cmdBtn3

Caption 3

CommandButton Name cmdBtn4

Caption 4

CommandButton Name cmdBtn5

Caption 5

CommandButton Name cmdBtn6

Caption 6

CommandButton Name cmdBtn7

Caption 7

CommandButton Name cmdBtn8

Caption 8

CommandButton Name cmdBtn9

Caption 9

CommandButton Name cmdBtn0

Caption 0

This is used to create calculator design. By changing or
setting all the above properties and values of control the
form will be looking like below.

Code and explanation for each control:

Step 1: Create userform and do its initialization by
double clicking on the userform and add the
below code.

Private Sub UserForm_Initialize()

txt Res.Max Length = 10

txt Display.Max Length = 10

End Sub

In the above code we are setting maximum length of dis-
play numbers is 10. You can change this number.

Step 2: Double click on the textbox (Value-txtRes) and
add the following code. Double click on the ‘
Textbox’ and add the below code.

Private Sub txt Res_Change ()

 If txtRes.TextLength> 10 Then

MsgBox “Its Too long to calculate value.”,vbInformation

txtRes.Text = Left(txtRes.Text, 10)

Exit Sub

End If

End Sub

In the above code we are displaying message when dis-
playing numbers are exceeding 10.
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Step 3: Set properties as mentioned above and do the
alignment of all controls as shown above in the
screenshot.

Step 4: Double click on the ‘Clear Button’ and add the
below code.

Private Sub cmd Btn clr_Click ()

txtRes = 0: txt Display = Empty

End Sub

Step 5: Double click on the ‘ Back Button ‘ and add the
below code.

Private Sub cmd Btn Bak_Click ()

 If  txt Res <>  0  And  txt Res<> “” Then txtRes = Left (txt
Res, Len (txt Res) - 1)

End Sub

Step 6: Double click on the ‘ Divide (/) Button’ and add
the below code.

Private Sub cmd Btn Dvd_Click ()

If txt Res <> 0 Then

txt Display = txt Res

txt Res = 0

cal Val = “Divide”

End If

End Sub

Step 7: Double click on the ‘ Multiplcation (*) Button’
and add the below code.

Private Sub cmd Btn Mult_Click ()

If txt Res<> 0 Then

txt Display = txt Res

txtRes = 0

cal Val = “Multiplication”

End If

End Sub

Step 8: Double click on the ‘ Minus (-) Button’ and add
the below code.

Private Sub cmdBtnMns_Click()

If  txt Res <> 0 Then

txt Display = txt Res

txt Res = 0

cal Val = “Minus”

End If

End Sub

Step 9: Double click on the ‘ Add (+) Button’ and add
the below code.

Private Sub cmdBtnAdd_Click()

If  txt Res <> 0 Then

txt Display = txt Res

txt Res = 0

ca lVal = “Add”

End If

End Sub

Step 10: Double click on the ‘ Dot (.) Button ‘ and add the
below code.

Private Sub cmdBtnDot_Click()

If  txt Res <> 0 Then txt Res = txt Res + “.”

End Sub

Step 11: Double click on the ‘ One (1) Button’ and add the
below code.

Private Sub cmd Btn1_Click ()

If  txt Res = 0 Then

txt Res = cmd Btn1.Caption

Else

txtRes = txtRes + cmdBtn1.Caption

End If

End Sub

Step 12: Double click on the ‘ Two (2) Button’ and add the
below code.

Private Sub cmdBtn2_Click()

If  txt Res = 0 Then

txt Res = cmd Btn 2.Caption
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Else

txt Res = txt Res + cmd Btn 2.Caption

End If

End Sub

the below code.

Private Sub cmdBtn3_Click()

If  txt Res = 0 Then

txt Res = cmd Btn 3.Caption

Else

txt Res = txt Res + cmd Btn 3.Caption

End If

End Sub

Step 14: Double click on the ‘ Four (4) Button’ and add
the below code.

Private Sub cmdBtn4_Click()

If  txt Res = 0 Then

txt Res = cmd Btn 4.Caption

Else

txt Res = tx tRes + cmd Btn 4.Caption

End If

End Sub

Step 15: Double click on the ‘ Five (5) Button’ and add the
below code.

Private Sub cmd Btn 5_Click ()

If txt Res = 0 Then

txt Res = cmd Btn 5.Caption

Else

txt Res = txt Res + cmd Btn 5.Caption

End If

End Sub

Step 16: Double click on the ‘ six (6) Button’ and add the
below code.

Private Sub cmd Btn 6_Click ()

If  txt Res = 0 Then

txt Res = cmd Btn 6.Caption

Else

txt Res = txt Res + cmd Btn6.Caption

End If

End Sub

Step 17: Double click on the ‘ Seven (7) Button’ and add
the below code.

Private Sub cmd Btn 7_Click ()

If  txt Res = 0 Then

txt Res = cmd Btn 7.Caption

Else

txt Res = txt Res + cmd Btn 7.Caption

End If

End Sub

Step 18: Double click on the ‘ Eight (8) Button’ and add
the below code.

Private Sub cmdBtn8_Click()

If  txt Res = 0 Then

txt Res = cmd Btn 8.Caption

Else

txt Res = txt Res + cmd Btn8 .Caption

End If

End Sub

Step 19: Double click on the ‘ Nine (9) Button’ and add
the below code.

Private Sub cmdBtn9_Click()

If  txt Res = 0 Then

txt Res = cmd Btn 9.Caption

Else

txt Res = txt Res + cmd Btn 9.Caption

End If

End Sub
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Fig 6

Step 20: Double click on the ‘ Zero (0) Button’ and add
the below code.

Private Sub cmdBtn0_Click()

txtRes = txtRes + cmdBtn0.Caption

End Sub

Step 21: Double click on the ‘ EqualTo (=) Button’ and
add the below code.

’21. Final Calculations

Private Sub cmd Btn Eql_Click ()

On Error Go To Err Occcered

 ‘Dim txt Res As Long

If  txt Display = “Cannot divide by Zero” Then txt Display =
Empty

If txt Res<> “” And cal Val<> “” Then

F Num = Val (txt Display): S Num = Val (txt Res)

Select Case cal Val

Case “Add”

txt Res = FNum + SNum

Case “Minus”

txt Res = F Num - SNum

Case “Multiplication”

txt Res = FNum * SNum

Case “Divide”

If  S Num = 0 Then

txt Res = “Cannot divide by Zero”

Else

txt Res = FNum / SNum

End If

Case Else

End Select

txt display = Empty

End If

Err Occcered:

End Sub

Display Calculator on the WorkSheet:

Here are steps to display calculator on the userform.

1 Place any shape by clicking on insert menu from illus-
trations group.

2 Right click on the shape, select assign macro.

3 Select the shape name from the available list and click
on OK button.

4 Now, go to the Developer tab.

5 Design Mode should be turned off from the Controls
group.

6 Now, go back to the shape and click on the created
shape to see the calculator on the userform.

Instructions to Execute the Procedure:

You can download the below file and see the code and
execute it.

1 Open VBA Editor window or Press Alt+F11.

2 Insert userform from the Insert menu.

3 Create design as shown in theabove steps..

4 Add Procedures by double clicking on userform.

5 Run the project by hitting F5 key from the keyboard.

6 hit the numbers on the calculator and see the output
on the display area.

7 And als you can use keyboard keys(up, down, left,
right and enter to display numbers.

The Output window:- (Fig 6)
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IT & ITES                                                                                           Exercise 2.3.121
COPA - Accounting Software - Tally

Practicing Tally Interface
Objectives: At the end of this exercise you shall be able to
• start Tally software.
• identify the screen components
• quit from Tally software.

PROCEDURE

TASK 1 : Start Tally software

1 Tally  can be started in any one of the
following manner. (see Fig 1)

- Double click the Tally icon on desktop.(or)

- Select Run from Start Menu and enter the command.
Type the drive & path name and then the executable
file name.

For example, if Tally is installed at C:\
Tally.ERP9 folder, then enter the path name of
C:\Tally.ERP9\tally and click OK button.

- At start menu select program then select Tally.ERP9
and then Tally.ERP9.

Fig 1
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TASK 3 : Quit from Tally. ERP 9

Quit Tally in any of the following manner.

1 Press ESC until you see the message Quit? Yes or
No?

2 Press Enter or Y, or click Yes  to quit Tally.ERP9.

a To exit without confirmation, press Ctrl + Q from
Gateway of Tally.

b You will also press Enter, while the option Quit is
selected from Gateway of Tally.

TASK 2 : Identify the screen components (See Fig 2)

1 Identify the Tally Screen Components. (see Note 2)

- Titlebar: Displays the version number of Tally.ERP 9

- Horizontal buttonbar: Selection of Language key,
Keyboard Language and Tally.ERP 9 Help.

- Close button: Performs the standard Windows
Operating Systems function (Windows95 onwards),
allowing you to Close/Quit Tally. ERP9 and work on
other applications. To restore Tally.ERP9, click the
Tally.ERP9 icon on the taskbar.

- Gateway of Tally: Displays menus, screens, reports
and accepts the choices and options which you select
to view data required.

- Buttons toolbar: Displays buttons which provide quick

interaction with Tally.ERP9. Only buttons relevant to
the current task are visible.

- Calculator Area: Used for calculator functions.

- Info Panel: Displays Version number, License details,
Configuration details.

- For Switching between Screen Areas to toggle between
this screen and the Calculator area at the bottom of
the screen, press Ctrl + N or Ctrl + M as indicated on
the screen.

- To minimize the Info. Panel, press Close(X) button on
the right side of the Info. Panel and to restore, click ̂
appearing on the bottom centre of the screen.
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IT & ITES                                                                                           Exercise 2.3.122
COPA - Accounting Software - Tally

Company Creation & Voucher Entry in Tally
Objectives: At the end of this exercise you shall be able to
• enter company information
• enter base currency information
• select a company
• alter a company
• shut a company.
• create a ledger account
• create a journal & enter transactions
• view journals.

PROCEDURE

TASK 1 : Entry company information

1 Click "Create Company" Option in the Tally Screen or
simply press "C" Key.

 Company Creation Screen will appear. (see Fig 1)

2 Create a company Universal Enterprises with the
details as shown in the screen: (see Fig 2)

1 Directory: This is the physical location on the
computer where the company details to be stored. By
default cursor skip this field.

Fig 1
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2 Name: Enter Name for the company.

3 Mailing Name: This name will appear in hardcopy
reports. By default the name entered in the "Name"
field is displayed in this field. If you want a new name
as mailing name, you can enter a new name.

4 Address:  Enter Address of the company is entered
in this field.

5 E-mail Address: Enter E-mail address of the company
is entered in this field.

6 Currency Symbol: Enter the currency symbol in which
book of accounts for the company is to be maintained.
For example to maintain in Rupees, enter Rs $ for
Dollar.

7 Maintain: Tally provides option to maintain

- Accounts only

- Inventory only

- Accounts cum Inventory.

A pop-up menu will appear. Select the choice required.

8 Financial year from: Enter the beginning date of the
financial year.

9 Books beginning from: Enter the data from which
the accounting books actually begins from. Normally
"books beginning form" and "Financial Year from"
would be the same.

10 Tally vault password: Enter the password to use Tally
vault.

11 Use Security Control: If you wish to restrict access
to company's date to authorized users only respond
"Yes". This will prompt to enter name of Administrator,
Password and confirm the same at next prompt.

If you do not wish any Security Control,
respond "No".

Fig 2
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TASK 2 : Enter base currency information

Step 1 Enter base currency information as per the following
options given below -

1 Base currency symbol: The Currency symbol entered
in top section is displayed here. This symbol is treated
as base currency. You will not modify here.

2 Formal Name: Enter the formal name for the currency.
For example Indian Rupees, US Dollar.

3 Number of Decimal places: Enter the number of
decimal places for the currency. For example 2 for
Rupees and 3 for Dinars.

4 Show Amount in Millions: If you put "Yes", the amount
will be formatted in Million. If you put "No", the amount
will be formatted in Lacs.

5 Is Symbol suffixed to amounts: If you put "Yes", the
currency symbol will appear after the amount. (eg: 1000
Yen - Currency of Japan)

If you put "No", the currency symbol will
appear before the amount. (eg: Rs1000- Indian
currency).

6 Put a space between amount and symbol: If you put
"Yes", a space will appear between the currency
symbol and the amount. (e.g: Rs 1000, $ 1000, 1000
Yen)

If you put "No", there will be no space between
the amount and the currency symbol.

e.g: Rs1000, $1000, 1000Yen.

2 On completing the information, Tally seeks your
confirmation to save the company profile by asking
"Accept?" "Yes or No".

- If you click "Yes", the information will be stored and
necessary folder and data files for the company will
be created.

 If you click "No", the information will not be
stored.

1 If you want to modify put the cursor at the particular
field then make necessary modifications.

 Press Ctrl + A to save the information.

2 If you want to modify the company information even
after storing it, click company info button in the button
bar.

3 Then select "Alter" in the Gate way of Tally.

4 This will show the list of companies select a company
in which you want modification.

5 Press Ctrl +A to save the changes.

TASK 3 : Select a Company

The company Universal Enterprises maintains
Accounts and Inventory for the financial year
1.04.2011. Booking begins from 1.4.2011. Once
the Company creation screen is accepted, the
Gateway of Tally Screen loads. The Gateway
of Tally screen is displayed as shown: (see Fig
3)

To Select a Company, in Gateway of Tally you have to
press Alt+F3 (Company Info.) and then Select
Company.

1 Tally.ERP9 displays the List of Companies screen with
all the companies created in an alphabetical order.

2 Select the required company from the list.

3 Incase two or more companies are loaded, click on
the company which you need to work on.

The selected company will be highlighted and
will appear on top of the list.
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TASK 4 : Alter a Company

To Alter a Company, In the Gateway of Tally you have
to press Alt + F3 (Company Info.) and then Alter the
company.

1 Select the company which you need to alter from the
List of Companies.

2 Press Enter to view the Company Alteration screen.

3 Alter the company details as required and accept the
screen.

TASK 5 : Shut a Company

To Shut a Company, In the Gateway of Tally you have
to press Alt + F3 (Company Info.) and then Shut the
company.

- Select the company which you need to shut from the
List of Companies

- You can also use Alt + F1 to shut a Company from the
Gateway of Tally screen

- You can also access these functions, by selecting
the appropriate button from the button bar

TASK 6 : Create a ledger account

1 Before creating a journal, it is necessary to create,
required ledger accounts.

2 In journal, we have to record the amount against a
particular ledger account.

So ledger account is first created. (see Fig 4)

Fig 3
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1 In the gateway of Tally you have to click "Accounts
Info" or just press "A".

You will be entered into Accounts Info menu.

2 In "Accounts Info "menu click "Ledgers" or just press
"L".

You will get a new "Ledgers" menu.
(see Fig 5)

3 In "Ledgers" menu click "create" or just press "C".

You will get a ledger creation screen.

4 In ledger creation screen (see Fig 6, 7,8)

- Enter the name of the account in the name field e.g.
Sales, Furniture, etc.
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Fig 5
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Fig 6

Fig 7
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- You enter alias name in the alias name field or just
leave the field empty.

- In "Under" field you choose any one of the related
"groups name" from the "list of groups".

- Maintain balance bill-by-bill. It will ask Yes or No. Put
"No", in this field.

- "Opening Balance" field is kept empty.

- Then the cursor goes to mailing and related details.

5  By default Account name is displayed in the Name
field.

You fill up the remaining fields or you keep
the fields empty. Then hit enter.

 6  Then a dialogue box will ask you “Accept” Yes or No.

Press “Y” to save the account. (see Fig 7)

TASK 7: Create Journal & entering transactions

- In gateway of Tally select “Accounting Vouchers” or
just press “V”.

You will enter into “Accounting Voucher
Creation” Screen.

- In the button areas press the “F7. Journal” button or j
just press “F7”

You will get a voucher screen for journal

- Journal number is displayed automatically.
(see Fig 9)

1 Enter the date of the journal that will fail within the
accounting year.

2 Press Enter or Tab key.

3 Then the cursor goes to particulars field that starts
with “By”.

4 A menu with ledger accounts appears. Select a account
that should be debited.

5 The cursor goes to the "debit" column.

6 Enter the amount and press enter key.

7 Now the cursor goes to the next row that starts with
"By" press Enter key.

8 A list of ledger accounts that should be created is
displayed. Select one of the accounts.

9 The credited value is displayed automatically.

10 Press enter key.

11 You will get into narration column.

12 Write the narration of the transaction. E.g. Sold good
to soloman or Cash sales.

13 Press Enter key

14 A dialogue box is displayed asking Accept? Yes or
No.
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15 Press "Y" key to save and "N" key for not to save. 16 If you save, then the next journal voucher is displayed
to enter next transaction.

TASK 8 : View journals

1 In the Gateway of Tally, click "Display" or just press
"D" key.

You will enter into "Display menu".
(see Fig 10)
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2 In display menu click Account books or press "A". You will get "Account books" menu.
(see Fig 11)

3 In "Account books" menu click "Journal register" or
just press "J" key.

4 You will enter into "Journal Register" screen.

There you will find months names.

5  Select the month for which you entered journal, say
April. (see Fig 12)
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You will get into a new screen that list all
journal vouchers.

6 You will select any journal to view the actual journal
voucher entries. (see Fig 13)
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IT & ITES                                                                                           Exercise 2.3.123A
COPA - Accounting Software - Tally

Report Generation - List of Accounts
Objectives: At the end of this exercise you shall be able to
• view list of accounts/ledgers

PROCEDURE

TASK 1 : View the list of accounts

1 Click Display in Gateway of Tally or  press "D".

The "Display menu"  screen appears.

2 In "Display menu" click "List of Accounts" or  press
"L". (see Fig 1)

3  Note the features of the ledgers displayed. Refer Note
    below:

The main features are as follows:

- List of Ledgers is displayed in alphabetical
order of main groups.

- The groups are in bold and begin on the
extreme left.

- The sub-groups are also in bold and slightly
indented towards the right.

- The ledger accounts are in italic and at the
lowest level.

Fig 1
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IT & ITES                                                                                           Exercise 2.3.123B
COPA - Accounting Software - Tally

Report Generation - Ledger
Objectives: At the end of this exercise you shall be able to
• view ledger account
• view trial balance.

PROCEDURE

TASK 1 : View ledger account

As the journal entries are posted automatically
to the respective accounts you will view the
ledger accounts directly.

1 In Gateway of Tally click Display or just press "D"
key.

You will enter into "Display menu".

 2 In display menu click "Account Book" or just press
"A" key.

You will  get the "Account Book" menu.

 3 In Account Books menu click Ledger or just press
"L".

You will get a text box and a menu of list of
ledgers.

4 You will  type the Ledger Account name in the text
box or you will  click from the menu.

You will get the ledger account. (see Fig 1)

By clicking the journal entry field, you will to
view the corresponding journal also.

Fig 1
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TASK 2 : View Trial Balance

1 In the Gateway of Tally, press "D" or click "Display".

You will  get a display menu.

 2 In Display menu click "Trial Balance" or just press
"T".

 You will  see the trial balance on the screen.
(see Fig 2)

- Further clicking the group names.

- you will get into a screen that shows all the ledger
account involved with the group.

- Further clicking the ledger accounts, monthly
summary is displayed.

- By clicking a month, you will get details of the ledger
account for that particular account.

- By clicking the particulars in the ledger.

Then the journal entries can be seen.
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IT & ITES                                                                                           Exercise 2.3.123C
COPA - Accounting Software - Tally

Reports - Profit and Loss Account & Balance sheet
Objectives: At the end of this exercise you shall be able to
• view Profit and Loss Account
• view Balance Sheet
• view Day Book.

PROCEDURE

TASK 1 : View profit and loss account

1 In the gateway of Tally Click  Profit and Loss Account
that lies under the heading Reports, or just press   "P". You will get the Profit and Loss account screen.

(see Fig 1)

TASK 2 : View Balance Sheet

1 In the gateway of Tally Click the Balance sheet option
that lies under Reports or you can just press the key

"B".

You will get the balance sheet screen.
(see Fig 2)

Fig 1



179

TASK 3 : View Day Book

1 In the gateway of Tally, press "D" or click "Display".

 You will get a display menu.

 2  In Display menu click "Day Book" or just press "D".

You will to see the Day Book on the screen.
(see Fig 3)
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Fig 3
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IT & ITES                                                                                           Exercise 2.3.123D
COPA - Final Accounts  - Tally

Final Accounts Preparation
• create Company “SAGAR INDUSTRIES LIMITED “ in Tally & Maintain Accounts with Inventory management
• journalise the transactions
• prepare Cash book, Bank book & Day book
• show the Trial Balance
• balance Sheet
• Profit and Loss  Account Statement

Sagar started a Company as “SAGAR INDUSTRIES LIMITED” on 01/04/2018.

The following transactions occurs.

  Sl.No. Date Narration

1 10/04/2018 Sagar Brought capital Rs.1,00,000/- by cash

2 11/04/2018 Sagar deposited Rs.3,00,000/- at ICICI bank in Company’s
CurrentAccount as capital

3 12/04/2018 Purchase of Computer for Rs.15,000/- for office use

4 15/04/2018 Purchase of Furniture for Rs. 5,000/- for office use

5 30/04/2018 Paid Electricity Bill for Rs.1,500/-

6 30/04/2018 Paid Rent Rs.6,000/-

7 01/05/2018 Purchase of Computer 10 Nos. @ 20,000 each from Comptech
Limited on credit

8 01/05/2018 Lorry freight paid Rs.2,000/-

9 01/05/2018 Discount Received from Comptech Ltd Rs.10,000/- adjusted
in purchase bill payment.

10 02/05/2018 Cash Paid for Advertisement Charges Rs.3,000/-

11 02/05/2018 Stationery bill paid Rs.1,000/-

12 10/05/2018 Salary paid Rs.8,000/-

13 20/05/2018 Sale of Computer9 Nos. @ 30,000/- each to Caltex
Communication Ltd on credit

14 20/05/2018 Cash sale – Computer 1 No. @ 35,000/-

15 20/05/2018 Sales Discount 5% given to Spectrum Communications Ltd

16 25/05/2018 Cash paid Rs.1,95,000/- to Comptech Ltd

17 27/05/2018 Amount  Received from Spectrum Communications Ltd   against
sale bill adjusting sales discount

18 27/05/2018 Withdrawal of cash Rs.10,000/- for personal use

19 30/05/2018 Calculate 10% Depreciaton on Furniture

Calculate 25% Depreciation on Computer

20 30/05/2018 Provide Payables for Rent,Salary for May month
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TASK 1 : Create Company “SAGAR INDUSTRIES LIMITED “ in Tally & Maintain Accounts with Inventory
management

Create Company

1 Click “Create Company “  Option in Company Info.
(Fig 1)

2 On completing the information,  Tally seeks your
confirmation by asking Accept Yes or No. .Press Yes
to save the Companys information. (Fig 2)

Fig 1

Fig 2
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3 Select Company (Fig 3)

4 Press F1 to Select Company name, the list of
companies are displayed, from that we select our
particular company (Sagar Industries Ltd)

After selecting the Company Tally displays the
Gateway of Tally screen. (Fig 4)

Fig 4

Fig 3
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Ledger Creation

5 In Gateway of Tally screen Select “Account Info” or
Just Press ‘A’

6 In Accounts Info, Select “Ledgers” or just press ‘L’

(i.e. Gate way of Tally –> Accounts Info. –> Ledgers)

The following Ledger accounts are created in the following
manner

  Ledger Name Under

  Cash Account Current Asset Fig.5

  ICICI Bank Account Current Asset Fig.6

  Capital Account Current Liability Fig.7

  Electricity Expense Direct Expense Fig.8

  Rent Expense Direct Expense Fig.9

  Furniture Fixed Asset Fig.10

  Computer for Office
  purpose Fixed Asset Fig.11

  Purchase Account –
  Computer Purchase Account Fig.12

 Ledger Name Under

  Sales Account –
  Computer Sales Account Fig.13

  Salary account Direct Expense Fig.14

  Sagar –

  Withdrawal Account Current Liability Fig.15

  Stationary Expense Direct Expense Fig.16

  Sales Discount Indirect Expense Fig.17

  Purchase Discount Indirect Income Fig.18

  Advertisement Indirect Expense Fig.19

  Lorry Freight Direct Expense Fig.20

  Comptech Ltd. Sundry creditor Fig.21

  Spectrum

  Commnications Sundry Debtor Fig.22
  Depreciation Indirect Expense Fig.23

  Payables –
  Salary, Rent Current Liability            Fig.23a

Fig 5
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Fig 6

Fig 7
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Fig 8

Fig 9
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Fig 10

Fig 11
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Fig 12

Fig 13
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Fig 14

Fig 15
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Fig 16

Fig 17
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Fig 18

Fig 19
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Fig 21
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Fig 23
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Fig 22
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Fig 23a

7 By clicking ‘Yes’ in the Accept dialog box, the above
all Ledger accounts are created.
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TASK 2: Journalising the transactions

Date Particulars Dr. Cr. Key

 10/04/2018 Cash Account 1,00,000.00  F6 Receipt      Fig.25

  To Capital Account         1,00,000.00

 11/04/2018 Cash Account 3,00,000.00 F6 Receipt Fig.26

   To Capital Account 3,00,000.00

 11/04/2018 ICICI Bank 3,00,000.00 F4 Contra Fig.27

  To Cash Account 3,00,000.00

 12/04/2018 Computer for Office Use 15,000.00 F5 Payment Fig.28

   To Cash    15,000.00

 15/04/2018 Furniture Account  5,000.00 F5 Payment Fig.29

  To Cash      5,000.00

 30/04/2018 Electricity Charges 1,500.00 F5 Payment Fig.30

  To Cash      1,500.00

 30/04/2018 Rent Expense 6,000.00 F5 Payment Fig.31

  To Cash      6,000.00

 01/05/2018 Purchase – Computer 2,00,000.00 F9 Purchase Fig.32

 To Comptech Ltd 2,00,000.00

 01/05/2018 Lorry Freight  2,000.00 F5 Payment Fig.33

  To Cash      2,000.00

 01/05/2018 Comptech Ltd 10,000.00 F7 Journal Fig.34

  To Purchase Discount    10,000.00

 02/05/2018 Advertisement Exp. 3,000.00 F5 Payment Fig.35

  To Cash      3,000.00

 02/05/2018 Stationary Exps. 1,000.00 F5 Payment Fig.36

  To Cash     1,000.00

 10/05/2018 Salary Exps. 8,000.00 F5 Payment Fig.37

  To Cash     8,000.00

 20/05/2018 Spectrum Comm.Ltd 2,70,000.00 F8 Sales Fig.38

  To Sales 2,70,000.00

 20/05/2018 Sales Discount 13,500.00 F7 Journal Fig.39

  To Spectrum Com.Ltd    13,500.00

 25/05/2018 Cash 35,000.00 F8 Sales Fig.40

  To Sales    35,000.00
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Fig 24

Date Particulars Dr. Cr. Key

 30/05/2018 Cash 2,56,500.00 F6 Receipt Fig.41

  To Spectrum Com.Ltd 2,56,500.00

 30/05/2018 Comptech Ltd. 1,90,000.00 F5 Payment Fig.42

  To Cash 1,90,000.00

 30/05/2018 Sagar Withdrawal A/c. 10,000.00 F5 Payment Fig.43
  To Cash  10,000.00

 30/05/2018 Depreciation 500.00 F7 Journal Fig.44

  To Furniture         500.00

 30/05/2018 Depreciation 3,750.00 F7 Journal Fig.45

  To Computer-office      3,750.00

 30/05/2018 Rent Exp. 6,000.00 F7 Journal Fig.46

Salary Exp. 8,000.00

  To Payable–Rent,Salary      14,000.00

1 Enteri the transaction in Tally

- Select Gateway of Tally->Account vouchers (Fig 24)
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Fig 25

Fig 26
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Fig 27

Fig 28

IT & ITES : COPA - (NSQF- 4 )  Exercise 2.3.123D



198

Fig 29

Fig 30
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Fig 31

Fig 32
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Fig 33

Fig 34
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Fig 35

Fig 36
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Fig 37

Fig 38
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Fig 40
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Fig 41

Fig 42
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Fig 43

Fig 44
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Fig 45

Fig 46
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Fig 47

Fig 48

TASK 3: Daybook  Printing

- Click Gateway of Tally-> Display - > Daybook (Fig.47)

Cash Book Printing

- Gateway of Tally -> Account Books - > Ledger ->Cash (Fig.48)
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TASK 4: Trial Balance Printing

- Click Gateway of Tally - > Display - > Trial Balance
(Press F1 for Detailed, F5 Ledgerwise) (Fig.49)

Fig 49

TASK 5: Balance Sheet Printing

- Gateway of Tally - >  Balance Sheet (Fig 50)

Fig 50
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Balance Sheet  (F1 - Detailed) (Fig 51)

TASK 6: Profit/Loss statement

Fig 52

The Business is running in Profit as Net Profit of
Rs.61,750/-
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IT & ITES                                                                                           Exercise 2.3.124A
COPA - Accounting Software

Cost Centre and Cost Category
Objectives: At the end of this exercise you shall be able to
• enable Cost Centre and Cost Category.

TASK 1 : Enabling Cost Centre and Cost Category

1 Go to Gateway of Tally > F11: Features >
F1:Accounting Features

2 Set ‘Maintain Cost Centres’ to ‘Yes’

3 Set ‘More than ONE Payroll/ Cost Category’ to ‘Yes’
(Fig 1)

Fig 1

Creating Cost Categories

To group the salesmen under one Cost Category (one
similar project):

- Go to Gateway of Tally > Accounts Info. > Cost
Categories >  Select ‘Create’ under ‘Single Cost Centre’

Enter ‘Sales Project 1’ in ‘Name’ > Accept the screen

Creating Cost Centres

Each salesman is considered as a cost centre, so to create
these:

- Go to Gateway of Tally> Accounts Info.> Cost

- Centres> Select ‘Create’ under Single Cost Centres

- Select ‘Sales Project 1’ in ‘Category’

- Enter ‘Salesman 1’ in Name and accept the screen

Similarly, you can create cost centres for other different
salesmen.

Allocating Expenses to Cost Centres during
Transaction

To allocate expenses to each cost centres while making
payment for salesmen’s expense (for e.g. Conveyance):

- Let’s create a ‘Conveyance’ ledger under ‘Indirect
Expense’. Also note that ‘Cost Centre is enabled by
default.

To pass the payment transaction:
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- Go to Gateway of Tally > Accounting Vouchers > F5:
Payment

- Debit the ‘Conveyance’ ledger with the required
amount

- Press Enter to open ‘Cost Allocation’ screen

- Select the ‘Sales Project 1’ in ‘Cost Category’

- Allocate each Salesman with the amount as shown:

Pre-Allocation of Costs

For faster entry you can pre-allocate cost centres by
defining percentage in the Cost Centre Class. For
example, if a salary of Rs.50, 000 is to be paid and
distributed as 30% to Salesman 1, 25% to Salesman 2,
25% to Salesman 3 and 20% to Salesman 4. To do this:

- Go to Gateway of Tally > F11: Accounting Features

- Set ‘Use Pre-defined Cost Centre Allocations during
Entry’ to ‘Yes’ > Press ‘Enter’ (Fig 2)

Cost Centre Reports

For faster identification and detailed analysis of how costs
are allocated to your business units, Tally.ERP 9 provides
reports to show complete details of all the cost centres
and their related transactions in different ways. These
reports are:

1 Category Summary

2 Cost Centre Break-up

3 Ledger Break-up

4 Group Break-up

For example, the ‘Cost Category Summary’ report is
shown below:

To view these cost centre reports:

- Go to Gateway of Tally > Display > Statements of
Accounts > Cost Centres (Fig 3)
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Fig 3
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IT & ITES                                                                                           Exercise 2.3.124B
COPA - Accounting Software - Tally

Cost summary
Objectives: At the end of this exercise you shall be able to
• view cost category summary
• view cost centre summary.

PROCEDURE

TASK 1 : View cost category summary

1 Click Display in Gateway of Tally or just press "D".

You will get the "Display menu".

 2 In "Display menu" click "Statement of Accounts" or
just pass “S”.

You will get statement of Account menu.

3 In statement of “Accounts” menu click “Cost Centres”
or just press “C”

4 In Cost Centres menu click "Category summary" or
just press "C".

You will get a screen displaying Cost Category
Summary. (see Fig 1)

TASK 2 : View Cost Centre Summary

 1 Click Display in Gateway of Tally or just press "D".

You will get the "Display menu".

2 In "Display menu" click "Statement of Accounts" or
just press "S".

You will get Statement of Accounts menu.

3 In "Statement of Accounts" menu click "Cost Centres"
or just press "C".

 You will get Cost Centres.

Fig 1
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4 In Cost Centres menu click "Group Break-up" or just
press "G".

5 You will select the group as an Indirect Expenses.

Then you will get a screen displaying Cost
Centre Summary. (see Fig 2)
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IT & ITES                                                                                           Exercise 2.3.125
COPA - Accounting Software  - Tally

Budgeting System
Objectives: At the end of this exercise you shall be able to
• enable Budgets
• create Budgets
• alter and Delete Budget
• display Budgets and Variances for Groups and Ledgers.

TASK 1 : To Enable Budgets in Tally ERP 9

- Go to Gateway of Tally > F11: Features (Accounting
Features)

- Set ‘Maintain Budgets and Controls’ to ‘Yes’ (Fig 1)

TASK 2 : To create Budgets:

- Go to Gateway of Tally > Accounts Info. > Budgets

- Select ‘Create’ > Press ‘Enter’

- Enter budget name in ‘Name’

- Select ‘Primary’ in ‘Under’

- Specify the ‘Period of Budget’ in ‘From:’ and ‘To:’
(Fig 2)

Fig 1
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1 For Group Budgets:

- Set ‘Yes’ under ‘Group’ in ‘Set / Alter Budgets of’ >
Press ‘Enter’ (Fig 3)

Fig 3

Fig 2

- In ‘Group Budgets’ screen, select the required Group
in ‘Account Name’

- Select the appropriate ‘Type of Budget’

- Enter budget ‘Amount’

- Accept the screen
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Note : ‘On Closing Balance’ option is used to
compare the closing balances of the Accounts
with the budgets in the final statements. ‘On
Net Transactions’ is used to monitor the
transaction amounts (not the balances) for a
specified period.

2 For Ledger Budget

Set ‘Yes’ under ‘Ledgers’ in ‘Set/ Alter Budgets of’ > Press
‘Enter’

Just as we have created the group ledger, ledger budget
can be created as shown. (Fig 4)

Fig 4

TASK 3 : Altering and Deleting Budget

You can make changes to Budgets as per your
requirement. To do these:

- Go to Gateway of Tally > Accounts Info. > Budgets >
Alter

To delete budget, press ‘Alt+D’ on the budget alteration
screen.

Displaying Budgets and Variances for Groups and
Ledgers

Once the required budgets are created, they can be
displayed in the new columns in financial statements such
as Balance Sheet, Profit & Loss Account etc.

Let’s include the created Group Budgets in Trial
Balance and view the variance.

- Go to Gateway of Tally > Display > Trial Balance

- Press ‘Alt+B’ or click on ‘B: Budget Variance’
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     Scenario management is a management tool that
enables different displays of accounts and inventory
related information, by selectively including certain
types of vouchers without affecting the source data.
It is useful in generating provisional reports, where
entries are not actually made in the main books. It is
also a useful forecasting tool i.e. you can forecast
the expenses using provisional Vouchers and include
them in your reports.

The vouchers that are used in Scenario Management
are:

1 Optional Vouchers

2 Memorandum Vouchers

3 Reversing Journals

TASK 1: Enabling Scenario management

CLICK GATEWAY OF TALLY->  F11 Accounting
Features, Click  Yes to reversing journals and optional
vouchers. (Fig 1)

TASK 2 : Creating a Scenario

Go to Gateway of Tally > Accounts Info. >
Scenario > Create (Fig 2)

IT & ITES                                                                                           Exercise 2.3.126
COPA  - Accounting Software  - Tally

Scenario and Variance Analysis
Objectives: At the end of this exercise you shall be able to
• practice on enable scenario management
• create scenario
• alter scenario
• reversing journal in scenario
• scenario statement & reports.

Fig 1
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Fig 2

1 Give a suitable name to the scenario. In this case, it
is Provisional.

2 Set Include Actuals to Yes

3 Set Exclude Forex Gains/Losses Calculations to
Yes if you do not want the Unadjusted Forex Gain/
Loss  element to appear in the scenario

4 Set Exclude Inventory Tracking Calculations to Yes
if you do not want the Sales/Purchase Bills Pending
element to appear in the scenario

5 Include - From the list of vouchers, include the type of
vouchers required. Notice that it picks up the Voucher
Types created for this company. Provisional Vouchers
and Regular vouchers that are marked Optional are
permitted for selection.

6 Exclude - Exclude from the list of vouchers already
included in the type of vouchers that you do not  want
to affect this scenario. This option is used in Alter
mode and hence is discussed under Alter/Display
Scenario Information.

7 Accept to create this scenario.

TASK 3 : Altering a Scenario

Go to Gateway of Tally > Accounts Info > Scenario
> Alter

- Select the scenario to alter from the List of Scenarios

The information given while creating the scenario displays
and you can alter it.

Exclude

Use the Alter mode, when you do not want a selected
included voucher to affect the scenario, anymore. It is
easier to put the selected voucher in the Exclude List,
rather than to remove it from the Include List.

TASK 4 : Using Reversing Journals in Scenarios

Create a Reversing Journal Entry for the scenario as
follows.

Go to Gateway of Tally > Accounting Vouchers > F10:
Rev Jrnl

1 Select Reversing Journals from the list.

2 Debit Depreciation and enter the amount

3 Credit Provision for Depreciation (Fig 3)

4 Enter Narration if any.

5 Accept the Voucher.
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TASK 5: Using Scenarios in Statements and Reports
You can use scenarios in statements (not registers) that
have the New Column button active.

1 Display the Balance Sheet.

2 Select New Column.

3 In the column details, tab down to Types of Values to
Show.

4 Select the scenario named Provisional.

The Balance sheet displays as shown with two columns
for the same date.

Note: the Provision for Depreciation figures in both the columns. The actual column shows 18250 while
the Provisional column shows 33250. This is on account of the reversing journal entry in the Scenario.
To view, go through the Exceptional Reports Display Menu.
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IT & ITES                                                                                           Exercise 2.3.127A
COPA - Accounting Software  - Tally

Ratio Analysis
Objectives: At the end of this exercise you shall be able to
• view ratio analysis.

PROCEDURE

TASK 1 : View ratio analysis

1 In the gateway of Tally you have to click "Ratio
Analysis" or just press "R". Then You will get the Ratio Analysis screen.

(see Fig 1)

Fig 1
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IT & ITES                                                                                           Exercise 2.3.127B
COPA - Accounting Software  - Tally

Cash flow & Funds flow statements
Objectives: At the end of this exercise you shall be able to
• view Cash Flow
• view Funds Flow

PROCEDURE

TASK 1 : View cash flow

 1 In the Gateway of Tally, click "Display" or just press
"D" key.

You will enter into "Display menu".

 2 In display menu click "Cash/Funds Flow" or press "C".

You will get "Cash/Funds Flow" menu.

3 In Cash/Funds Flow menu click "Cash Flow" or press
"C".

You will get cash flow screen. (see Fig 1)

TASK 2 : View Funds Flow

1 In the Gateway of Tally, click "Display" or just press
"D" key.

 You will enter into "Display menu".

2 In display menu click "Cash/Funds Flow" or press "C".

You will get "Cash/Funds Flow" menu.

3 In Cash/Funds Flow menu click "Funds Flow" or press
"F".

Fig 1
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IT & ITES                                                                                           Exercise 2.3.128A
COPA - Accounting Software  - Tally

Stock Grouping
Objectives: At the end of this exercise you shall be able to
• create unit of measure
• create stock group
• create stock item.

PROCEDURE

TASK 1 : Create unit of measure

1 In the Gateway of Tally you have to click "Inventory
Info." or just press "I".

 You will be entered into Inventory Info menu.

2 In "Inventory Info." menu click "Unit of Measure" or
just press "U".

You will get a new  "Unit " menu.

3 In "Unit" menu click "Creation" or just press "C".

You will get a unit creation screen. (see Fig 1)

Type

Tally has the option to create simple units as well as
compound units. Example of simple units are 'nos', 'pcs',
etc. compound Units is a combination of two simple units.
Examples of compound units is ' box of 10 pcs' a
combination of two simple units, 'pcs' and 'box'.

Symbol

This is the symbol by which we will identify the stock
item. For example,  'nos' to indicate 'numbers'.

Formal Name

This is the complete or formal name of the symbol.
Specifying the formal name is useful if you wish to

Fig 1
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consolidate data of different companies where the symbols
might be the same but are assigned to difference Units.
In such a case - the formal name will be used to match
them.

Number of Decimal places

If the unit will be used in fractions, say for a kilogram you
may have to use grams as well, give the number of decimal
places. For kilograms, you would give 3 decimal places
to accommodate up 999 grams. Hence, a measure, 1
kilogram 865 grams will be 1.865 kilograms. For units

like numbers, you do not normally want a decimal place
and you can specify 0 in such cases. You can specify 0
to 4 decimal places.

Let us create the unit 'Number'.

For 'Type' select SIMPLE

For 'Symbol' type 'nos'

For 'Formal Name'- type' Number'

For 'Number of Decimal places'- type '0'

TASK 2 :  Create Stock Group

You will get a new "Stock Groups" menu.

3 In "Stock Groups" menu click "Stock Group Creation"
or just press "C".

You will get a Stock Group creation screen for
create under Single Stock Group. (see Fig 2)
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1 In the Gateway of Tally you have to click "Inventory
Info." or just press "I".

You will be entered into Inventory Info menu.

 2 In "Inventory Info." menu click "Stock Groups" or just
press "G".

Fig 2
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TASK 3 : Create Stock Item

1 In the Gateway of Tally you have to click "Inventory
Info." or just press "I".

You will be entered into Inventory Info menu.

2 In "Inventory Info." menu click "Stock Items" or just
press "I".

You will get a new "Stock Items"  menu.

3 In "Stock Items" menu click "Stock Item Creation" or
just press "C".

You will get a Stock Item creation screen. (see
Fig 3)

• You can enter the stock group under which to classify
the stock item.

• Enter  the unit of measure for the stock item being
created.

• In "Opening Balance" enter the opening balance of
the stock item already available with us.
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IT & ITES                                                                                           Exercise 2.3.128B
COPA - Accounting Software - Tally

Analyzing and Managing Inventory
Objectives: At the end of this exercise you shall be able to
• know inventory features
• view the stock summary
• view the stock category
• view the stock query
• transfer materials via Journal Voucher
• create Bill of Materials for a Stock Item
• record the Manufacturing Journal of Finished Goods.

PROCEDURE

TASK 1 : Inventory features
1 In gateway of Tally press the "F11:Features" button or

just press "F11".

2 In "Company Features" menu click "Inventory
Features" or just press "I".

3 You also just press the "F2" key for "F2:Inventory"

The F2:Inventory Features screen is displayed
as shown: (see Fig 1)

4 Enable the required features and press Enter to accept.

TASK 2 : View the Stock Summary.
1 In the Gateway of Tally, click "Display" or just press

"D" key.

You will enter into "Display menu".

2 In display menu click "Inventory books" or press "I".

You will get "Inventory books" menu.

3 In Inventory books click "Group Summary" or press
"G".

 You will get list of Groups.

Fig 1
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4 Select the Primary group and also click
"F12:Configuration" or press "F12".

5 Set the Expand all levels in detailed format to "Yes"
and press "Enter" to accept

6 Click the "F1:Detailed" and then display the stock
summary screen. (see Fig 2)

7 This report displays all stock groups in a single screen
and to view the report for a specific group, just clicks
individual groups.

TASK 3 : View the Stock Categories.

1 In the Gateway of Tally, click "Display" or just press
"D" key.

 You will enter into "Display menu".

2 In display menu click "Statements of Inventory" or
press “E”

You will get “Statements of Inventory”menu
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3 In Statements of Inventory click “Categories” or press
“C”

You will get the list of Categories.

4 Select the Primary category.

Then display the stock category summary
screen. (see Fig 3)

Fig 2
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TASK 4 : View the Stock Query.

1 In the Gateway of Tally, click "Display" or just press
"D" key.

You will enter into "Display menu".

2 In display menu click "Statements of Inventory" or
press "E".

You will get "Statements of Inventory" menu.

 3 In Statements of Inventory click "Stock Query" or press
"T ".

You will get the list of Items.

4 Select the Item  and then display the Stock Query
screen. (see Fig 4)

Fig 3
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Task 5 : Transfer materials via Journal Voucher
- To create stock journal for inter - godown
transfers,

1. Go to Gateway of Tally > Inventory vouchers >
Alt+F7 for Stock Journal and select the class.
(Fig 5)

Fig 4

      Fig 5
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2. Pass the stock transfer entry. (Fig.6)

- To print stock transfer vouchers

 Press Alt+P to print the Stock Transfer
Journal Voucher.

TASK  6 : Creating Bill of Materials for a Stock Item

- To setup Bill of Materials Fig. 7

    Go to Gateway of Tally > F12: Configure

> select Accts/Inventory Info.

-  Set Allow Component List Details (Bill of
Materials)? to Yes .
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For a Stock Item you can create

-  A Single BOM

-  Multiple BOM

-  Single/Multiple BOM with Type of Item.

TASK 7 : Record the Manufacturing Journal of Finished Goods

5 Application skips the BoM Name field as bill of
Material is not created for the stock item.

6 In Godown field select the godown where the finished
goods manufactured will be stored.

7 In Quantity field specify the quantity of goods
manufactured. For example, 300 

8 In Cost Tracking field select the Cost Tracking
Number towards which you want to track the cost of
Manufacture.(Fig 8)

ABC Company manufactured 300 Cooker 12Liters.

To record the Transaction in Manufacturing Journal

1 Go to Gateway of Tally > Inventory Vouchers >
F7: Stock Journal

2 In Change Voucher Type screen
select Manufacturing Journal from the List of Types.

3 Enter the Date 

4 In Name of Product select the Finished Goods which
is manufactured. E.g. Cooker 12 Litre.
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9 Under Components (Consumption) section select
the stock items which are used to manufacture the
finished goods.

10 Name of Item : In this field select the components
used to manufacture the finished goods.

11 Godown : In this field select the goods from where
the components are consumed.

12 Quantity : In this field mention the Quantity of
Components required to manufacture the finished
goods.

13 Rate : In this field specify the Rate of Components.

14 Amount : Amount will be calculated and displayed
automatically.

15 Under Co-Product / By-Products / Scrap section
select the stock items which are produced as Co-
Product / By-Products of finished goods or Scrap.

16 Name of Item : In this field select the Co-Product /
By-Products / Scrap produced during manufacture of
Finished goods.

17 Godown : In this field select the goods from where
the Co-Product / By-Products / Scrap  are stored.

18 % of Cost Allocation : In this field specify the % of
cost of allocation to be made towards the By-product/
Co-product/Scrap produced.

19 Quantity : In this field mention the Quantity of Co-
Product / By-Products / Scrap produced.

20 Rate & Amount : Rate & Amount will be displayed
automatically based on the % of Cost Allocation.

The completed Manufacturing Journal will be displayed
as shown:(Fig 9)
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21. Press Enter to save.
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Fig.9
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IT & ITES                                                                                           Exercise 2.3.129A
COPA - Accounting Software - Tally

VAT & Service Tax Processing in Tally
Objectives: At the end of this exercise you shall be able to
• view the statutory & taxation menu
• perform value added tax entry for purchase
• perform value added tax entry for selling
• view value added tax report
• set the service tax processing in tally.

PROCEDURE

TASK 1 : View the statutory & taxation

1 In gateway of Tally press the "F11:Features" button or
press "F11". (see Fig 1)

2 In "Company Features" menu click "Statutory &
Taxation" or  press "S".

• You  may also  press the "F3" key for "F3:Statutory" .

The F3:Statutory&Taxation screen is displayed
as shown: (see Fig 2)

3  Set the Enable Value Added Tax  to "Yes"

4  Set/Alter VAT Details to "Yes".

5  Enter the Value Added Tax Details. (see Fig 3)

 6  Press Enter or "Y"  key to accept.

Fig 1

Fig 2
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TASK 2 : Value Added Tax (VAT) Entry for Purchase

1  In the gateway of Tally click "Accounts Info".

2  In "Accounts Info" menu click the "Ledgers".
3  Create the ledger for sundry creditor as follows : (see

Fig 4)

4  Create the ledger for input vat as follows :(see Fig 5)

5  Create the ledger for purchase account as follows
    (see Fig 6)

6 Now go to purchase order voucher & enter the following
details: (see Fig 7)

7 Enter the receipt note voucher as follows : (see Fig 8)
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Fig 5
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Fig 7
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Step  8 : Now enter the purchase bill voucher as follows:
(see Fig 9)

TASK 3 : Value Added Tax (VAT) Entry for Sell

1 In the gateway of Tally you have to click "Accounts
Info".

2  Click the "Ledgers" In "Accounts Info" menu .

3 Create the ledger for sundry debtor as follows : (see Fig
10)

4  Create the ledger for output vat as follows : (see Fig 11)

5  Create the ledger for sell account as follows: (see Fig
12)

6 Now go to sell order voucher & enter the following
details: (see Fig 13)

7  Enter the delivery note voucher as follows : (see Fig
14)

8 Enter the sell bil l voucher as follows: (see
Fig 15)
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Fig 10

Fig 11
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Fig 12
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Fig 15

Fig 14
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TASK 4 : View Value Added Tax  (VAT) Report

1 In Gateway of Tally click Display or  press "D" key.

 The "Display menu" screen appears.

 2 In display menu click "Statutory Reports" or  press
"O"

The "Statutory Reports" menu appears.

3  In Statutory Reports menu click "VAT Reports" or
press "V".

The "VAT Reports" menu appears.

4 In VAT Reports menu click "VAT Forms" or  press "A".

The "VAT Forms" menu appears.

5  In VAT Forms menu click "VAT Return" or  press "V".

The "VAT Return" menu appears.

6  In VAT Return menu click "FORM VAT 100" or  press
"F".

The report on Form VAT 100 is displayed.. (see
Fig 16)
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TASK 5 : Set the Service Tax Processing in Tally

1 In gateway of Tally press the "F11:Features" button or
press "F11".

2 In "Company Features" menu click "Statutory &
Taxation" or  press "S".

IT & ITES : COPA - (NSQF- 4 )   Exercise 2.3.129A



246

• You also  press the "F3" key for "F3:Statutory" .
(see Fig 17)

3  Set the Enable Service Tax to "Yes".

4  Set/Alter Service Tax Details to "Yes".

5  Enter the Company Service Tax Details. (see Fig 18)

6  Press Enter or "Y"  key to accept.
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IT & ITES                                                                                           Exercise 2.3.129B
COPA - Accounting Software

TDS in Tally
Objectives: At the end of this exercise you shall be able to
• set the tax deducted at source in tally.

PROCEDURE

TASK 1 : Set the TDS (Tax Deducted At Source) in tally

1 In gateway of Tally press the "F11:Features" button or
press "F11".

2 In "Company Features" menu click "Statutory &
Taxation" or  press "S".

- You may also press the "F3" key for "F3:Statutory" .

The F3:Statutory&Taxation screen is displayed
as shown: (see Fig 1)

3  Set the Enable Tax Deducted at Source to "Yes".

4  Set/Alter TDS Details to "Yes".

5  Enter the Company TDS Details. (see Fig 2)

6  Press Enter or "Y"  key to accept.

Fig 1
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Fig 2
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IT & ITES                                                                                           Exercise 2.3.129C
COPA - Accounting Software  - Tally

TCS in Tally
Objectives: At the end of this exercise you shall be able to
• set the tax collected at source in tally
• enter tax collected at source journal
• view tax collected at source reports.

PROCEDURE

TASK 1 : Set the TCS (Tax Collected At Source) in tally

1 In gateway of Tally press the "F11:Features" button or
just press "F11".

2 In "Company Features" menu click "Statutory &
Taxation" or just press "S".

- You also just press the "F3" key for "F3:Statutory" .

The F3:Statutory&Taxation screen is displayed
as shown: (see Fig 1)

3 Enter the Enable Tax Collected at Source to "Yes"

4 Set/Alter TCS Details to "Yes".

5 Enter the Company TCS Collector Details. (see Fig 2)

6 Press Enter or "Y"  key to accept.

Fig 1
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TASK 2 : Enter Tax Collected at Source (TCS)  Journal

1  In the gateway of Tally you have to click "Accounts
Info". Then In "Accounts Info" menu click the

"Ledgers".
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2  In Sundry Debtors accounts enables TCS by altering
the ledger. (see Fig 3)

3 Create TCS account in ledger creation screen as
follows: (see Fig 4)

4  In gateway of Tally you have to select "Accounting
Vouchers".

5  Then "Accounting Voucher Creation" Screen in the
button area press the "F7:Journal" button or just press
"F7".

You will get a voucher screen for journal.

6  Enter sales bill using the accounting voucher as follows:
(see Fig 5)

7  Enter the Payment of TCS journal entry using the
accounting voucher for the payment as follows:(see
Fig 6)
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TASK 3 : View Tax Collected At Source (TCS)  Reports

1 In Gateway of Tally click Display or just press "D"
key.

You will enter into "Display menu".

2 In display menu click "Statutory Reports" or just press
"O" to get the "Statutory Reports" menu.

3 In Statutory Reports menu click "TCS Reports" or just
press "O" to get the "TCS Reports" menu.

4 In TCS Reports menu click "Print Form 27D" or just
press "T",

Then select the name of the ledger to get the
report on Form 27D. (see Fig 7)
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IT & ITES                                                                                           Exercise 2.3.129D
COPA - Accounting Software  - Tally

FBT in tally
Objectives: At the end of this exercise you shall be able to
• set the fringe benefit tax in tally.

PROCEDURE

TASK 1 : Set the FBT (Fringe Benefit Tax) in tally

1 In gateway of Tally press the "F11:Features" button or
press "F11".

2 In "Company Features" menu click "Statutory &
Taxation" or press "S".

• You may also press the "F3" key for "F3:Statutory" .

The F3:Statutory&Taxation screen is displayed
as shown: (see Fig 1)

3 Set the Enable Fringe Benefit Tax to "Yes".

4 Set/Alter FBT Details to "Yes".

5 Enter the Company FBT Assessee Details.
(see Fig 2)

6 Press Enter or "Y"  key to accept.

7 Enter the Tax Information like Local Sales Tax Number,
Inter-state Sales Tax Number,  PAN/Income - Tax No.

8  Press Enter or "Y"  key to accept. (see Fig 3)

Fig 1
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Fig 2
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IT & ITES                                                                                           Exercise 2.3.130
COPA - Accounting Software   - Tally

Configurations in Tally
Objectives: At the end of this exercise you shall be able to
• view & set the different types of configurations in tally

PROCEDURE

TASK 1 : View & Set general configuration

1 In gateway of Tally press the "F12:Configurations"
button or press "F12".

The Configuration screen is displayed as
shown: (see Fig 1)

2 Select the "General" menu or click the "G" key.

The General Configuration screen is displayed

3  Configure Country Details, Style of Names, Dates and
    Numbers in the General Configuration screen. (see Fig2)

Fig 1

Fig 2
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TASK 2 : View & Set Numeric Symbols Configuration

1 In gateway of Tally press the "F12:Configurations"
button or press "F12".

2 Select the "Numeric Symbols" menu or click the "N"
Key.

The Numeric Symbols screen is displayed.

3 Configure Number Styles and Symbols used to
represent Positive Numbers, Negative Numbers, Debit
Amounts and Credit Amounts by using Numeric
Symbols. (see Fig 3)

TASK 3 : View & Set Accts / Inventory Info. Configuration

1 In gateway of Tally press the "F12:Configurations"
button or press "F12".

2 Select the "Accts / Inventory Info." menu or click the
"A" Key.

The Accts/Inventory Configuration screen is
displayed.

3 Enable additional settings /options/ configurations in
Accounting and Inventory masters. (see Fig 4)

TASK 4 : View & Set Voucher Entry Configuration

1 In gateway of Tally press the "F12:Configurations"
button or press "F12".

2 Select the "Voucher Entry" menu or  click the "V"
Key.

The Voucher Entry Configuration screen is
displayed.

3 Configure additional settings and options during voucher
entry. (see Fig 5)
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TASK 5 : View & Set Invoice / Orders Entry Configuration

1 In gateway of Tally press the "F12:Configurations"
button or press "F12".

2 Select the "Invoice / Orders Entry" menu or click the
"I" Key.

The Invoice Entry and Order entry screens are
displayed.

3 Configure  additional information such as export details,
shipping details, etc.

TASK 6 : View & Set Payroll Configuration

1 In gateway of Tally press the "F12:Configurations"
button or press "F12".

2 Select the "Payroll Configuration" menu or click the
"Y" Key.

The Payroll Configuration screen is displayed.

3 Enter information related to Statutory Details, Passport
& Visa Details, Contract Details and Resigned/Retired
Employees. (see Fig 6)

IT & ITES : COPA -  (NSQF- 4 )  Exercise 2.3.130

Fig 5

Fig 6



259

TASK  7 : View & Set Banking Configuration

1 In gateway of Tally press the "F12:Configurations"
button or press "F12".

2 Select the "Banking Configuration" menu or click the
"B" Key.

The Banking configuration screen is displayed.

3  Configure settings related to Bank Reconciliation
Statement.

TASK  8 : View & Set Printing Configuration

TASK  9 : View & Set Data Configuration

1 In gateway of Tally press the "F12:Configurations"
button or press "F12".

2 Select the "Data Configuration" menu or click the "D"
Key.

The Data configuration screen is displayed

3  Define location of Language Files, Tally Configuration
File, Export Files, Data Files and details of the
companies to be loaded on startup. (see Fig 8)
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1 In gateway of Tally press the "F12:Configurations"
button or press "F12".

2 Select the "Printing" menu or click the "P" Key.

The Printing configuration menu is displayed.

3 Configure the print settings for various Accounting,
Inventory vouchers and other MIS related statements.
(see Fig 7)

Fig 7
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TASK  10 : View & Set TDL Configuration

1 In gateway of Tally press the "F12:Configurations"
button or  press "F12".

 2 Select the "TDL Configuration" menu or  click the "T"
Key.

The TDL Configuration screen is displayed.

3 Perform TDL Configuration for Local TDLs, Account
TDLs & Remote TDLs enabled for the product.

TASK 11 : View & Set Advanced Configuration

1 In gateway of Tally press the "F12:Configurations"
button or  press "F12".

2 Select the "Advanced Configuration" menu or  click
the "C" Key.

The Advanced Configuration screen is
displayed.

3 Specify Client / Server Configuration, Connection
configuration and Proxy configuration for ODBC
connectivity. (see Fig 9)

TASK 12 : View & Set Licensing Configuration

1 In gateway of Tally press the "F12:Configurations"
button or  press "F12".

2 Select the "Licensing" menu or  click the "L" Key.

The Licensing configuration menu screen
appears.

3 Update, surrender, reset license and also configure
existing License from this screen. (see Fig 10)
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IT & ITES                                                                                           Exercise 2.3.131
COPA - Accounting Software

Backup & Restore of Company
Objectives: At the end of this exercise you shall be able to
•  backup data of  the Company
•  restore data of the Company

TASK 1 : To Backup data of the selected Company

Gateway of Tally->Alt F3 the Company Info is displayed,
Select Backup. (Fig 1)

The source and Destination of data is to be specified,
then the backup of the specified company data is done.
(Fig 2)

Fig 1

Fig 2
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TASK 2: Restore Data of the Company

Gateway of Tally->Alt F3 the Company Info is displayed,
Select Restore. (Fig 3)

The Destination and source folders of the company data
is to be specified, then the data are restored. (Fig 4)
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IT & ITES                                                                                           Exercise 2.3.132
COPA - Accounting Software

Multilingual Functionalities
Objectives: At the end of this exercise you shall be able to
• set tally interface in different languages.

PROCEDURE

TASK 1 : Set tally interface in different langauges

1 In gateway of Tally press Alt + G key for the
"Language".

The Language Configuration Screen is
displayed.

2 Select the required language from the list of
Languages. (see Fig 1)

Fig 1
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TASK 1 : Browse and observe  features of ebay

1 Open web browser for accessing web page.

2 Type in the address bar as “http://www.ebay.in” as in
Fig 1

Items Placement On Click

Name of the Site / Logo

Products Catalogue

Offers

User Login

Seller Login

Terms & Conditions

Fig 1

3 Note down the features listed in the following table from
the main window.

IT & ITES  Exercise 2.4.133
COPA - E-Commerce

Main features of E-Commerce websites and compare them
Objectives : At the end of this exercise you shall be able to
• browse and observe features of ebay
• browse and observe Amazon website
• browse and listout the Flipkart
• browse and listout the OLX
• browse and listout QuickR
• compare websites and features on the following table basis by tick marks.
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Items Placement On Click

Name of the Site / Logo

Products Catalogue

Offers

User Login

Seller Login

Terms & Conditions

TASK 3 : Browse features of Flipkart

1 Open web browser for accessing web page.

2 Type in the address bar as “http://www.flipkart.com”
as in Fig.3

3 Note down the features listed in the following table
from the main window.

Fig 2

Fig 3

TASK 2 : Browse features of Amazon

1 Open web browser for accessing web page.

2 Type in the address bar as “http://www.amazon.in”
as in Fig.2

3 Note down the features listed in the following table from
the main window.

IT & ITES : COPA - (NSQF- 4)  Exercise 2.4.133
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Items Placement On Click

Name of the Site / Logo

Products Catalogue

Offers

User Login

Seller Login

Terms & Conditions

TASK 4 : Browse features of OLX

1 Open web browser for accessing web page.

2 Type in the address bar as “http://www.olx.in” as in
Fig.4

3 Note down the features listed in the following table from
the main window.

Items Placement On Click

Name of the Site / Logo

Products Catalogue

Offers

User Login

Seller Login

Terms & Conditions

Fig 4

IT & ITES : COPA - (NSQF- 4)  Exercise 2.4.133
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Items Placement On Click

Name of the Site / Logo

Products Catalogue

Offers

User Login

Seller Login

Terms & Conditions

Sl.No. Site Name Buy Sell     Used     Return\    COD     Feedback         Offers    Update
          Goods    Refund          Email

1 Ebay

2 Amazon

3 Flipkart

4 OLX

5 QuickR

Fig 5

TASK 6 : Compare websites and features on the following table basis by tick marks

TASK 5 : Browse features of QuickR

1 Open web browser for accessing web page.

2 Type in the address bar as “http://www.quickr.com” as
in Fig.5

3 Note down the features listed in the following table from
the main window.

IT & ITES : COPA - (NSQF- 4)  Exercise 2.4.133

Note : This chart compares facilities available
for users in various E-Commerce websites,
which increases the usability of services of the
particular site.  More facilities, more visitors,
which makes continuous sale over E-
Commerce sites.
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IT & ITES  Exercise 2.4.134
COPA - E-Commerce

Upload products for selling in E-Commerce sites and make online purchase
from E-Commerce sites
Objectives : At the end of this exercise you shall be able to
• create an account in Amazon website
• login and buy a desired product
• sell a product in OLX.in website.
TASK 1 : Create an account in Amazon website
1 Open amazon.in website

2 Create an account using Sign in - New Customer<Start
Here> option as in Fig 1.

3 Fill in Name, mobile, Email and password and press
continue to get a verification code OTP to the mobile
number as in Fig 2

4 Enter the OTP received via phone to finish registration
as in Fig 3 to complete registraion.

Fig 1

Fig 2

Fig 3

Fig 3
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TASK 2 : Login and buy a desired product

1 Login to the created account as in Fig 4.

2 View the deals in Today’s deals tab, it is matches to
buy.

3 Enter the item required to buy in the “search” tab at
the top of the site as in Fig 5.

4 Select on “ Sort by “ to get the order of the product list
as to price low to high or new & popular, etc.

5 Select the product that matches the requirement.
(Fig 6)

6 Click on the product desired to get detailed view of the
product as in Fig 7.

7 Click on “Buy now” to finish selection and purchase or
“Add to Cart” to continue for more items to buy. (Assume
here, it is Buy Now to complete the order) (Fig 8).

Fig 4

Fig 5

Fig 6

Fig 7

Fig 8

IT & ITES : COPA - (NSQF- 4)  Exercise 2.4.134
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8 Enter the password if asked.

9 Enter details of shipping address on the page. (Fig 9).

10 Select the payment method from available options.
(Fig 10)

Note : Use a Debit card which requires an OTP
to complete payment or COD if available which
allows to pay at the time of delivery

11 Complete the order and get a Track-order to know the
current status of order in future.

TASK 3 : Sell a product in OLX.in website

1 Open the website in a browser http://www.olx.in (Fig 11)

2 Click on Submit a free Ad to post a classified
advertisement (Fig 12)

3 Add a title to the ad, say Laptop Headphone and select
category, say ‘Accessories-Mobile’ as in Fig 13.

5 Put price for the product.

6 Write a description to match the product like ‘Best
sound quality with rich bass compatible with laptop
and mobile’ as in Fig 14.

Fig 9

IT & ITES : COPA - (NSQF- 4)  Exercise 2.4.134

Fig 10

Fig 11

Fig 12

Fig 13
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7 Upload view of product photographs (5 views of photos
will attract more) (Fig 15).

8 Enter seller name, Phone number and City and press
Submit to complete. (Fig 16).

9 Re-enter OTP if required to activate the advertisement.

Note : Posted ad will be active upto a standard
time frame i.e. 15 days minimum, then renewal
may be required.

IT & ITES : COPA - (NSQF- 4)  Exercise 2.4.134

Fig 14

Fig 15

Fig 16
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IT & ITES  Exercise 2.4.135
COPA - E-Commerce

Manage security issues in E-Commerce and payment operations
Objectives : At the end of this exercise you shall be able to
•  find website as a reliable one
•  secure personal information sharing
• secure payment operations online.

TASK 1 : Find website as a reliable one

1 Find a website to be a secured one by answering the
following test questions

Note : If the answers are not usual, the user
can confirm, the seller is not genuine and there
are chances for improper delivery of goods and
/ or its a cheating, scam site.

TASK 2 : Secure personal information sharing
The following table ensures for a secure E-commerce practice

1 Abnormally prices are too low Yes|No

2 Merchant gives proper address and contacts Yes|No

3 Is there lot of grammar mistakes Yes|No

4 Does the support call is attended Yes|No

5 Is the merchant looks professional Yes|No

a Never public internet / WiFi for online purchases

b Never forget to LOGOUT to secure the account associated

c Never save a Debit Card / Banking details with password or PIN in any
website as it can easily be hacked

d Never use a legible / assumable password

e Prefer Cash on Delivery option to avoid online payment threats

f Never share personal / confidential information to Login in any website
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TASK 3 : Secure payments operation online

The following points make payments online to be
secure.

a Ensure the payment gateway is PCI compliant by clicking the Payment Gateway’s Terms and
Conditions page

b Confirm, the payment transactions are encrypted, as encrypted data is securedof transfer time from
hacking

c Use always a transaction that requires a PIN and / or OTP to be received in mobile as without this
authentication, the amount will not be transferred

d Use E-Wallets to pay as there is no need to disclose banking or card details always and the amount
in the wallet only is spent securely.

IT & ITES : COPA - (NSQF- 4)  Exercise 2.4.135
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IT & ITES Exercise 2.5.136
COPA - Cyber Security

Protect information, computers and networks from viruses, spyware and
other malicious code
Objectives : At the end of this lesson you shall be able to
• run and identify virus using antivirus software
• repair or remove malware / virus affected files.

TASK 1 : Run and identify virus software

1 Refer to exercise no 1.4.17 from the First Semester
COPA Trade Practicals for anti virus software installation
as in Fig.1

2 Open the Avira antivirus software by double clicking
Avira Logo which brings the window as in Fig.2

3 Make sure, the software is updated and realtime
protection is set to ON status as in Fig.

4 Run scan files to check for any virus or malware in the
system as in Fig.3

Note : The antivirus can be run on any folder,
drive or on whole system files and takes time
accordingly to complete scan as in Fig 4.

− − − − − − − − −

Fig 1

Fig 2

Fig 3

Fig 4
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TASK 2 : Repair or remove malware / virus affected files

1 Run the scan files to get report of affected files list as
in Fig.5

2 Get the options on the scanner window as in Fig. and
in each item right click on Action to get list of options

Note :

Mark it as “Delete” if it is sure to remove
file.

Mark it as “Quarantine” to move files to a
non-accessible vault of antivirus folder

Mark it as “Repair” if the malware can be
repaired

3 Click “Apply now” to perform the selection and get
protected of the computer system files.

− − − − − − − − −
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Fig 5
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IT & ITES  Exercise 2.5.137
COPA - Cyber Security

Provide firewall security for internet connection and network system
Objectives : At the end of this lesson you shall be able to
• enable or disable firewall settings of windows 10
• protect system using windows defender.

TASK 1 : Enable or disable firewall settings of windows 10

1 Access Windows firewall using Win Key → Settings
→ Network & Internet as in Fig.1

2 Select Windows firewall in the available options to open
Windows - Defender security center as in Fig.2

Fig 2

3 Make sure the “Firewall” is ON state for Domain
Network, Private Network and Public Network as in
Fig.3

Note : The (active) state defines the current
available network.

4 Reset the firewall to default by clicking “Restore firewalls
to default” as in Fig 4.

Fig 1

Fig 4

5 Click on any network and in the next window, set
Windows Defender firewall status to OFF to disable
firewall.

Note : Don’t disable firewall unless it is
specifically required.

Fig 3

− − − − − − − − −
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TASK 2 : Protect system using Windows Defender

1 Click on the Virus & Threat protection option in the left
panel as in Fig 5.

2 Click “Scan Now” on the Threat History to scan files.
Alternatively Run a new advanced scan runs for cleaning
latest threat types as in Fig 6.

3 Run any action that is pending (or) required by settings
or updates, to make the  protection system up to date
as in Fig 7.

Fig 6

Fig 5
Fig 7

− − − − − − − − −

IT & ITES : COPA - (NSQF- 4 ) Exercise 2.5.137



278

IT & ITES  Exercise 2.5.138
COPA - Cyber Security

Protect the Computer against various Internet Threats
Objectives : At the end of this lesson you shall be able to
• identify common internet threats
• secure risks protected internet systems.

TASK 1: Identify common internet threats

Threat Type Functions

Botnet Spam mails with virus attachments a robots in net

Hacking Unauthorized access and steal information from system

Malware Damage data from system and fake alert of infections

Pharming Misleading to cloned / illegitimate websites

Phishing Tricky gather of information from users about Credit Cards

Ransomware Lock system / drives demand money to remove

Spam Junk mail to get info directly from users

Spoofing Sends spam mail and clone a legal site information

Spyware Steal contact information, username and passwords with
Popups

Trojen Horses Delete files, hack system info and user operations

Worms Spread unwanted files and dump the memory as well as disk
space

Viruses Delays startup time and make unwanted hidden file execution,
hide files /folders

TASK 2 : Checklist to safeguard systems from threats

1 Find the methods to protect systems and safe
operations from the following table and choose Yes/
No to determine whether the system is protected.

− − − − − − − − −
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Methods Protection System              Status

Passwords Complicated passwords reduce the method of Created  | Not Created
accessing to user info easily

Anti-Virus Software that protect system from threats Installed  |  Not Installed

Firewall Enabling this protects attacks from third party / Enabled  |  Not Enabled
external systems

Browser settings Updated browser with protected plug-ins Installed  | Not Installed
make safe browsing

OS Updates Updating the Operating System makes patches Updated  | Not updated
to existing less secured modules to be more safe

WiFi Security Protect personal WiFi with SSID and passwords Done  |  Not Done
and avoid public WiFi for safety based transactions

Download security Avoid unwanted downloads and ensure only the Enabled  |  Not Enabled
relevant files are downloaded.  Allow Anti- virus/
Defender to scan for threats  in downloaded files

Note : Make all the above tasks completed to
protect the system from any type of threats.

− − − − − − − − −
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IT & ITES  Exercise 2.5.139
COPA - Cyber Security

Make backup copies of important file, data and information
Objectives : At the end of this lesson you shall be able to
• take backup of files using  External hard drive
• backup files using Google Drive
• make a local restoration point and restore on failure / malfunction.

TASK 1 : Backup of files using external hard drive

1 Insert USB connector to access the external hard drive
as in Fig.1

Note : Usually the plugged hard drive is shown
using a new drive letter, auto assigned.
Change the name of the drive to ‘Backup’ so
as the it can be easily identified as in Fig.2

2 Select the files required to be back up, copy them all
and paste into the external hard drive as in  Fig 3.

Note : In case, the file size is too large, it may
take a long time to get pasted (Fig 4).  Its better
to use USB 3.0 to copy quickly.  Also take the
backup updated in regular intervals for safety
precautions.

Fig 2

Fig 1

Fig 4

Fig 3

− − − − − − − − −
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TASK 2 : Backup files using Google Drive

1 Download and install Google Drive application from
“http://www.google.com/drive/download” as in Fig1.

2 Open the exe file downloaded to install the Google Drive
into the system (will take 5 minutes and needs internet
to download features) as in Fig 2.

3 Login into Google account which is associated with
backup as in Fig 3.

4 Fix the folders to be back up to the system before
entering into backup as in Fig 4.

5 Add folders to drive from ‘My System/Laptop’ and press
NEXT to proceed.

6 Press START to start back up into Drive as in Fig 5.

7 Schedule timings like daily, weekly, etc. to set periodical
backup.

Fig 1

Fig 2

Fig 3

Fig 5

Fig 4

− − − − − − − − −
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TASK 3 : Local restoration point for failure recovery

1 Type ‘Restore Point’ in Cortana to search for ‘Create
Restore Point’

2 Select the option to get ‘Create a restore point’  as in
Fig 6.

3 Choose ‘Create’ option to create a Restore Point manu-
ally as in Fig 7.

4 Add description to the points identification, say
‘Before Installing Wordpress’

Note : The created restore point makes a
backup of applications as it is working and
related files ensuring the proper working.

5 Use system restore to restore the system to working
of files on the time of backup as in Fig.8

Fig 7

Fig 6

Fig 8

− − − − − − − − −
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IT & ITES  Exercise 2.5.140
COPA - Cyber Security

Secure WiFi networks and access controls
Objectives : At the end of this lesson you shall be able to
• configure a secure WLAN
• filter access using MAC Address
• create user accounts with limited rights.

TASK 1 : Configure a secure WLAN

1 Connect the internet port of the router with the incoming
internet connector as in Figures 1.

Note : In case of leased line, it will be a RJ45
connector and in case of Broadband / DSL it
will be a phoneline.

2 Connect LAN cable with port 1 of the modem and the
other end to the LAN connection of the system.

3 Run command prompt and type ‘ipconfig’ and press
Enter, which will bring a list of available options as in
Fig 2.

4 Find the default gateway (say eg. 192.168.0.1) and
access it using internet browser as in Fig 3.

Fig 1

Fig 2

Fig 3
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5 Type the username and password provided with modem
to login to access the configuration settings of the
modem and enter into configuration settings.

6 Click Network tab and in WAN settings, select the IP
mode or PPPoE mode suitable to access network and
provide the given username and password for accessing
(internet) as in Fig 4.

7 Select the list of Bound Ports including wireless ports
and Apply.

8 Select WLAN / Wireless tab, set the following items
as in Fig 5.

a SSID : <Name of the WiFi network>

Enable it for others to access.

Broadcast is enabled as it should be detected by
other devices.

b In WLAN security option select the following :

Encryption Mode : WPA-PSK;
WPA2-PSK

Encryption Mode2 : TKIP-AES

WPA Preferred Key Format : Password

WPA Pre-shared key : <set here a
password to
access WiFi>

Note : The above settings make the WLAN to
be accessed using the SSID and upon
accessing, password to be provided to connect.
Screenshots may vary according to the modem
/ router using for connecting but settings will
be there.

Fig 4

Fig 5

− − − − − − − − −
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TASK 2 : Filter access using Mac address

1 Open the web browser and address in the address bar
(default is http://192.168.0.1 or http://192.168.1.1).
Press Enter as in Fig 6.

2 Go to IP & MAC Binding->ARP List page, find the MAC
address of the all the devices which are connected to
the router as in Fig 7.

3 Go to Wireless->Wireless MAC Filtering page, click
the Add New button as in Fig 8.

4 Type in the MAC address you want to allow or deny to
access the router, and give a description for this item
as in Fig 9.

5 Choose Enable and Allow/Deny the Wireless MAC
Filtering function about the Filtering Rules as in
Fig 10.

Note : Allow enables the accessing of Mac
address into this connection and Deny
disallows to connect into.

Fig 6

Fig 7 Fig 10

Fig 9

Fig 8
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TASK 3 : Create individual user accounts

1 Goto Control Panel and select User Accounts as in
Fig 11.

2 Click Manage another account option to enter into Users
list option as in Fig 12.

3 Click on Add a new user to create a new windows user
as in Fig 13.

4 Click on Add someone else to the PC to add a new
user as in Fig 14.

5 Skip the email option in the next window by click as in
Fig 15 and click NEXT.

6 Click Add user without Microsoft Account to proceed a
custom named user as in Fig 16.

IT & ITES : COPA - (NSQF- 4 ) Exercise 2.5.140

Fig 14Fig 11
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Fig 13

Fig 15
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7 Type the username and password with three security
questions with answer for creating a new account as
in Fig 17.

8 Complete the user creation and the user will be
available for login as in Fig 18.

9 Click on the user name to change user type as Local
user / Administrator and for adding new users, repeat
same steps and get cleared with instructor.

Fig 17
Fig 18

− − − − − − − − −
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IT & ITES  Exercise 2.5.141
COPA - Cyber Security

Limit Member Access to Data and Information and Restrict Authority to Install
Unnecessary Downloads
Objectives : At the end of this lesson you shall be able to
• disable or restrict the use of Windows Installer via Local Group Policy Editor
• test the Windows Installer allows downloaded file to install or not
• disable Automatic Download In Google Chrome
• disable Downloads in Internet Explorer
• limit member access to a file in Windows.

PROCEDURE

TASK 1: Disable or restrict the use of Windows Installer via Local Group Policy Editor.

1 Type gpedit.msc in Start search (Fig 1) and Press
Enter Key.

Requirement
• Pc system with Windows OS and

Internet Connection

Fig 1

2  It opens the Group Policy Editor. (Fig 2)

Fig 2

3 In RHS Pane, double click on  Computer
Configurations. It displays the folders list (Fig 3).

Fig 3

4 Double click on Administrative Templates folder. It
displays the folders list (Fig 4).

Fig 4
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5 Double click on Windows Components. It displays
the folders list (Fig 5).

Fig 5

6 Double click on Windows Installer. It displays the
settings (Fig 6).

Fig 6

7 Double-click on Disable Windows Installer. It displays
Disable Windows Installer Window (Fig 7)

8 Select Enabled button  and Always option in the drop
down list (Fig 8).

Fig 8

9 Click on Apply and then Ok button.

Fig 7

TASK 2: Test the Windows Installer allows downloaded file to install or not
   − − − − − − −

1 Download the Free JavaScript editor.

2 Try to install it.

3 InstallShield wizard is display (Fig 9)

Fig 9

4 System Administrator prevents this installation
(Fig 10) as per Settings done in Task 1.

Fig 10
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TASK 3 :  Disable Automatic Download In Google Chrome

1 Goto your chrome settings by click settings icon and
goto settings. (Fig 11)

Fig 11

2 Here you can click to show advanced settings option
(Fig 12) and then locate downloads section.

3 Now you can tick to enable Ask where to save each
file (Fig 13) before downloading.

4 This prevents drive by downloads, and may also prevent
accidental downloads of files.

Task 4 :  Disable Downloads in Internet Explorer

1 Click on the Tools menu option located on the top
right side of the main toolbar. Click on “Internet Options”
from the drop-down menu that will appear on the screen.
(Fig 14)

− − − − − − − −

Fig 12

Fig 14

Fig 13
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2 Click on the Security tab on the top toolbar of the new
window that will pop up. Scroll down to the second
heading and then click on the button labeled as
Custom Level. (Fig 15)

 

Fig 15

3 Scroll down through the list of custom options and find
the Downloads section. Locate the File Download
tab and click on the Disable radio button. (Fig 16)

Fig 16

4 Click on the OK button. Close down the Internet
Explorer program and then re-start the computer to
save the changes.

Note : Log in as an administrator and navigate
back to the “Custom Level” area of the
“Internet Options” menu if you want to turn
the downloading feature back on. Click on the
“Reset” button and then click on “OK.” Re-start
the computer again to save the change.

TASK 5: Limit member access to a file in Windows.

 − − − − − − − −

1 Right click on the file  Cyber Security-1 to set the
permissions. It displays the Pop-up Menu. (Fig 17)

Fig 17

2 Select Properties. It displays Properties Window.
(Fig 18)

Fig 18
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3 Click on Security tab. Group or User Names and
Permission are displayed. (Fig 19)

Fig 19

4 Select the Group or User name  to set
permission.(Fig.19)

5  Click on Edit button to change permission.  Click on
Modify under Deny. It selects Modify, Read & execute,
Read and Write permissions. Click on Apply and OK.
(Fig 20)

Fig 20

6 Try to open the file Cyber Security-1.  Windows OS
will not allow the user to open the file and displays the
warning message. (Fig 21)

Fig 21

Note : User can deselect the options under Deny
in the Properties Window to reset the file
permission.

7 Choose the Folder/Drive and try to set permission using
steps 1 to 5 of Task 5.

IT & ITES : COPA - (NSQF- 4 ) Exercise 2.5.141
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